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1 - Client Issues

Client Failures

Client Closing Unexpectedly

Many Client failures and exceptions are caused by missing Microsoft updates.

An example is the message "Client is Closing Nuance.PowerScribe360.exe…". This 
issue occurs because of a known issue in Ole32.dll which is fixed with 
http://support.microsoft.com/kb/2541119. 

To address this cause, run and apply all current MS updates. NOTE: If you are on V
1.x, do not apply the .NET update 4.5 and above.

Editor Client Hangs/Crashes

Failure / Error When Playing Back Audio

The nssystem.ini file "Maximal amount of differences between two texts" limit value
for the workstation may be exceeded.

This is a workstation specific modification and will not follow the users profile. Be sure
that the PowerScribe 360 Client is closed before you modify the Maximal amount of
differences between two texts value. To change the value:

1. Edit the nssystem.ini file located at: 

C:\ProgramData\Nuance\Dragon SDK Client Edition12

2. Within the [Settings] section of the nssystem.ini file, add the following line if it
does not exist.

Maximal Amount of Difference Between Two texts=xxx

If this line is not in the nssystem.ini, the default value is 100. The xxx represents a limit
value based on the number of edits within the report. Adding the line modifies the
default vault. The performance to load the report is slower when the default value is
higher, but playback highlighting/concordance improves.

Increment the value by 200 until the desired playback is obtained. Do not exceed a
value of 600.

1. Go to the Control Panel > Sounds and Settings dialog.
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2. Ensure the Audio Mixer Device shows under Recording Devices as shown below:

3. If you do not see the device, righ-click and select Show Hidden Devices.

4. Right-click Rec Playback, and select Enable.

If the device does not show, even if hidden devices are shown, it means
the audio drive needs to be upgraded.
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Installation Issues

Install Wizard Interrupted

"The wizard was interrupted before Nuance Powerscribe 360 | Reporting - Client
could be completely installed. The system has not been modified. To install this
program at a later time, run the installation again." 

1. Check to make sure the Philips Speech Mike software is not running on the
workstation. Exit the Speech Mike application from Task bar and run the Client
install again. 

2. Check to make sure there is no Microsoft Office Application open on the
workstation. Close any Word documents, Outlook, Excel, etc. that are open and
run the Client install again. 

"Your system must be restarted due to another program install/uninstall" and you
have already restarted your system, that is because the system registry has a key that
needs to be deleted. 

1. Launch the Registry editor. 

2. Navigate to the following destination.

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\

Control\Session Manager 

3. Locate and delete the key named: PendingFileRenameOperations 

Copy the link below in your browser address bar to view an eTIPS video image 
for a brief demonstration on how to delete the registry key. 
http://healthcare1content.nuance.com/Video/eTIPS_2013/PowerScribe360/Wind
owsRestart/WindowsRestart.html
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Log-in Issues

Client Does Not Display

When attempting to launch the PowerScribe 360|Reporting Client, the Client does not
display, but appears on the task bar. Even when clicking the taskbar, the Client will not
display.

1. Go to Start>Run, and type in regedit. Hit enter. 

2. Rename the HKCU\Software\Nuance\PowerScribe360 folder. This will 
regenerate automatically.

PACS Error

When launching the Client in standalone or integrated, PowerScribe 360 displays an 
error message:

"An error occurred initializing PACS. Please notify support. Invalid parameter 
specified for the log file path or logging level." 

This is caused by Windows 7 PCs having the wrong TEMP and TMP user 
environmental variables (check: Start > Run >%temp%). 

To fix the error, update the environmental variables:

Right-click Computer > Properties > Advanced System Settings > Environment 
Variables and change the User Environment Variables for Temp and TMP from 
%USERPROFILE%\Local Settings\Temp to 
%USERPROFILE%\AppData\Local\Temp.

Slowness Logging In

Error / delays when logging into Client may be due to internet access not available for
the user logged in. When the Client launches it goes to the internet to check the
certificate revocation list. This is a security feature in IE when the local machine has an
outdated list. Disabling the revocation check in production environments isn't
recommended. Certificate revocation checking protects your clients against the use of
invalid server authentication certificates either because they have expired or because
they were revoked (e.g., when a server certificate was compromised).

1. To get the updated list you can download it from Microsoft at
http://support.microsoft.com/kb/2677070 
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2. As an alternate, your site IT can disable certificate revocation check in IE. Starting
with IE 7.0, server certificate revocation checkin is enabled by default. You can
disable this feature by clicking Internet Options on the Tools menu, selecting the
Advanced Tab, and clearing the Check for server certificate revocation check box,
as shown below. You need to restart IE in order for this setting to take effect. 

Error Loading Speech Files

When logging in, the Client fails during the Speech profile download process.
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You should review the Dragon log and look for the following:

09:05:26.536 Roaming: RoamingInternetCopySOptionsIni can't copy soptions ini file
from http://AASJCSTLV398SQL/DragonUsers/luckt/current/soptions.ini to
C:\Users\luckt\AppData\Local\Temp\dra1838\current\soptions.ini error = 151 Server
return =404 Not Found

09:05:26.781 Roaming Error: Can't copy options.ini file down from network
luckt\current\soptions.ini to C:\ProgramData\Nuance\Dragon SDK Client
Edition12\RoamingUsers\Default Server\Location_1\luckt\current\soptions.ini in
RoamingInternetAcousticNew error = 151 Server return =404 Not Found

The cause of this issue is that the Mime Type is missing from the IIS configuration. To
resolve, go to the server and add the mime type as shown below.

Time Out When Logging In through GE ImageCast

When PowerScribe 360 | Reporting is integrated with GE ImageCast 10.8 update 3 or
earlier, a GE ImageCast Timeout error can occur. Timeout for launching Report
Creation System expired. Dictation session will be terminated. 

To resolve, the client needs to upgrade to a more recent version of GE.
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Receiving the Audio Wizard Setup Prompt

Each Dragon Medical profile can retain audio settings for ten (10) computer and input
device combinations.

Once a specific user roams and attempts to open the eleventh (11th) combination, a
previous combination will be overwritten. When that overwritten combination is next
accessed by the user, Dragon considers this to be a new combination and will therefore
prompt to complete ASW again.

There is a workaround to increase the default number of audio setting combinations
supported by Dragon. This can be increased through manually editing the nssystem.ini
file in the following steps:

1. Locate and make a backup copy of the nssystem.ini file 
(default location: C:\Documents and Settings\All Users\Application 
Data\Nuance\NaturallySpeaking10). 

2. Open nssystem.ini with any text editor (i.e. Notepad). 

3. Navigate to the last entry of the [Settings] section. 

4. Add the following line:

Number of Audio Settings= 

For example: Number of Audio Settings=15 

5. Save the file, and then re-launch Dragon Medical.
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Queue Empty Error Messages Crashing the Client

To resolve this error, you must edit the Nuance.PowerScribe360.exe.config file and
republish the client.

1. On the Web server, launch the Client Admin, and note the Publication Source 
Path.

2. Open the directory to the Application 
Files\Nuance.PowerScribe360_X_X_XX_X folder (if there are multiple, use the 
highest numbered). 



PN 889672 July 24, 2015 1-9

3. Find and open the Nuance.PowerScribe360.exe.config file: 

4. Add the following line to the end of the appSettings section:

<add key="SendKeys" value="SendInput"/> 

5. Save the changes and return to the Client Admin. 
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6. Note the Publication Version. 

7. Click Generate. 

8. On the prompt, click Yes. 

9. Click Edit to confirm the RAS address. 

10. Click OK and OK again to begin republishing the Client. 

11. Once complete, click Regenerate so that the Publication version is one number
higher than it was previously (IE, 5.5.33.1 to 5.5.33.2). 

Failure to regenerate the publication version number may cause issues
launching the client and existing clients will not be updated with the new
settings.
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DGNERR_ROAMING_SUCCESS_WARN_VOC_DELTA_FULL Error

When users are experiencing 
DGNERR_ROAMING_SUCCESS_WARN_VOC_DELTA_FULL errors, it means 
that they’ve made multiple vocabulary changes, but those changes have not been 
permanently applied to their profile yet.

This data is typically applied to the profile via ACO/LMO. However, if the user is not 
or cannot save speech files, you will see this error.

To resolve:

1. Get on a server or workstation with Dragon installed. 

2. If not on the web server, create a mapped drive to the 
\\PowerScribe360Server\DragonUsers directory.

3. In your DragonUsers folder, open the folder matching the user’s username, then
the current folder and open the topics.ini file. 

4. Under the [Topics] row, you will find a string of text, typically US English | Large
| PS360 Radiology=US_Engli, but it may vary depending on the site. 

5. Highlight and copy that line, all the way to the just before the equals sign, (IE US
English | Large | PS360 Radiology) 

6. In your start menu, under Programs, find Dragon SDK Client Edition 
10.2>Dragon SDK Client Tools and select VocDelta Merge Tool. 

7. In the CMD window, type mergevocdelta -username="Z:\Username" 
-topicname="US English | Large | PS360 Radiology" using the appropriate 
username and topic values.
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Client Latency

In some cases, performance or latency issues are caused by profiles. This is possible,
but should not be assumed. Confirm this by troubleshooting in a logical manner.

Bloated Profiles

A word of warning: Never disable ACO or LMO and do not disable the standard profile
settings. These settings and ACO / LMO allow the system to properly clean up after
itself, while improving speech recognition.

On systems that are V1.x and 2.x where the Dragon AND SUS is not updated, profiles
could grow too large on the server and prevent the local cache from uploading and
being removed from the local workstation.

On these systems you should do the following:

1. Run the profile clean up tool against the users profile on the server. (If you are
able to, you should run it against all users to be proactive).

2. Have the user log in, and select Speech > Save Speech Files.

3. Re-run the speech profile clean up against the users profile again, to trim it up, and
allow SUS to run.

4. If the user is a large Volume reader and speaks most of the reports, you should set
the user to run ACO more often, for example every 2 or 3 days. This will allow
the user to successfully upload data from other workstations.

Even if the system is version 2.x with an updated Dragon and SUS, if the user dictates
more than they use AutoTexts, they could create a large local cache and after one
session upload, the server profile is too large to accept more uploads.

On these systems you should do the following:

1. Run the profile clean up tool against the users profile on the server. (If you are
able to, you should run it against all users to be proactive).

2. Have the user log in, and select Speech > Save Speech Files.

3. Set the user to run ACO every 2 or 3 days.

Verify Client Setting

Sometimes Client settings can cause issues. A common one is the user has enabled auto
saving of the profile every X report saves. This cause's severe latency as the system is
trying to upload the profile to the server while the user is trying to read reports.
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Under the user's options (below) Check the box to indicate "Don't backup user profile".
Note the setting above it, where if left unchecked it would save the profile after every
5 reports saved / completed.

Resetting Client UI State

Important notes about resetting the Client state:
 Resetting the Client state can be done with little to no effect on users and is often

easier than coordinating any changes with users. 
 Depending on the system and user volume, a single system can have thousands

of AutoText templates. The AutoText filter, when set for All Users, can have an
effect on how quickly a report opens. Resetting the Client UI state can reset this
for the user to the default filter of Relevant AutoTexts.
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To reset the Client UI, with the user logged out of the Client:
1. From RadPortal > Setup > Accounts > User > Preferences, select Reset UI State

at the top of the web page: Performance Logging. 
Performance logging will provide information needed to identify calls that take
too long, if any.

Agfa Integrations Performing Slow

NConsole is the integration component from Agfa, like PACSBridge was in PS5 or
VDI for Cerner RIS. 
By default, the Agfa installation sets the log levels to Error > Debug > Debug. We
found this causes a noticeable delay in PowerScribe 360. 
The log levels can be changed by right-clicking on the NConsole icon in the system
tray, then select Log Levels.
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Logging

If the above actions do not address the issue, you will need to generate and collect logs
for development to assist in addressing the issues. 

Performance Logging

When the complaint is slow performance of hangs when signing or closing a report,
performance logging will provide you and development the information needed to ID
what calls are taking too long, if any.

Enabling Performance Logging

Use the following to enable Performance Logging for systems V3.0.x and higher or
V2.5.x and lower:

Performance Logging for V3.0.x and Higher

Application logging can be enabled on a user or system level in RadPortal.

To enable application logging:

1. Log in to the Radport. 

2. From Preferences, select Security. 

3. Uncheck Disabled and check Report Workflow, Performance, and RAS
logging.
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WARNING: This logging can impact performance. Enable the Report
Workflow, Performance, and RAS options only. Only enable more at
development request

Enabling Performance Logging for V2.5.x and Lower

You must log in with administrative privileges to alter the registry of the Client
Workstation.

Paths and values are case-sensitive!

1. Create the following folder: C:\Nuance\PowerScribe360\PerfLogs. 

2. Create a Windows Registry Script File for Performance Logging:

a. Open a new Notepad file on the desktop. 

b. Copy the following script, including the header into the Notepad file.

Windows Registry Editor Version 5.00 

[HKEY_LOCAL_MACHINE\SOFTWARE\Nuance\PowerScribe360Perf] 

"EnablePerformance"="True" 

"DaysToKeepPerformanceLogs"="10" 

"PerformanceLog"="C:\Nuance\PowerScribe360\PerfLogs"

If enabling on a 64-bit workstation, add the following registry entries:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Nuance 

c. From File, select Save As and enter PS360PerformanceLog.reg as the file
name, and select All Files as the Save as type. 

d. Click Save to save the file on the desktop. A PS360PerformanceLog icon
displays on the desktop. 

3. Double-click the PS360PerformanceLog icon on the Desktop. 

4. Click Yes when the Registry Editor prompts to add the information to the Registry.      

IMPORTANT
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Enabling Additional Client Logging

Additional application logging can be enabled for a user or at the system level. 

To enable additional Client logging for V2.x and lower:

1. From RadPortal, select Preferences and Security. 

2. Uncheck Disabled and then select the required logging. 

WARNING: This logging can impact performance. Enable the Report
Workflow option only. Only enable more at development request.

Obtaining Client Logs

With Performance logging enabled, have the user replicate the issue to generate logs.

For the Client version, retrieve the:

 V2.5 and higher logs from Help > Upload Logs menu. 

 Lower than V2.5 logs manually from: 

 Location: C:\Nuance\PowerScribe360\PerfLogs 

 Filename: PS360PERF + MMddyyHHmmss + MachineName + .log 

 V1.x through V2.0.x logs manually from: 

 %temp% folder. 

 PACS integration logs (Vary depending on integration) 

 RadWhereCOM Logs 

 Dragon logs in %appdata%\Nuance\Dragon SDK Client Edition12 

 Dragon.log 

 Dragon.bak.log 

 PowerScribe 360 Performance Logs 

 Location: C:\Nuance\PowerScribe360\PerfLogs 

 Filename: PS360PERF + MMddyyHHmmss + MachineName + .log. 

IMPORTANT
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Interpreting the Logs

To interpret the log files, you must understand the PowerScribe 360 Client Report life
cycle. The following illustrates the normal report open and close events that occur:

From the Web Server Communication/Explorer screen, the API or XML integration
Event and then the API Integration Event (Report Open) occurs at the start of the report
open event.

Opened reports are saved by the API Integration Report Pending Status event or Final
Report Status event.

Reviewing Logs

The PowerScribe 360 Client Log Parser is available on the DML to download and use
to view the log files.

Run the PowerScribe 360 Client Log Parser and open the folder containing the log files
you collected.

Performance Logs

Performance logs provide summary data, explaining how long each action took to
complete.

TimeTaken shows how long each action took to complete. This would include
communicating with the PowerScribe 360 web server and waiting on user input. 
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TimeAccounted demonstrates how much time is taken on communicating with the
PowerScribe 360 web server:

 If the TimeAccounted vs TimeTaken is high, select the Highlight RAS Logs
option. 

 If it is low, select the Highlight App Logs section. 

RAS Logs

RAS logs are available in V3.0 and higher exclusively. These logs provide details about
each call made to the PowerScribe 360 web server, including TimeTaken. 

If the time taken of a RAS call is high, it means that there was a delay with the Client
receiving data back from the web server. Next, identify WHERE that delay is
occurring. Some possibilities: 

 Network performance 

 Proxy server performance 

 SQL performance 

 Server performance 

 Workstation performance 
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App Logs 

Application logs provide details about what is occurring within the application itself. 

Report Workflow application logs can be very helpful in identifying a variety of issues,
including a local profile that has NOT been saved in some time.

For example (see above), the SaveSessionForOptimization method, which is the
speech data generated and saved as part of the voice profile for ACO/LMO, takes 4
seconds to complete. This would be 4 seconds added onto the Client signing process.

To ensure this is related to the local profile size on the workstation, and not I/O or A/V,
review the Dragon log as well. If the issue is related to profile size, you should see lines
like the following:

07:49:17.300 (Optimizer): ACO: Info: (FIFO) Queue size (XXXXXXXXX  bytes)
exceeds the requested DRA limit (167772160 bytes) by XXXXX bytes

If the above steps and recommendations have not provided a resolution,

you should ensure you have logs and consult with a Product Specialist.

Process Monitor

These steps capture the File, Registry, and Process/Thread activity using the
Sysinternals Process Monitor to capture latency during dictation, sign on/off, or
starting/ending reports. 

Running Process Monitor

1. Double-click Launch Process Monitor (procmon.exe). 

2. Verify the Process Monitor is set to capture data; this should be the default. 
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To determine if the Process Monitor is collecting data: 

a. Uncheck registry and network activity icons to filter out extra processes

b. Toggle the Capture button if it has a red X. 

c. Check that events are being captured by viewing status information in the
lower left corner of Process Monitor. If the tool is capturing data, the numbers
displayed as "Showing 'X' of 'Y' events" will be incrementing upward. 

3. Stop Process Monitor capture activity by clicking on the Capture button to now
display with a red X. 

4. From the File menu, select Save. 

5. Leave the Events to Save and Format as the default settings.

6. Specify a location to save the output file. 
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Reading Process Monitor Logs

To begin reading the data, set the filters in Process Monitor. 

1. From the toolbar, click Filter. 

Filters to Add:

2. With the results now filtered, mouse over the process name to get details on the
process, and review the specific path of the file being touched by the process. 

All workstations are different, and therefore all results will be different. 

3. Specifically note if there are any non-Windows related processes accessing files
or folders from the A/V and DLP exclusion list from KB 16484.

IE, McShield.exe (McAfee A/V process) accessing files in the 
C:\ProgramData\Nuance folder or subfolder or within the 
C:\Users\<username>\AppData\Roaming\Nuance\Dragon SDK Client 
EditionX\results folder.

4. If you see non-Windows related processing files or folderds from the A/V and
DPL exclusion list, A/V exclusions have NOT been set or are not being honored
properly. 

5. If the issue seems to be XML integration related, in the Filters list above, instead
of Path Contains Dragon, change it to Path Contains XMLFilePath (C:\Nuance for
instance).

What Process Monitor cannot confirm is whether the natspeak.exe process is being
scanned within memory itself.

Column Relation Value Action
Path Contains Dragon Include
Process Name is Nuance.PowerScribe360.exe Exclude
Process Name is dgnuiasvr.exe Exclude
Process Name is dgnuiasvr_x64.exe Exclude
Process Name is natspeak.exe Exclude
Process Name is vcmd.exe Exclude
Process Name is svchost.exe Exclude
Process Name is consent.exe Exclude
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Fiddler

When calls are taking too long for each of the Application servers, analyzing the
network communications from the Client to server can help. The Fiddler logs can help
you identify if the latency is related to communications to the application server.

If the site is SSL, Fiddler logs will not provide data as the SSL will encrypt everything.

1. Download the Fiddler Installer: Download the full version of Fiddler. For web
traffic capture only, download FiddlerCap. 

2. Run the Fiddler Installer: 

a. Select Run from any Security Warning dialog. 

The Fiddler Setup: License Agreement dialog displays. 

b. Click I Agree. 

http://www.telerik.com/download/fiddler
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The Fiddler Setup: Installation Folder dialog displays. 

c. Click Install. 

The Fiddler Setup: Completed dialog displays. 

d. Click Close. 

Customizing Columns to Adjust Data Captured

1. From Start, select Fiddler2. 

2. Right-click in the column heading section, and select Customize Columns. 

The Customize Columns dialog displays. 

3. From Collection list, select Session Timers. 

4. From Timer Name list, select Overall_Elapsed. 



PN 889672 July 24, 2015 1-25

5. In the Column Title box, type Overall_Elapsed. 

Adding columns lets you capture the web service calls and the overall elapsed
time.

6. From the File menu, click Save and select All Sessions.

Reading Fiddler Logs

Review the Overall_Elapsed column once the issue has been replicated. Similar to
reviewing the RAS logs above.

If the overall elapsed of a web call is high, it means that there was a delay with the
Client receiving data back from the web server. Identify WHERE that delay is
occurring. Some possibilities:

 Network performance 

 Proxy server performance 

 SQL performance 

 Server performance 

 Workstation performance 
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2 - Recognition Issues
Recognition issues are not necessarily related to the dictator's profile. To properly
address reports of degraded accuracy or inadequate accuracy, follow the
recommendations below.

Never delete a user's profile to address recognition issues unless 

instructed to do by a Developer or a Manager.

Best Practices for Speech Recognition

To achieve the best results with PowerScribe® 360 | Reporting speech recognition, use
the best practice guidelines shown in resource documents below:

 PSA027 — Best Practices for Speech Recognition V2.0 and Higher

 P36A038 — How to Handle Misrecognitions 

For more information about working with the Vocabulary Editor and Auto Formatting
Rules, login to iSupport and search for Solution #14686: PowerScribe 360 | Report
User Documentation for the latest System Administrator Guide and navigate to the
chapter on Provider Training - Intermediate and Advanced and Auto Formatting
Rules.

For more information about best practices for speech recognition, login to iSupport and
search for Solution #14686: PowerScribe® 360 | Reporting User Documentation
for the latest Best Practices Speech Recognition document.

IMPORTANT

https://isupportcontent.nuance.com/healthcare/documents/ats/resource/p36/P36A027.pdf
https://oracle.nuance.com/OA_HTML/OA.jsp?page=/oracle/apps/cs/knowledge/solution/search/webui/SolViewPG&OAFunc=CS_KB_SMS_SOLN_VIEWSOL2_FN&retainAM=Y&addBreadCrumb=RP&cskSolNum=14686
https://oracle.nuance.com/OA_HTML/OA.jsp?page=/oracle/apps/cs/knowledge/solution/search/webui/SolViewPG&OAFunc=CS_KB_SMS_SOLN_VIEWSOL2_FN&retainAM=Y&addBreadCrumb=RP&cskSolNum=14686
https://isupportcontent.nuance.com/healthcare/documents/ats/resource/p36/p36a038.pdf
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First Steps

Adjusting Speed vs Accuracy Setting

Before trying to fix mis-recognized words or phrases, make sure the system and client
are set for maximum recognition.

Set the Dragon maximum compute speed in the RadPortal, System, Configuration,
PowerScribe 360 Client tab to the highest level you can (Usually 70).

Adjust the users Speed v Accuracy setting to the same value you set in the RadPortal.

Once you have done this, dictate a report and validate if your level of recognition has
improved.

Validating Dragon Version

Before trying to fix mis-recognized words or phrases, make sure the Dragon version is
updated to the versions indicated below. This is due to prior versions having a defect
where the microphone Gain was not properly set and maintained.

 V 1.0 to V 1.5.1 - No update for Dragon. 

 V1.5.2 - Update to DNS 10.20.104.301 

 V2.0 to 2.5.1 - Update DNS to 12.52.150.032 or higher

Adjusting Microphone Recording Level

The process below is not standard. This should be used for those who have recognition
issues even after they have exhausted all standard practices.

Before trying to fix mis-recognized words or phrases, make sure the system is
recording your dictated content at an optimal recording level. If you rewind and play
back a portion of your dictation and the volume is low or the recording indicator, found
on the bottom right of the PowerScribe® 360 | Reporting Client application, is not
maintaining green and peaking to red often, then run the Audio Setup wizard to
improve the recording level.

Perform the following to run the Audio Setup Wizard in an efficient manner:

1. Log in to the PowerScribe® 360 | Reporting client application. 

2. On the Menu bar, click Speech > Audio Setup. 

3. When the Check Microphone dialog appears, read the content and then click Next.
The Dragon will adjust your volume dialog will appear, shown below. 

4. Click Start Volume Check and do not say anything. 
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5. When you hear the beep or ding, click Next to continue to the Dragon will test the
quality of your sound system dialog, shown below. 

6. Click the Start Quality Check, and dictate the content found in the text box above
it. 

The system will "ding" and then show "passed" in the black box. At this point,
click Finish to save your setting and exit.

Once you have done this, dictate a report and validate if your level of recognition
has improved.

Vocabulary Editor

In the PowerScribe® 360 | Reporting Dictation Client, the radiologist can use the
Vocabulary Editor to view the full set of words included in the speech vocabulary,
trained words, and set various properties. The Vocabulary Editor provides access to the
written form and spoken form (if different) of all words in the speech vocabulary.

Adding a Spoken Form to a Word or Phrase

1. From Menu, select Speech > Vocabulary Editor.

2. Type the word or phrase into the Written form box.

3. Find the word or phrase in the list, and highlight it.

4. In the Spoken Form box, type a number of short words representing how you
speak the word. Here is an example for tomato. Some say "ta mate oh", others say
"to mot oh" 

5. Click the Add. 

The word(s) may appear twice in the list. Do not delete any copies.

6. Click Close to exit the Vocabulary Editor. 

You may also have to train the word as well as adding a spoken for. Be
sure to remove all duplicate entries for any word you add a spoken form
or train. Leaving multiple entries will negate any improvement.
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Reference Aids for Dictator and Admins

Provide the client the two URL's below. These websites provide the dictator and the
administrator with proven methods to address common recognition issue not addressed
by the steps above.

 Configuring PowerScribe® 360 | Reporting to Better Enable Radiologists to
Improve Speech Recognition Accuracy

<https://isupportcontent.nuance.com/healthcare/16500/16518/PS360R-Admin-Proced
ures-to-Improve-Recognition-20150713.html>

 How to Improve Speech Recognition Accuracy and Fix Misrecognized
Words and Phrases in PowerScribe® 360 | Reporting

<https://isupportcontent.nuance.com/healthcare/16500/16518/PS360R-Fixing-Misrec
ognized-Words.html>

If all the above has not resolved the recognition complaints, you should escalate this
issue to a product specialist for assistance.

Deleting a User's Dragon Profile

Deleting a profile is a last resort when addressing recognition issues.

There are two selections in the Admin Portal to reset a user's profile. There are major
differences which need to be considered when resetting a user to re-read training.

The Rest Acoustics and Retrain option does not set the user back to the initial starting
point. This option sets the acoustic profile back to factory (ACO), but keeps all the
information (Trained words, learned pronunciations, etc.) (LMO). Essentially if the
user's language model is really poor, and the user is getting very poor recognition, it
will be unlikely that the user's recognition will improve greatly. This option should not
be used to address very poor recognition of a converted profile. The fact that it still
contains the bad information may result in garbage-in, garbage-out.

The Delete Profile option will drop the Dragon profile and when the user logs back in,
and the user will have to re-train. The difference in this case, is the AutoTexts, auto
corrects, and custom words added by the Admin are NOT lost, and are maintained as
they are stored in the DB / application, not in Dragon.

https://isupportcontent.nuance.com/healthcare/16500/16518/PS360R-Admin-Procedures-to-Improve-Recognition-20150713.html
https://isupportcontent.nuance.com/healthcare/16500/16518/PS360R-Fixing-Misrecognized-Words.html
https://isupportcontent.nuance.com/healthcare/16500/16518/PS360R-Fixing-Misrecognized-Words.html
https://isupportcontent.nuance.com/healthcare/16500/16518/PS360R-Fixing-Misrecognized-Words.html
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If a user has very poor recognition (observed, not just reported), and the profile was
converted from Dragon 10 to Dragon 12, it is recommended that you:

1. Log the user out of PowerScribe® 360 | Reporting. 

2. On the server, locate the user's profile folder in DragonUsers directory. 

3. Zip up the folder and store in a separate location. 

4. From the Portal, go to the user’s profile and select Delete Profile. 

5. Log the user in, and then have the user re-read the training screens.
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Advanced Dragon Logging

In order to send a recognition issue to development, the Dragon log must have NBest
logging enabled. This logging is workstation specific. 

To enable NBest logging:

1. Locate the natspeak.ini file at C:\ProgramData\Nuance\Dragon SDK Client
Edition10 (Dragon SDK Client Edition 12 if 2.x or higher)

2. Right-click the file and select Edit.

3. Add in the lines:

[Tracing] 

NBest-Choices=1

4. Save the changes.
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3 - ACO/LMO Failures

ACO / LMO Process

Profile management is an important part of making the dictators and the site successful
using PowerScribe® 360 | Reporting.

As users dictate throughout the day, for each report, a DRA file generates. DRA files
are stored on the user workstation until the user saves their speech files to the server.
These DRA files are necessary for Optimization jobs (ACO/LMO) to run successfully. 

If a user trained a word today on a workstation and moves to a different workstation
before the nightly LMO runs, the trained word(s) do not follow the user. Once the LMO
runs, the trained word will be available system wide. Only DRA files that contain 30
seconds of audio and 2 voice corrections will input to the ACO process.

Keyboard edits are currently not included in corrections for adaptation (ACO).
Therefore, if a provider or an editor uses the keyboard to edit mis-recognition errors,
the mis-recognition errors will not be used for ACO.

Dragon Speech Profiles are stored on the web server at:
X:\Nuance\DragonUsers. This is also a shared folder \\<webserver>\DragonUsers. 

There are two methods for the locally saved profile data to get to the server.

1. Users can save their speech data manually, from Speech > Save Speech Files in
the Client, or when the user logs off of the Client, depending on preferences.

2. Users must complete the logoff for speech files to upload. If the user leaves their
sessions open and lets the inactivity timer log to time-out, the user speech files will
not be saved.

Profile sizes can vary. Larger profiles do not necessarily cause latency. PACS systems
typically control the logging out of the PowerScribe® 360 | Reporting Client; however,
the specific log out method should be verified with the PACS vendor.

When logging out of the Client, the application will perform a check of the size of the
profile stored on the server. If the profile is greater than 500 MB, data will NOT be
copied form the workstation to the server. During this time, the user will see a dialog,
Saving Speech Files, for about 10 seconds.

If the application determines the server profile is less than 500 MB, the application will
create a new session folder on the server and upload the profile data from the
workstation. It will then delete the profile data from the workstation.

If it is noted that a user's profile goes through ACO (ACO analyzes a provider
speech/acoustic patterns and applies this analysis to the acoustic model.) as scheduled,
but the data keeps building up on the workstation, the site Admin should change the
frequency of ACO for that user to be more often. For example, every 2 or 3 days. This
will allow ACO to run more often, therefore trimming the profile more often and
allowing the user to upload data from the workstations more effectively.
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This should not be done for the entire site, but only for dictators who
read a great deal of reports per day.

Never delete a profile to “address” profile issues. Deleting a profile
should only be performed when instructed to do so by Development or
a Manager.
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Validate the SUS/Dragon Version

Due to some defects in earlier SUS versions, some profiles may grow too large to
process. Before troubleshooting why profiles are not processing, you should validate
that the SUS version has been updated to provide optimal processing ability. 

In version 1.x through 1.5.x, the Client should be on SUS V 116. If not, you should
update the SUS version. If the site is on this version, you should run the DNS Profile
Clean-up Utility on a regular basis to keep profiles trimmed. This should only be a stop
gap measure until the site can update to V2 or higher.

If the site is at version 2.0 and higher, the SUS should be updated to version 2.5.0.36
or higher. This release has the Profile Clean up utility built in.

If the site is on V3, you should verify the SUS is version 3.0.0.2.
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Validate the User Account Settings

By reviewing the users account, you can validate if ACO and LMO is processing. If
ACO/LMO ran within the last 2 weeks, there is generally not an issue with profile
processing.

If a user is not processing through ACO or LMO you should:

1. Verify the following system and user settings are set to save data and upload the
profile data at the end of the session. 

2. From the Dictation tab, check these settings: 

 Prompt to save speech files is set to Always Save. 

 Enable Dragon data collection is checked. 

If the user is complaining about recognition, refer to the section on Recognition Issues.
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Verify the User Completed ACO / LMO

Verify that the user is processing through ACO / LMO.
T

Checking ACO / LMO Logs

ACO / LMO Logs

If the ACO and LMO is not processing, check the logs to determine the cause.

If you see the user has not processed ACO / LMO in the past 2 weeks, but has logged
in and used the system in that time period, you should see if the ACO or LMO failed.

You can confirm the functionality from the RadPortal > Logs > ACO/LMO page. The
ACO/LMO page displays individual SUS jobs with a recent date.
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Jobs with "Profile folder is not available" in the Additional info field
only indicates users are scheduled in ACO/LMO but have not yet trained
their voice profile. This message is removed in V3 and up.

Reviewing Exception / Failure Messages

1. If you find a profile that is still failing ACO or LMO, after running the Speech
Profile Remediation Utility, review the stack trace to determine the cause.

All exceptions are logged to RadPortal. Jobs may be completing successfully, but
finishing with a state of 5 (Not Enough Data), which do NOT show in RadPortal.
Exceptions are also logged to the Windows Event Viewer. 

If the above steps and recommendations have not provided a resolution,
you should ensure you have logs, and consult with a Product Specialist.

SUS Logs

 Exceptions are logged to RadPortal. All jobs that run aren’t. Jobs may be
completing successfully, but finishing with a state of 5 (Not Enough Data),
which do NOT show in RadPortal.

 Location for SUS log files:

 Server 2008 and 2012 – C:\Nuance\Logs

- Spark Core Services

* SPARKServicesLog.txt

- Spark Host Manager Service

* HostMgrLog.txt

- Spark Speech Node Manager
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* SUSClientLog.txt

* SUSNodeMgrLog.txt

- Speech Utility Server

* SUSServiceLog.txt

 Log location is specified during the install and can vary. They are usually under
the folders in the X:\Nuance directory.

 Exceptions are also logged to the Windows Event Viewer.

 Log File Naming convention for SUClient.log and Dragon.log for individual
SUS jobs.  These files are located in the C:\Nuance\Jobs\ directory: 

 8(30)_nwhite_1_workernode.log.zip

8 – JobID from Job Table in Spark DB

30 – Retry Number (jobs are repeated when there is not enough data)

Nwhite – Username

1 – Job Type. Can be 1 for ACO, 2 for LMO

Workernode – Log Type. Will be Dragon or Workernode.
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Trimming Bloated Profiles

A word of warning: Never disable ACO or LMO and do not disable the standard profile
settings. These settings and ACO / LMO allow the system to properly clean up after
itself, while improving speech recognition.

On systems that are V1.x and 2.x where the Dragon AND SUS is not updated, profiles
could grow too large on the server and prevent the local cache from uploading and
being removed from the local workstation.

On these systems you should do the following:

1. Run the profile clean up tool against the users profile on the server. (If you are
able to, you should run it against all users to be proactive).

2. Have the user log in, and select Speech > Save Speech Files.

3. Re-run the speech profile clean up against the users profile again, to trim it up, and
allow SUS to run.

4. If the user is a large Volume reader and speaks most of the reports, you should set
the user to run ACO more often, for example every 2 or 3 days. This will allow
the user to successfully upload data from other workstations.

Even if the system is version 2.x with an updated Dragon and SUS, if the user dictates
more than they use AutoTexts, they could create a large local cache and after one
session upload, the server profile is too large to accept more uploads.

On these systems you should do the following:

1. Run the profile clean up tool against the users profile on the server. (If you are
able to, you should run it against all users to be proactive).

2. Have the user log in, and select Speech > Save Speech Files.Set the user to run
ACO every 2 or 3 days.
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4 - PX2008 HL7 Interface Issues

Restart the Service

Your first priority is to get the HL7 stream operating. However, you should not stop
there. The cause of the outage should be investigated and a permanent resolution
applied. First, restart the RadBridge.

Restarting RadBridge

1. Login to the Web server, and open Services. 

2. Right-click the Nuance Web Bridge service, and select Stop. 

3. Once the service has stopped, right-click Nuance Web Bridge service again, and
select Start. 

To verify that the interface is up and connected, go to the desktop on the
interface server, view the Px2008 Monitor and verify that you have
either green lights (connected) or yellow lights (listening) on the left
side of the window. If the Px2008 Monitor is not launched, double click
the PX2008 Monitor icon. If you do not have green or yellow lights, you
may need to restart the PX2008 to connect.

Restarting PX2008

1. Login to the Interface server and open Services.

2. Right-click the PX2008 service, and select Stop.

IMPORTANT
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3. Once the service has stopped, right-click PX2008 service, and select Start.

Some of the PX2008 engines flash all red lights when they are updating.

To verify that the interface is up and connected, go to the desktop on the
interface server, view the Px2008 Monitor and verify that you have
either green lights (connected) or yellow lights (listening) on the left
side of the window. If the Px2008 Monitor is not launched, double click
the PX2008 Monitor icon. If you do not have green or yellow lights, you
may need to restart the PX2008 service to connect.

Verify the PX2008 Version

When troubleshooting PX2008 issues such as port disconnects, it is important to verify
the version of PX2008 installed. Versions prior to Px2008_v5.0.5641.24770 had issues
with port disconnects. Be sure you inform the client that the users will not be impacted,
and the only system impact will be a 15 min interruption of the HL7 stream.

To verify the version, click on the Version menu selection in the PX2008 monitor. If the
PX is not at Px2008_v5.0.5641.24770 or higher, you should work with the client to
have the PX updated. The instructions to update PX are included in the installation
manual, and can be performed by all support engineers.
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Determine the Cause of the Failure

Monitoring Traffic To and From PX

In cases where you see  repeated connects and disconnects to PX2008, or you are not
sure if the RIS or RadBridge are connecting to PX you can monitor traffic and
connections

1. Open the PX Monitor application.

2. Select TcpView.

3. Observe what servers are communicating with PX and what connections are being
made.

Supported ADT Message Types

Sometimes messages are not processed or rejected due to incompatibility

The following is a list of ADT event types that are recognized by the PowerScribe®
360 | Reporting HL7 RadBridge. All others event types are rejected.
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Message Acknowledgements (ACK's)

Acknowledgements are used to confirm the receipt of the message. Acknowledgements
are implemented at two levels transport level and application level. The sending system
will assume that the message sent by is not received until it receives an ACK from the
receiver.

Sending systems open a connection to send messages to the receiving messages, mostly
through the interface engine which acts as the broker for communications between
different systems in a healthcare setup. If a message is acknowledged on the same
connection which is used to send a message, they are termed as transport level
acknowledgements.

Transport Level Acknowledgements also indicate that the ownership of the message is
passed to the receiving system after it has received an acknowledgment. The transport
level acknowledgement also informs the transport and reception error.

If a message is received and accepted by the receiver then it sends a ACK and performs
one of the following:

1. Validates and persists the message successfully, generating the functional 
response message with a value of AA (Application Accept) in 
MSA-1-acknowledgment code field.

2. Send an error response, providing error information in functional segments to be
included in the response message with a value of AE (Application Error) in
MSA-1-acknowledgment code field.

A failure to process (reject) the message for reasons unrelated to its content or format
(system down, internal error, etc.). For most such problems, it is likely that the
receiving system will be able to accept the same message at a later time. The sending
system must decide on an application-specific basis whether the message should be
automatically sent again. The response message contains a value of AR (Application
Reject) in MSA-1-acknowledgment code.
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PX2008 Logs

You can view the actual HL7 messages crossing through PX2008 by looking at the log
files. The general path to find these log files is C:\PowerExpress2008\Logs. Keep in
mind every customer site might have the logs on a different drive. The HL7Socket
folder holds the log files for inbound orders and the PowerScribe folder holds the log
files outbound reports.

How to Populate a Custom Field via HL7 Feed 
(Orders)

The ability to send data to the custom fields is prebuilt into PowerScribe® 360 |
Reporting and does not need Nuance Support involvement.

The RIS / HIS team should send the data to PowerScribe 360 in an OBX CE (custom
element) segment as part of the order, to populate the custom field.

The format should be as follows:

OBX|1|CE|CTLE1^CT LOWER EXT WO CONTRAST||AOI^AREA OF INTEREST|

OBX|2|CE|CTLE1^CT LOWER EXT WO CONTRAST||ICD9^454

If the client's RIS team cannot send CE segments, use the Mapping change process for
a billable mapping change.
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MPI - Master Patient Identifier

The MPI is a unique identifier that ties together a patient’s records, from different
facilities, where the patient MRN is different.

To allow PowerScribe 360 to link patients across sites, the RIS should send the MPI in
PID 3.
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5 - Microphone Issues

PowerMic issues on Windows 7 and 8 workstations can have different causes, but the
presentation can be similar.

Initial Settings to Check Or Verify

1. Is the PowerMic a non-scanning microphone and the PowerMic with scanner
drivers not installed on the workstation? 

2. Is the PowerMic a scanning microphone and the PowerMic with scanner drivers
are installed? 

3. Is the PowerMic firmware updated to the latest version? 

4. Is the PowerMic configured to be the default recording device? 

5. Are the other recording devices disabled, except for the Audio Mixer device? 

6. Are the audio recording Power Management properties disabled for the PowerMic
audio device?

Download Microphone Drivers

The following microphone drivers are available to download.

 PM2_Update_1.0.0.11.exe

 PowerMicDrivers.exe

http://healthcare1content.nuance.com/downloads/PowerMic/PM2_Update_1.0.0.11.exe
http://healthcare1content.nuance.com/downloads/PowerMic/PowerMicDrivers.exe
http://healthcare1content.nuance.com/downloads/PowerMic/PM2_Update_1.0.0.11.exe
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Resolving - No Audio Device Installed

When logging into the PowerScribe 360 Client on a Windows 7 workstation, the
following error displays:

"It appears that this computer has no audio recording devices installed. Speech
will therefore be disabled."

Resolutions

1. Go to the Control Panel > Sounds and Settings dialog.

2. Ensure the Audio Mixer Device shows under Recording Devices as shown below:

3. If you do not see the device, righ-click and select Show Hidden Devices.

4. Right-click Rec Playback, and select Enable.

If the device does not show, even if hidden devices are shown, it means
the audio drive needs to be upgraded.

Remove Remnant USB Devices

1. Remove the remnant USB device drivers which can remain and interfere with the
installation of Nuance input devices such as PowerMic and the USB foot pedal.
This process provides a procedure to eliminate drivers for non-present devices on
client workstations.
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Remnant USB devices can accumulate and interfere with the installation of the
PowerMic and PowerMic II USB devices. Below is a procedure to add one system
environmental variable, which allows drivers for non-present devices to be displayed
in Device Manager. Removal of these non-present devices has proven to be beneficial
in resolving issues related to the installation of the PowerMic USB device 

a. On the workstation, click Start > Settings > Control Panel > System. 

b. Click the Advanced tab. 

c. Click Environmental Variables at the bottom. 

d. In the System variables box at the bottom, click New. 

e. Enter the values presented in the Edit System Variable window, shown below: 

- Variable name: DEVMGR_SHOW_NONPRESENT_DEVICES

- Variable value: 1 

f. Click OK and the new variable should be displayed as shown below. 

g. Click OK and OK to close. 

h. Unplug the PowerMic. 

i. Open Device Manager and enable Show hidden devices. 



PN 889672 July 24, 2015 5-4

Notice how many remnant USB device drivers (grayed-out) clutter Device
Manager, shown below. 

j. Right-click each non-present driver for the USB Human Interface Device,
USB Audio Device and USB Composite Device, and then click the Uninstall
menu option. 

k. Reboot the workstation. 

Apply Microsoft Update

1. Apply the USB Hot fix that is available through Microsoft. This hotfix addresses
the issue which occurs because the initialization that is performed for the buffer
of the audio data is insufficient for when you try to play audio.
http://support.microsoft.com/kb/2721341

Disable Power Save Options

1. Disabling Power save features in BIOS like Intel Speed Step Technology (aka
Runtime Power Management). 

http://support.microsoft.com/kb/2721341
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2. Switch Windows power plan to high performance (Control Panel / Power
Options). 

3. Change the minimum processor state of the current power plan to 50% (Control
Panel / Power Options / Change plan settings / Change advanced power settings). 

Add a USB PCI Card

4. Insert a USB PIC card into the workstation and plug only the microphone into this
card / device. Cards that have been used successfully are:

a. Insignia USB 3.0 PCIe Host Card NS-PCCUP53/NS-PCCUP53-C. 

b. Transcend Model PDU3 USB 3.0 PCI Express.
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Resolving - Cannot Find Sound System

The user receives an error message on the workstation when logging into
PowerScribe® 360 | Reporting:

1. Go to the Control Panel > Sounds and Settings dialog.

2. Ensure the Audio Mixer Device shows under Recording Devices as shown below:

3. If you do not see the device, righ-click and select Show Hidden Devices.

4. Right-click Rec Playback, and select Enable.

If the device does not show, even if hidden devices are shown, it means
the audio drive needs to be upgraded.
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DLLs failed to register properly: HIDDEV.dll and/or USBMGR.dll.

1. Re-register the DLLs using the provided script.

2. Download and extract regfix.zip. 

http://supportcontent.nuance.com/healthcare/documents/manauals/889672/reg
fix.zip

3. Run regfix.bat. 

https://isupportcontent.nuance.com/healthcare/documents/manuals/889672/regfix.zip
https://isupportcontent.nuance.com/healthcare/documents/manuals/889672/regfix.zip
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Resolving - Microphone Disconnects While Dictating

While dictating, the user receives an error message on the workstation:

This is generally due to, the connection to the audio device being lost due to a Windows
driver crash. The assumption is, that the Intel chip set drivers; respectively, USB
controller drivers fail. The issue seems to only occurs, when the CPU is idle and the
CPU frequency drops below 1 GHz. This Issue occurs with several audio devices from
different vendors (Nuance PowerMic, Philips SpeechMike, etc.), but only on the
Windows 7 Operating System.

Remove Remnant USB Devices

1. Remove the remnant USB device drivers which can remain and interfere with the
installation of Nuance input devices such as PowerMic and the USB foot pedal.
This process provides a procedure to eliminate drivers for non-present devices on
client workstations.

Remnant USB devices can accumulate and interfere with the installation of the
PowerMic and PowerMic II USB devices. Below is a procedure to add one system
environmental variable, which allows drivers for non-present devices to be
displayed in Device Manager. Removal of these non-present devices has proven
to be beneficial in resolving issues related to the installation of the PowerMic USB
device 

a. On the workstation, click Start > Settings > Control Panel > System. 

b. Click the Advanced tab. 

c. Click Environmental Variables at the bottom. 

d. In the System variables box at the bottom, click New. 
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e. Enter the values presented in the Edit System Variable window, shown below: 

- Variable name: DEVMGR_SHOW_NONPRESENT_DEVICES

- Variable value: 1 

f. Click OK and the new variable should be displayed as shown below. 

g. Click OK and OK to close. 

h. Unplug the PowerMic. 

i. Open Device Manager and enable Show hidden devices. 
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Notice how many remnant USB device drivers (grayed-out) clutter Device
Manager, shown below. 

j. Right-click each non-present driver for the USB Human Interface Device,
USB Audio Device and USB Composite Device, and then click the Uninstall
menu option. 

k. Reboot the workstation. 

Add a PCI USB Card

1. Insert a USB PIC card into the workstation and plug only the microphone into
this card / device. Cards that have been used successfully are:

a. Insignia USB 3.0 PCIe Host Card NS-PCCUP53/NS-PCCUP53-C. 

b. Transcend Model PDU3 USB 3.0 PCI Express
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Resolving - Microphone Button Latency

Disable Audio Playback Enhancements

When pressing the record button on the microphone, the recording does not start for a
few seconds.

Is the audio playback Enhancements properties disabled for all audio devices? (MS
resolution for the issue where the audiodg.exe process spikes CPU usage to 80% or
more for short periods.) 

In Windows 7 or 8, when running audio or video player software, CPU usage will
reach above 80% instantly. This phenomenon is caused by the "audiodg.exe"
process. Sometimes, high CPU usage by this process might lead to a fake crash.
Follow these steps to fix the issue:

1. On the taskbar, right-click the Speakers icon, and then select Playback devices. 

2. From the Playback tab, right-click Speakers, and select Properties. 

3. From the Speakers Properties dialog, select the Enhancements tab, and check
Disable all enhancements. Switch Windows power plan to high performance
(Control Panel / Power Options). 

Enable Audio Mixer Device

1. Go to the Control Panel > Sounds and Settings dialog.

2. Ensure the Audio Mixer Device shows under Recording Devices as shown below:

3. If you do not see the device, righ-click and select Show Hidden Devices.
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4. Right-click Rec Playback, and select Enable.

If the device does not show, even if hidden devices are shown, it means
the audio drive needs to be upgraded.



PN 889672 July 24, 2015 6-1

6 - AutoText Issues

Verify Standard Configuration

Proper Naming

 Assure the AutoText is using proper naming conventions. The AutoText name is
the word or phrase you dictate to invoke the format of the report. It should be at
least 2 syllables, all lowercase, except for acronyms. 

Proper Trigger Word

 Verify the trigger word you have set is not the same as any Dragon command, for
example "insert" or "paste". 

 Verify that you are using the trigger word you have set. If the proper trigger word
is not used the name of the AutoText will end up in the report instead of the
contents of the AutoText. You can verify your trigger word by clicking on Tools
> Preferences > Dictation Tab. The default choices are PowerScribe, Macro or
Dictaphone. 

Relevancy

 Make sure the AutoText you are trying to invoke has relevancy to the procedure
code associated with the report order. If the order has an associated procedure
code that does not match the one associated with the AutoText that you are
attempting to invoke it will only bring in the AutoText name and not the contents
of the AutoText. 
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Common AutoText Issues

In V2, there was a defect causing the site AutoText to be inserted, if the personal and
site AutoText had the same name.

This is resolved in the following patches:

 2.0.1 patch 1'

 2.5.1 patch 1

 2.5.2 patch 1 (Not yet released)

As a temporary workaround, your system admin can rename the site AutoTexts so they
do not conflict with the personal AutoTexts, or the dictator can rename their AutoTexts.

Relevancy

In some instances you may not be able to invoke specific AutoTexts into a report.  This
is typically due to the relevancy of the associated procedure code of the AutoText not
matching that of the procedure code that is tied to the report's order.

Adding additional Procedure Codes to be associated with an AutoText can be
accomplished in the PowerScribe 360 Dictation Client, or in PowerScribe 360 Portal
following a similar procedure: 

1. In PowerScribe 360 Dictation Client. open the Autotext Editor. 

2. Select Categories and click Site. 

3. Search for a specific Procedure Code number, or select the desired Modality and
the Anatomy. 

4. In PowerScribe 360 Portal, access: Setup > AutoText. 

5. Select AutoText to add additional Procedure Codes. 
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6. Click Procedures, and select the Site and search for a specific Procedure Code
number, or select the desired Modality and the Anatomy. 

7. Select and click Add to associate the Desired Procedure Codes found in the search,
to the Autotext.
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The Autotext's attributes: Normal, Default, Private and the Patient's information:
Age, Gender, or Class (Inpatient, Outpatient, Pre-admit, Emergency), if used in
the Autotext, will further restrict the Autotext’s relevancy. See the Client and
respective Portal view in the following pictures.
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The Autotext List with the available Autotext in the Dictation Client - Report Editor 
Window varies based whether the Autotext is Personal, Site, and/or Relevant. 

Only relevant AutoTexts can be introduced or called in a report. If the voice-invoked 
AutoText is not available in the Autotext List Pane for a report, it cannot be introduced 
in the report, and the AutoText's name will be spelled out in the dictation, instead. 

For example, if using "PowerScribe" as the key word to invoke AutoTexts and the name 
of a non-relevant AutoText for a report is: "CT abdomen": when dictating 
"PowerScribe CT abdomen" the words "PowerScribe CT abdomen" will show dictated 
in the report, as opposed to introducing in the report the invoked AutoText called: "CT 
abdomen".
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7 - Assure/Quality Checker Issues

Overview

Assure for PowerScribe® 360 | Reporting checks for the following:

 Laterality check: Identifies potential left/right mismatches in the report, for
example, the exam was for the left side, but the radiologist said right. 

 Gender check: Identifies potential male/female mismatches and references to
anatomy that does not match patient gender. 

 Critical Test Results check: Identifies and highlights potential references to
critical test results dictated in the report.

Technology

Assure for PowerScribe® 360 | Reporting utilizes Nuance's CLU (Clinical Language
Understanding) technology. During the Assure for PowerScribe® 360 | Reporting
workflow, the report text, exam description (for example, "Chest CT"), and patient
gender will be passed to the Nuance datacenter where the Nuance CLU engine will
parse the text. The results will be passed back to the PowerScribe® 360 | Reporting
Client software and presented to the radiologist. This interaction will occur in near real
time as to not disrupt the radiologist's workflow.

The Nuance CLU technology only offers this as a hosted service. The Nuance CLU
technology cannot be deployed onsite within the customer's datacenter.

The connection to the Nuance datacenter encrypts the data passed back and forth from
the PowerScribe® 360 | Reporting system, via SSL. The customer does not need an
SSL certificate for Assure. However, https port 443 needs to be open on the firewall to
allow PowerScribe® 360 | Reporting to connect to the Nuance datacenter over an SSL
connection. If the customer cannot allow https port 443 to be open, then Assure for
PowerScribe® 360 | Reporting cannot connect.

Portal Configuration

1. As an administrator, you can configure (enable/disable) the Assure for
PowerScribe® 360 | Reporting feature at the System, Site, and Account levels. 

To enable the Assure for PowerScribe® 360 | Reporting feature at the System
level: 

a. Click Setup > System > Preferences > Permissions. 

b. Select the Allow report consistency check box. By default, the preference is
True (enabled).

To enable the Assure for PowerScribe® 360 | Reporting feature at the Site level: 

a. Click Setup > Sites and select the site you want to configure. 
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b. Click Preferences > Permissions and select the Allow report consistency
check box.

2. You can also set an initial value for the account-level parameter called Perform
consistency check at signoff which will automatically run the consistency checker
at signature. This parameter can also be changed by each user in the Client
software. 

To set the initial value for the Perform consistency checks at signoff parameter for
a user:

a. Click Setup > Accounts and select the user you want to configure. 

b. Click Preferences > Workflow and select the Perform consistency check at
signoff check box.

3. Configure PowerScribe® 360 | Reporting for Assure the Service URL and License
ID must be entered under the System Configuration. This information is provided
to the customer by the project manager assigned to the implementation. 

Verify the Client Configuration

You can configure the following preferences for Assure:

 Choose one or more items on which to run your consistency check. Currently
your choices are Critical Test Results, Gender Mismatches, and Laterality
Mismatches. 

 Configure Assure for PowerScribe® 360 | Reporting to run automatically or
manually.

To configure which items on which to run consistency checks: 

1. Click Tools > Preferences > General. 

2. Click the drop-down arrow to the right of the Enable Assure consistency check
types item. 
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3. Select (or clear) the check boxes based upon your specific requirements.

To configure Assure to run automatically or manually: 

1. Click Tools > Preferences > Workflow. 

2. Uncheck the Perform consistency check at signoff box.

For information on the use of the PowerScribe® 360 | Reporting Assure 
Consistency Checker, see:

 P36P015 - PowerScribe® 360 | Reporting Clinical Guidance User Guide

 P36A017 - PowerScribe® 360 | Reporting Assure Consistency Checker for 
Version 1.5 

 P36P001 - PowerScribe® 360 | Reporting Assure Consistency Checker for 
Version 2.x

https://isupportcontent.nuance.com/healthcare/documents/ats/resource/p36/p36a017.pdf
https://isupportcontent.nuance.com/healthcare/documents/ats/purchase/p36/p36p001.pdf
https://isupportcontent.nuance.com/healthcare/documents/ats/purchase/p36/P36P015.pdf
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Troubleshooting

1. Check the Portal to make sure Assure is setup correctly. If settings are correct in
the Portal, you can run the Assure tool to help troubleshoot an issue.

If it is correct, check the CLU license that is installed with the PowerScribe® 360
| Reporting Application.

2. On the Application Server run RASConfigUI.exe in the 
C:\inetpub\wwwroot\RAS folder .

3. Click Configure Assure, and verify the data entered matches the screen shot
below:
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Testing the Configuration

Assure Test Application

1. Download the PS360AssureTestAPP.zip from the Definitive Media Library, 360
Vx Tools folder.

2. Extract the files from the zip to a folder on your workstation. 

3. Double-click AssureTesting.exe.

4. Leave the default settings in place for the Work Type, URL and License ID. These
are specific settings that point to the Development System. 

5. The Procedure Code is not scanned when testing the tool but should be populated
with a few numbers. 

6. The key is to put in a procedure description code relevant to the topic of the
dictated text. Such as XR (x-ray) Wrist (body part) and left or Right. Most of the
time customers use LT or RT, which comes out as "XR Wrist RT". 

7. Choose a gender for your test. 

8. Enter some text in the "Body" section. 

9. Click Submit. 

10. If you get a return as shown above, this indicates that the overall CLU system is
operating. 

11. If you do not get a return on the customer system, test it on your workstation. It is
possible the customer's Firewall is blocking traffic. 

12. If you were able to get to the Dev. CLU, your next step is to replace the default
License ID and URL with the customer's specific data, and repeat the test. 
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13. If you cannot reach the customer specific CLU gateway, you will need to verify
the license and URL is correct. To do this, send an e-mail to
CLUServices@nuance.com with the Site name, Account number and info you
have in Portal at that time, asking if the data is correct / valid. 

14. If it is not the correct ID and URL, update the customer system and test. If the
values are correct, it is possible the customer CLU is down, send an e-mail to CLU
Partner Support CLU_Partner_Support@nuance.com asking them to check
the customer system. Be sure to provide the license and URL for the customer.
Also make sure you cc support management.

Common Issues

Assure is Not Returning Accurate Results

If a site opens a ticket indicating that Assure is working but the results returned are
inaccurate, you can use the tool to test as you did above. The difference is you need to
evaluate:

1. Is the gender being picked up? Maybe unknown is selected? 

2. IS the right left identifier being picked up? 

3. IS the right / Left being used valid? Maybe they are not using LT / RT or other
appropriate selection. 

If the returned results are not the expected results, escalate.

Method Call OpenSession Failed with Sys Response

Assure Consistency Check Error in PowerScribe Reporting Dictation 
Client 

When running the Assure Consistency test, you may receive an error: "method call
OpenSession failed with sys response OpenSession(): [AuthenticationError]-Generic
application error. Please contact system administrator".

Symptom

To fix the error, follow the steps below.

1. Review the Assure Config file on the web server: 

X:\inetpub\wwwroot\RAS\RASConfigUI.exe 

mailto:CLUServices@nuance.com
mailto:CLU_Partner_Support@nuance.com
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2. Click Config Assure.

Check the RAS Configuration: Assure Configuration. The entries may be
currently blank or incorrect.

3. On the RAS Configuration: Assure Configuration dialog, use the following
values: 

 Assure Partner ID: 796b708b-e674-4126-af50-9522ed022b39 

 Name: Nuance 

 Assure Connection Timeout: 15 

 Assure Max Retries: 1 

 Assure Worktype Code: 1 

4. Recycle the following Server IIS Application Pools

 DefaultAppPool 

 PS360AppPool 
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8 - LDAP Issues

Supported LDAP Authentication Types

PowerScribe® 360 | Reporting can support the following LDAP Authentication Types:

 Basic - Indicates that basic authentication should be used on the connection. The
value is equal to 1. 

 Digest - Indicates that the Digest Access Authentication should be used on the
connection. The value is equal to 4. 

 Kerberos - Indicates that Kerberos authentication should be used on the
connection. The value is equal to 9. 

 Negotiate - Indicates that Microsoft Negotiate authentication should be used on
the connection. The value is equal to 2. 

 Ntlm - Indicates that Windows NT Challenge/Response (NTLM) authentication
should be used on the connection. The value is equal to 3. 

 Sicily - Indicates a negotiation mechanism (Sicily) will be used to choose MSN,
DPA or NTLM. This should be used for LDAPv2 servers only. The value is
equal to 5. 
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Configuring the LDAP

You can configure the LDAP settings from the PowerScribe 360 portal, System page.
The LDAP configuration Path, Domain, Authentication, etc., option settings, are
shown below.

Configuring LDAP binds a connection using the credentials of users
logging in from the login page. Although each user has a single
username and password, there can be more than one way to represent a
user's entry in LDAP and more than one attempt can be made to bind.

Administrator Field

At a high level, LDAP authentication follows one of two paths. The path chosen
depends on the absence or presence of a value in the Administrator fiel

Administrator Field Absent

Configuring the LDAP for the customer without a value in the Administrator field
should be tested first. This method will prove to be more efficient and place a smaller
load on the LDAP server (a domain controller in the case of Active Directory).

Username Syntax Format Options

Active Directory is flexible and allows up to four different username syntax format
options and PowerScribe® 360 | Reporting is designed to try all four syntax format
options. The four syntax formats contained in the distinguishedName attribute include:

 Full DN (e.g., CN-username, DC=domain, DC=com) 

 CN-username 

 DC=domain 

 DC=com

If all four Active Directory syntax format options fail, the user cannot be authenticated, 
and PowerScribe® 360 | Reporting performs authentication attempts to verify the 
username/password pair against its own database.

If both the Active Directory and PowerScribe® 360 | Reporting authentication methods
fail, a user will receive a failed login notification.

IMPORTANT
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Example - Administrator Field Absent

In this example, there is no Administrator account name specified, so this example is
of the simple authentication method.

Assumptions

 Created an account in the PowerScribe 360 portal for a user named scott_simon. 

 PowerScribe 360 will try to authenticate this username and password pair in the
following order 

Authentications

 Full DN, in this case that would be “CN=scott_simon, DC=nuance, DC=com” 

 User Principal Name, in this case scott_simon@nuance.com 

 NT account name, in this case nuance.com\scott_simon 

 Plain username, in this case scott_simon 

When logging into a PowerScribe 360 server within the Nuance domain, the first
attempt to authenticate fails. The directory tree is somewhat more complex within
Nuance and there are several levels missing causing the failure.

The second attempt to authenticate succeeds. The User Principal Name is valid and if
the proper password is entered, the user is successfully authenticated.

In this example, only the first Authentication method fails; all other
Authentication methods succeed since they match the proper account
within the Active Directory.

There are already several possible ways that information can be entered into the portal
and still have a successful LDAP authentication.

Administrator Field Present

If you can configure the LDAP settings from the PowerScribe 360 portal, System page
and the Administrator field is present, PowerScribe 360 performs the following steps
to authenticate the users' credentials:

1. Assures there is an Administrator password specified in the portal 

2. Authenticates the connection using the Admin credentials provided. 

Authentication is performed in order using the four Username Syntax
Format Options defined above.
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3. Upon successful Admin authentication, PowerScribe 360 executes an LDAP
sub-tree search against the 'Path' specified in the configuration, utilizing the
UserName Pattern specified as a filter. 

4. Results of the search are used to authenticate the user found in the search with the
password specified. 

Authentication is performed in order using the four Username Syntax
Format Options defined above.

Example - Administrator Field Present

In this example, there is an Administrator account name specified.

Assumptions

 The Adminstrator field value is specified as 'Administrator' 

 A user with the username, scott_simon logs in 

Authentications

 Authentication is using the specified value to authenticate. 

In step 2, if a value of 'Administrator' was specified in the portal for the
administrator field, replace the value 'scott_simon' with 'Administrator'
to see the different username formats that would be used to authenticate.

 Authentication of the sub-tree search executed starting in the directory tree at
DC=nuance, DC=com, searching the entire sub-tree under that entry for the
pattern matching sAMAccountName=scott_simon

 Results of the search, compare the required fields values and attempt to
authenticate. 

If the four username format search/compare authentication attempts fail, PowerScribe
360 authentication attempts to verify the username/password pair.

If both the Active Directory and PowerScribe 360 authentication methods fail, a user
will receive a failed login notification.
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Tools

There are a couple of tools you can use to help you determine the configuration.

ADExplorer

ADExplorer can be obtained from the sysinternals web site. You can use this tool to:

 View the sites Active Directory tree 

 Determine how the site is configured 

 Identify what needs to be specified in the portal configuration 

1. Run the ADExplorer application, the Connect to Active Directory displays.

 If you are logged into a domain account at the customer site when you run
ADExplorer, you can click OK without filling in any fields. The application
determines the server to connect to and you should be able to browse from
any domain account. 

 If the customer does not provide a domain account, rather a local server
account for the Powerscribe 360 RAS server, you must enter the valid domain
account supplied to you by the customer in Connect to, User and Password
fields, then click OK. 
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With a valid connection established, the Active Directory Explorer clialo g
displays with the complete Active Directory tree.
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2. Browse the tree to find where users are defined. An example dialog is below: 

From this example, the path to use would be:

OU=Employees, OU=Users, OU=Corp Accounts, DC=Nuance, DC=com

When Powerscribe 360 builds the distinguished name for authentication, it adds
the string CN=user, in the case, CN=scott_simon, since that is the name of this
attempted login example.

This example also shows the sAMAccountName attribute and the
userPrincipalName attribute, both of which may be used during authentication. 

Wireshark

Wireshark can downloaded from http://www.wireshark.org.

1. Install Wireshark on the RAS server to assist you with LDAP issues. 

When users enter their credentials on a workstation running the
PowerScribe® 360 | Reporting Client, the credentials are passed to the
RAS server and authentication with LDAP is performed.

http://www.wireshark.org/
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2. Run Wireshark and select the interfaces you want to use to collect messages and
click Start. During collection, a lot of information is collected quickly. 

In the Filter field, you can enter ldap to limit the collection traffic for the
LDAP protocol only to appear in the dialog.

Shown above is the data captured from a single PowerScribe 360 login using the
first sample shown above. There was no data in the administrator field, the path
was set to DC=nuance, DC=com, and the username specified in Powerscribe 360
was scott_simon.

A bind request for the Distinguished name that was created displays first. The next
entry is an authentication failure.

3. As mentioned above, the bind failed since the distinguished name specified is
incomplete and the username is wrong. The CN used in the distinguished name is
actually Simon, Scott, not scott_simon.

The next entry is a bind request for scott_simon@nuance.com. Following that is
the successful authentication response. This verified the login and thus no more
formats needed to be attempted, and the final line is the unbind request matching
the successful bind.
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You need to be aware of the following important details when using Wireshark:

Passwords are passed to the LDAP server in clear text and Wireshark
shows all information in the packets. The bottom pane above, just out of
view shows the password that was sent to the LDAP server for
authentication. This may be useful debugging information; however,
security passwords appear in clear text.

While collecting packets, even though you filter for ldap packets, all
packets are monitored so the memory used by the application can grow
very quickly. Monitor packets only for as long as you need to get the
information required, then stop monitoring packets and, exit the
application.

ADInsight

ADInsight can be obtained from the sysinternals web site. Use this tool only with a
RAS server that is not on a 64-bit OS and the other two previously mentioned tools do
not provide the answers you need. Although this tool appears to be ideal for debugging
LDAP, it has not been maintained for many years and appears to have some
compatibility issues.

IMPORTANT

IMPORTANT
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9 - Critical Results Issues

Required Configuration

Traffic Must Bypass Proxy Server

Ensure that traffic to and from https://ps360criticalresults.com is allowed through the
firewall and does not go through the proxy server, if you have one.

Setting the URL in RadPortal 

1. In the Admin Portal, go to Setup > System > Configuration. 

2. Verify the Service URL to: 
https://ps360criticalresults.com/criticalresultsapi4.0/MessageDataService.asmx 

3. Verify the Dashboard URL to:
https://ps360criticalresutls.com/powerscribe360/RadiologistDashboard.aspx?Ra
dID={0} 

4. Click save and close. 

Ordering Clinician Setup

The following must occur for the ordering clinician to be available for auto population
or selection within Veriphy, and for alerts to subsequently be generated for an ordering
clinician:

1. Ordering Clinician needs to be setup in Critical Results. 

2. Ordering Clinician needs to be setup in PowerScribe® 360 | Reporting. 

3. Ordering Clinician needs to have been sent an order through the HL7. 

Notification Statement

If you wish to have the CR notification statement auto inserted into the dictated report
you can enable it by modifying the system or site settings. 

In RadPortal, from Setup > System > Preferences > Workflow and add or edit the text
from the Critical communication sent statement preference. Click save and close.

https://ps360criticalresults.com
https://ps360criticalresults.com/criticalresultsapi4.0/MessageDataService.asmx
https://ps360criticalresutls.com/powerscribe360/RadiologistDashboard.aspx?RadID={0} 
https://ps360criticalresutls.com/powerscribe360/RadiologistDashboard.aspx?RadID={0} 
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Critical Results and PowerScribe 360 | Reporting Account Roles

Testing Connectivity

1. From both the application server and the workstations that will use CR, open
Internet Explorer. 

2. Enter this URL: 

https://ps360criticalresults.com/criticalresultsapi4.0/MessageDataService.asmx 

Critical Results Role Description PowerScribe 360 | Reporting 
Role

Administrator Can manage both Radiology and Lab Accounts
Cannot create CR messages
Adding and Managing users
Can view all messages for Radiology and Lab 
Accounts

NONE

Group Administrator Administrator for Radiology Account
Cannot create CR messages 
Adding and managing Users for Radiology 
Account
Can view all Messages for Radiology Account

NONE

Specialist Radiology User Account
Can create CR messages using PS360 or CR 
Desktop
Can view only own messages
Can do own account provisioning
CR ID should match with Attending or Resident 
Account on PS360

Attending, Resident or Fellow

Lab Administrator Administrator for Lab Accounts
Cannot create CR messages 
Adding and managing Users for Lab Account
Can view all Messages for Lab Account

No relation with PS360

Lab Technician Technician for Lab Accounts
Can create CR Messages for Lab Account
Can do own account provisioning

No relation with PS360

Ordering Clinician Can receive CR messages 
Can do own account provisioning
CR ID should match with Physician ID on 
PS360
Until PS360 Ver 2.5, Physician Sync is done 
from System tab on Radportal
From PS360 Ver 3.0 onwards Sync is 
automatically done if OC exists on CR

Physician
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You should see:

If you do not, the machine does not have internet access to the Critical Results
System or traffic is routing through a proxy server.
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Common Issues

Checking Audio Impression Option

The following shows the Include Audio Impression option checked in the Critical
Findings Message:

The recorded message is not required when the Include Audio Impression" option is
checked in the Critical Findings Message dialog box.

When a radiologist needs to send a critical findings message and the option to "Include
Audio Impression" is enabled in the "Critical Findings Message" dialog box, the
radiologist is not required to record a message. 

Synch

PowerScribe® 360 | Reporting Versions 1.x to 2.0.1

The synch feature allows the administrator to pull provider information from the CR
system into the provider data table for Reporting. This is a ONE WAY update from
Critical Results to Reporting. 
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The SYNCH looks at the provider's hospital ID, matches the last name and then pulls
the following information from CR into Reporting.

1. CR provider ID 

2. Work Phone 

3. Email 

4. Fax 

5. Street 

6. Street2 

7. Zip 

8. City 

9. State

If the field is blank or NULL in CR, it will not update the field in PowerScribe 360
Reporting. So a null value in CR will NOT blank out the data field in Reporting.

An individual SYNCH occurs in the latest version of PowerScribe® 360 | Reporting
when the dictator selects a provider for a CR message, and the providers CR Provider
ID in Reporting is null. In this case Reporting pulls the users info into the Reporting
Provider data table and allows the Dictator to send them a CR message.

PowerScribe® 360 | Reporting Versions 2.5 and Up

Synch is no longer used in PowerScribe® 360 | Reporting Versions 2.5 and above. 

The synch button is scheduled to be removed from the application in
V3.x in 2015. 

In V 2.5.x the user account will synch when a dictator creates a CR message. The
Reporting application will query the CR system, match up the providers First, Last and
Middle name along with the RIS ID associated to the user in both systems. If it finds a
match, the reporting system will be updated and the provider can be selected.

If there is a difference in the name spelling or context, the synch will fail and the
dictator will not be able to select that provider.

In V3, if the Critical Results ID:

 Is not present in PowerScribe® 360 | Reporting, then it will check firstname and
lastname, and update the Critical Result ID. 

 Is present in PowerScribe® 360 | Reporting, then it will not check firstname and
lastname, and it will update only VocadaDocOnly and VocadaTextOnly, it will
not update the rest part.
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Blank Recording

Symptom

In the Critical Results window, when the Rad taps the Record button (Toggle on, but
the red light is NOT on), the Message time slider bar moves and increases as though a
recording is taking place, but the recording is blank.

The Rad will not be able to record if the preference in Critical Results is setup
incorrectly to Toggle on/Toggle off). This should be set to DEADMAN.

The Rad must click the Pause/Stop button on the Critical Results
window to stop the record function.

Setting

Rads workstation settings in PowerScribe 360 Dictate Client > Tools > Preferences >
Dictaphone PowerMic defaults to Toggle on/Toggle off is incorrectly set.

Workaround

If the Rads are using Toggle on/Toggle off in PowerScribe® 360 | Reporting, they must
be trained to use the Deadman switch to record a Critical Result message.
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10 - Mobile Radiologist Issues

Background

The purpose of the mobile bridge is to serve as a translation layer between the eSig
provider and the mobile device. The bridge exposes only the methods applicable to
support eSig workflows, and those methods are structured in a manner to minimize
chatter between the device and the service.

Due to its restricted responsibility, the Bridge is stateless and leverages a “pseudo”
shared nothing architecture to achieve scalability needs. This allows the bridge to be
deployed on multiple nodes with no reliance on its siblings, fully leveraging load
balancers where applicable. 
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Mobile Bridge Deployment

There are two ways Mobile Bridge can be deployed at the Customer site.

1. Access inside and outside Hospital Network: The mobile application users can
access the eSignature feature from their devices from anywhere, inside and
outside the hospital Network using the device’s mobile communication (3G, 4G,
etc. . . ).

The mobile bridge is hosted in a separate server in the DMZ environment. This
configuration allows the Mobile application to send request to the Mobile Bridge.
The communication between the Mobile application and mobile Bridge has to be
over a secured channel of SSL (Secured Socket Layer) connection. The SSL
creates a secure connection between the Mobile device and the Mobile Bridge
Server over which any amount of data can be sent securely.
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The communication between Mobile Bridge and RAS Bridge is performed using
Hospital Local Network.

2. Access inside Hospital Network: The mobile application users can access the
eSignature feature only within the hospital network, available via its Wi-Fi
network.

Following architecture depicts how Mobile Bridge is deployed in the hospital
network. The mobile bridge is hosted in the same server as RAS Bridge. Since the
server is not known outside the boundary of the hospital, the mobile application
will not have access from outside the hospital Network. In order for the user to
access the application outside the Hospital network, the device should have a
successful Hospital VPN connection established.
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Mobile Workflow

The following diagram illustrates the user flow through the application.
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1. User launches the app and is presented with the landing page, and the option to
issue a search or go to their sign queue. 

2. If the user issues a search, they are presented with the search results, with content
providers displayed on the carousel and the search of the provider in the main area.
The user can issue another search, or go to their sign queue. 

3. If the user selects to go to their sign queue and has not been authorized for this
session, they are presented with the login screen for their credentials. 

4. Upon successful authentication, the user is presented with their sign queue. 

5. User selects a report from their sign queue and is presented with the detailed report
screen. The user can make edits to the report, save, sign, or issue a search. 

6. If the user issues a search, they are presented with the search results, with content
providers display on the carousel and the search of the provider in the main area.
The user can issue another search, or return to the detailed report screen. 

7. If the user saves the report, they receive confirmation of their action and are
returned back to the detail report page. 

8. If the user signs the report, they are requested to confirm the action, they then will
receive confirmation of the action, and are returned to their sign queue.
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Common Issues

Login

When the user attempts to login to the Mobile Client, they provide a username,
password, and site. The Client will then contact the NMS server via HTTP using the
provided site to obtain the location of the Mobile Bridge server. The address they go to
is below:

PremiseNMS?institutionCode={SITE}&productGuid=E85446E9â€?BEA9â€
?4E9Dâ€?9E28â€?190 

 8B8465E15

 The web address contains port 8051. If the Client is being accessed from a
managed network, port 8051 must be open.

This website will always be externally accessible. To confirm the address being
returned from NMS, you can enter this address into a web browser, replacing {SITE}
with the site identifier the customer is using in the Client. This should be provided by
the PM or customer. If successful, you will be presented with a web address (formatting
of the results will differ based on browser):

 If the web address returns “Webpage cannot be found” or any other HTTP 404
errors, the site identifier needs to be addressed by the NMS team.

 The web address return must NOT have /ps360mobile or anything additional
appended to it.

http://nms.nuancehdp.com:8051/Nuance.NMS.Services/NMSServiceStatus/Rest/OnPremiseNMS?institutionCode=%7bSITE%7d&productGuid=E85446E9-BEA9-4E9D-9E28-1908B8465E15
http://nms.nuancehdp.com:8051/Nuance.NMS.Services/NMSServiceStatus/Rest/OnPremiseNMS?institutionCode=%7bSITE%7d&productGuid=E85446E9-BEA9-4E9D-9E28-1908B8465E15
http://nms.nuancehdp.com:8051/Nuance.NMS.Services/NMSServiceStatus/Rest/OnPremiseNMS?institutionCode=%7bSITE%7d&productGuid=E85446E9-BEA9-4E9D-9E28-1908B8465E15


PN 889672 July 24, 2015 10-7

External Mobile Radiology Client

If the customer is planning to use the Mobile Radiology Client, externally, the website
returned should be accessible from any web browser. 

To confirm external accessibility:

1. Copy the web address from NMS, adding /PS360Mobile/Help to the end of url
and paste it in the web browser. 

Something similar should display:

If a web page not available (or any HTTP 404 error) error displays, the customer
must address the network configuration. Mobile will not work unless this page is
accessible.

Internal Mobile Radiology Client

If the customer plans to use the Mobile Radiology Client internally, the web address
returned should be the name of the Mobile Bridge server. You can confirm the name is
correct by entering the returned value from NMS, plus ps360mobile/help into a web
browser on the workstation inside the customer’s network:
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It should return the same as the external website:

 If this fails, getting a web page not available (or any HTTP 404 error), confirm
that the server name as well as the Mobile Bridge software has been installed on
the server.

The user logging in must have the attending, resident, or fellow roles specified when
logging in, or the login will throw an error.

They must also have the Enable Mobile Radiologist permission set in RadPortal.

Client Side (Mobile App/Mobile Device)

If all of the above steps are validated, have customer conduct test via Mobile Device.
If issues, consider the following:

 Explicit username or password error messages indicate end user may not have
valid logon details including Site ID (institution code). 
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 If the site specified in the mobile device is not registered with NMS, the
following error occurs: 

If a ”generic” error occurs (see screen shot), consider the items below:

1. Mobile device cannot connect to the address provided by NMS. See Login
section above. 

2. No Internet connection. 

Browse to http://www.nuance.com to verify Internet connectivity. 

3. Port 8051 is blocked. 

If this is the case, then browsing to the URL in Step 2 should return Web Page Not
Found. Check the site’s firewall. 

4. Mobile device does not have access to the address provided by NMS. 

Browse to the help screen URL in the mobile device browser to verify
connectivity to the PowerScribe 360 server:

The portion in red should be the URL provided by NMS. 

5. Mobile device can connect but has a problem once connected. 

On the Mobile Bridge Web Server, go to c:\inetpub\wwwroot\PS360Mobile\logs
to review the log files and determine why there is a problem after establishing a
connection.



PN 889672 July 24, 2015 10-10

Speech Disabled

If the customer is unable to dictate in the Mobile Client once logged in, check the
Mobile Client Identifier in RadPortal:
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Capturing Web Traffic

On occasion, you may need to capture web traffic from the Client to see where the issue
is occurring.

Fiddler

 Windows computer with Fiddler2 Download here:

http://www.telerik.com/download/fiddler

 iPhone/iPad

Enabling Fiddler to capture traffic from the Mobile Client:

 Your mobile device must be on the same network as your workstation 

 Launch Fiddler2, and from Tools, select Fiddler Options.
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 Go to connections, set your Fiddler port to 8888 and select Allow remote
computers to connect.

 If the customer will be accessing the Client externally, click the HTTPS tab, and
enable Decrypt HTTPS traffic, importing the cert automatically when
prompted: 

 Restart Fiddler. 

 Note your computer’s IP address 
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 On your iPhone/iPad, go to Settings>Wifi. Select the Wifi network you are
connected to, and press the right facing arrow: 

For the HTTP Proxy settings, select Manual:

 Enter the IP address for your computer in the server, a port of 8888, and leave
authentication off: 

Launch the Client on the device. All web traffic for the Client is now being captured
and shown in the Fiddler application. HTTP errors and the like can be very beneficial
for troubleshooting where the application is failing.
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