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Chapter 1

Creating and Configuring 
Roaming Users 

Objectives
In this chapter, you will learn:

• Features of Dragon® NaturallySpeaking®

• What’s new in Version 9.5

• Aspects of the roaming user feature

• How Master Roaming Users and Local 
Roaming Users are related

• Which Web servers support the Roaming User 
feature

• How to set up the Roaming User feature

• How to create a Roaming User

• How to convert a Local non-Roaming User to a 
Roaming User

• How to copy a Local non-Roaming User to the 
Master Roaming Users location

• How to open a Roaming User

• How Master and Local Roaming Users are 
synchronized
1
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Welcome to Dragon® 
NaturallySpeaking® Medical 
Edition

Dragon NaturallySpeaking Medical Edition lets you talk to your computer 
instead of typing. As you talk, your words are transcribed onto your screen and 
into your reports, documents, or e-mail messages.

Talking to a computer while it types what you say is called dictating. You can 
dictate, rather than type, into any program that accepts text.

You can use Dragon NaturallySpeaking to:

• Compose letters, memos, and reports, and send e-mail messages. 
• Cut and paste inside your documents as well as revise and format text.
• Create custom voice commands to navigate an application, such as 

Microsoft® Word.
• Enter data into forms or spreadsheets. (Most people can dictate numbers 

faster than they can type.)
• Create custom voice commands to insert commonly used reports, such as a 

normal exam.
• Work on the Web. You can search the Web, access information, and 

navigate Web pages by speaking URLs and links.
• Start programs and open menus.
• Use handheld recorders to dictate while you are away from your computer. 

(Dragon NaturallySpeaking can then later transcribe what you said.)
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Feature

Windows® Vista 
support

Microsoft Office 2007
support

Dictaphone PowerMic
support
What’s New in Dragon NaturallySpeaking 
Medical Edition Version 9.5
Dragon NaturallySpeaking Medical Edition Version 9.5 has some updated 
features and compatibilities over previous versions. The following table details 
the new or updated features and a brief description of each. 

System and Storage Requirements

System Requirements
Nuance Communications recommends the following minimum system 
requirements for running Dragon NaturallySpeaking Medical Edition:

• CPU speed 1GHz or greater (2.4 GHz is recommended). 
• Windows 2000 Service Pack 4 or higher, Windows Server 2003, 

Windows XP Pro or Windows XP Home (SP1 or SP2), Windows Vista 
Home Basic and higher (32-bit only). 

Note: Windows ME and Windows NT are not supported.

• 512 RAM MB free minimum (2 GB recommended). 
• Minimum of 800 MB of free hard disk space for a custom installation 

where you install only the program files and one set of speech files. 
Installations can range from 800 MB (US English Standard) to 2.5 GB 
(US English Medical). 

Description

Dragon NaturallySpeaking Medical Edition Version 9.5 is compatible with Windows 
Vista Home Basic and higher (32-bit only).
Dragon NaturallySpeaking Medical Edition Version 9.5 is also compatible with Windows 
2000 or Windows 2000 Advanced Server (Service Pack 4 or higher), Windows Server 
2003, Windows XP Professional or Windows XP Home (SP1 or SP2).

Note: Earlier versions of Dragon NaturallySpeaking Medical Edition (Version 7.x 
8.x, 9.0, 9.1) will not install or run on any edition of Windows Vista.

 Dragon NaturallySpeaking Medical Edition Version 9.5 includes support for the 
Microsoft Office 2007 Ribbon menus. 
The traditional menus and toolbars in previous releases of Microsoft Office have been 
replaced by the Ribbon interface in Office 2007.

 Dragon NaturallySpeaking Medical Edition has built-in support for the Dictaphone 
PowerMic and PowerMic II. 
3
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• Microsoft® Internet Explorer 5 or higher (free download available at 
www.microsoft.com). 

• Microphone jack, if you are using a microphone that requires one.
• Nuance-approved noise-canceling microphone. 

Note: For a list of all compatible headsets and microphones refer to the 
hardware compatibility list found at http://support.nuance.com/
compatibility/default.asp. At the site, click on the product drop-down list 
and select Dragon NaturallySpeaking, and click Continue to proceed.

Storage Space Required for User Files
Adequate storage space must be available for user files that store 
information about each particular user’s speech patterns. The space needs 
to exist on:

• Stand-alone installations where users work on dedicated machines.
AND

• (Only if you have roaming users) Central machines (sometimes 
servers) where Master Roaming User files are stored.
Having Roaming User files lets providers run Dragon 
NaturallySpeaking on more than one machine or device by accessing 
centrally stored provider-specific voice and speech information, rather 
than requiring that the voice information be on each machine.

For each Master Roaming User (user files stored on the central machine), 
you should plan to have this much space:

• 25 MB for each set of roaming user files
• 8 MB for each additional vocabulary you add for this user
• 18 MB for each additional dictation source you add for this user
• 500 MB for acoustic optimizer data associated with each dictation 

source of each user. To set how much data is stored: 
– Verify that no users are open. (On the DragonBar, click 

NaturallySpeaking > Close User.)
– On the DragonBar, select Tools > Administrative Settings. The 

Administrative Settings dialog box opens.
– Check the Disk space reserved for network archive option.

In addition, for the Local Roaming User, you should plan to have the 
following space on each PC where the roaming user dictates:

• 25 MB for each set of roaming user files
• 8 MB for each additional vocabulary you add for this user

http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
http://support.nuance.com/compatibility/default.asp
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• 18 MB for each additional dictation source you add for this user
• 240 MB for acoustic optimizer data associated with each dictation 

source of each user. How much acoustic optimizer data is retained 
locally is controlled by settings on the Data tab of the Options dialog 
box (located under the Tools menu):
– To set the number of minutes of audio to retain locally, click the 

Archive size button and position the slider. 
– To turn off retaining this data locally, check the Conserve disk 

space required by user files (for portability) option.

For each non-roaming user, you should plan on approximately twice as 
much space as a Local Roaming User, because Dragon NaturallySpeaking 
periodically makes a backup copy of the files and stores it on the same 
machine. The product does not back up Roaming User files this way as 
they are located on a central machine that your Information Technology 
department should back up regularly.

About the Roaming User Feature

Most healthcare facilities use the Roaming User capability, which lets users 
dictate with Dragon NaturallySpeaking from different locations on the 
network using a variety of computing devices without having to create and 
train individual user files at each location. 

Ideally, you enable the roaming capability before you create users, but you can 
also enable it after creating them and convert those users to Roaming Users.

Some situations that the Roaming User feature makes possible:

• A healthcare provider may need to dictate reports in a medical office 
building using a desktop computer, in a hospital room using a Tablet PC, or 
at home using a laptop computer. The Roaming User feature allows the 
provider to use the same set of user files containing the same vocabulary 
words with the acoustic information from each location.

• You have a provider who uses the same laptop at multiple offices and at 
home. Before leaving the office, your provider loads a set of user files from 
a central location on the network to his laptop. Once home, the provider 
dictates and corrects as he or she normally would. When the provider 
returns to the office and reconnects the laptop to the network, the Roaming 
User feature synchronizes the updated user files on the laptop with those at 
the network’s central location the next time the provider loads his or her 
user files.
5
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Master Roaming User and Local 
Roaming User

When roaming users have been set up, each Dragon NaturallySpeaking user 
has a single Master Roaming User that can be opened from multiple 
networked machines running Dragon NaturallySpeaking. The Master 
Roaming User is stored on a network location accessible to all users. 

When a Master Roaming User is opened, Dragon NaturallySpeaking 
transfers a copy of that user from the central machine to the local machine 
where the user has been opened. That local copy is called the Local Roaming 
User. 

The Local Roaming User is based on the Master Roaming User data, but 
also contains locally stored modifications based on corrections made to 
recognized dictation and other acoustic data gathered during dictation sessions 
on the particular local machine.

Normally, you set a central storage location to contain all your Master 
Roaming User files. By downloading his or her Dragon NaturallySpeaking 
user files from the central network location, a user can dictate on any computer 
where Dragon NaturallySpeaking is installed. When the user exits Dragon 
NaturallySpeaking and saves the changes to the user files, these changes are 
saved on the local machine and also copied to the central location. The next 
time the user runs Dragon NaturallySpeaking, all the changes saved are 
available regardless of the computer on the network that is being used to 
dictate.

Choosing Type of Machine for 
Storing Roaming User Files

Dragon NaturallySpeaking lets you store your Master Roaming Users on one 
or more of the following types of network machines:

• Peer computer (usually in a shared folder)
• File server
• Web server
• Secure web server running SSL

Note: You are not required to store Master Roaming User files on a server. 
Any shared location accessible to other computers on the network is a 
perfectly acceptable place to store Master Roaming User files.
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Web Servers That Support Roaming User 
Feature (Not Required)
If you want to store your Master Roaming Users on a web server, Internet 
access to Master Roaming User files is supported on two web servers:

• Microsoft Internet Information Services (IIS) 6.0. For this type of server:
– You might need to install a third-party web server application called 

WebDAV. WebDAV software is required to access and secure Dragon 
NaturallySpeaking user profiles on the web server location. The 
WebDAV application is available free of charge at www.webdav.org.

– Digest authentication through a proxy server with Internet Information 
Server (IIS) 6.0 is not supported.

– If you have not already installed the WebDAV component, use 
Add/Remove Programs in Control Panel and run the Windows 
Components Wizard. See the Microsoft IIS documentation for details.

• Apache HTTP Server 2.0.54 and higher. For this type of server:
– Internet Roaming User—Redirects must be turned on when using 

Digest authentication.
– Be sure the server has Web-based Distributed Authoring and 

Versioning (WebDAV) turned on.

Setting Up the Roaming User 
Feature

On each computer where you plan to have users dictating as roaming users, 
you must tell that installation of Dragon NaturallySpeaking where the Master 
Roaming User files are located, which you do in several steps:

1. Set up and create a network storage location for the Master Roaming 
User files.

2. Allow full access to that location by all providers who dictate.
3. Gather information about the network storage location, such as how to 

access it.
4. Close any open users.
5. Set Administrative Settings that:

 a. Enable the Roaming User feature.
 b. Set the Master Roaming User network directory location(s).
7
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 c. Set up the HTTP or SSL connection (if applicable, as a Web server is 
not required).

 d. (Optional) Set the Local Roaming User local directory location(s).
6. Set additional Roaming User options.

The steps are covered in detail in the subsections that follow. 

Note: You can also set up roaming users during a network installation 
process by putting Roaming User settings into an .ini file and setting the 
DEFAULTSINI option of the MSI installer to the full path to that .ini file. 

Step 1: Set Up and Create Network Storage 
Location for Master Roaming User Files

Before setting up the Roaming User feature on individual machines:

1. Set up a network location for the Master Roaming Users. Each 
location you choose must be accessible by all computers where 
roaming users will dictate. You can create multiple network storage 
locations.

2. Set permissions on the directory that stores Local Roaming Users on 
each workstation to Full Control access for all Windows user accounts 
of providers who will be dictating with Dragon NaturallySpeaking. By 
default the directory that stores Local Roaming Users is 
C:\Documents and Settings\All Users\Application Data\ 
Nuance\NaturallySpeaking9\RoamingUsers. 
Or you can have all providers log in as administrative users, who would 
automatically have full access.

Dragon NaturallySpeaking lets you access your Master Roaming Users 
through four possible avenues:

• Mapped Drives—Connect to a shared network folder that has a drive 
letter assigned to it. 

• Universal Naming Convention (UNC) Paths—Connect to a shared 
network folder using the UNC to locate a user. The format is: 
\\servername\sharename\path\filename 

• HTTP (http:)—Connect to machine on the internet or your local 
intranet. The format is: http://myserver.com/webdav

• HTTP with SSL (https:)—Connect to machine on the internet or your 
local intranet with SSL. The format is: https://myserver.com/webdav 

A couple of possible ways you can set up and manage Roaming Users are:

• Create a single network directory dedicated to storing Roaming User 
files of all users.
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• Set up a Roaming User directory on each user’s home drive on the 
network.

Before you can connect to the machine where the Master Roaming 
Users will reside, first gather the following information:

• The network location of the master roaming user files: You later enter 
the location of the user files (for an HTTP server, you supply the URL 
address) in the Roaming User Network Location dialog box. 

• For a web server, the HTTP user name and password, authentication 
type, firewall and proxy server access information. Later, you put this 
information in the Authentication and Firewall and Proxy Server 
sections of the HTTP Settings dialog box.

• For a secure web server, the certificate store and certificate store type, 
the certificate store password, and a list of the protocols that are 
enabled (TLS12, SSL3, SSL2, and PCT1). If you are using OpenSSL, 
gather the cipher list, the location and name of the certificate authority 
(CA) file, and the location of the CA directory.

Step 2: Close Any Open Users
Note: You do not have to be running Dragon NaturallySpeaking to act as 
an administrator of the product. Instead, you can skip “Step 2: Close Any 
Open Users” on page 9 and open the Administrative Settings dialog box 
from the command line, as explained under “Step 3: Turn On Roaming 
User Feature” on page 10.

When you run Dragon NaturallySpeaking, you can be either a user or an 
administrator. To enable the Roaming User feature, you must be acting as 
an administrator. After you start the product, as long as you do not open a 
user, you are the local machine administrator; if a user is already open, to 
act as the administrator, you must first close the open user. 

To close all users:

• If you are setting up a new installation and when you start Dragon 
NaturallySpeaking, the New User Wizard dialog box opens, click 
Cancel to close the wizard.

• If the Open User dialog box opens when you start Dragon 
NaturallySpeaking, click Cancel. 

• If a user opens automatically (this occurs if only one user is available), 
then on the DragonBar, select NaturallySpeaking > Close User.

When you have closed any open users, proceed with the next section, “Step 
3: Turn On Roaming User Feature” on page 10.
9
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Step 3: Turn On Roaming User Feature
You must be a Windows user with administrator privileges to carry out tasks 
that involve opening the Administrative Settings dialog box in Dragon 
NaturallySpeaking. If you have administrative privileges, the following line 
appears in the Dragon.log file after you log in:
09:33:10 LOG (MainWin): Windows user has administrative access to NatSpeak

Note: If you decide to give a provider administrative privileges on a laptop 
computer, note that you are giving that provider access to the 
Administrative Settings dialog box on that machine.

To turn on the Roaming User feature:

1. If Dragon NaturallySpeaking is running, on the DragonBar, select 
Tools > Administrative Settings. The Administrative Settings dialog 
box opens (see next illustration) and you can continue with Step 4.
If Dragon NaturallySpeaking is not running, select Start > Run.

2. Type the following command line in the Open text box:
“C:\Program Files\Nuance\NaturallySpeaking9\Program\natspeak.exe” 
/SetDefaultAdministrativeOptions

Note: Be sure to put a space between natspeak.exe and the option that 
follows it, /SetDefaultAdministrativeOptions.

3. Click OK and the Administrative Settings dialog box opens. Initially 
the entire dialog box is grayed out, until you take the next step.
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Note: With the Roaming User enabled, the Open User dialog box displays 
only users in the Roaming User storage locations. To let the users open 
both local (non-roaming) and Roaming Users, check the Allow non-
roaming users to be opened option in the Administrative Settings dialog 
box. Clearing this option prevents users from dictating with a non-roaming 
(local) user by mistake, but you should check it now to ensure you can open 
local users when you want to later convert them to Roaming Users.

4. On the Roaming tab, in the Roaming User section, select Enable.

5. Click Apply to save the changes you made and keep the dialog box 
open.

6. Proceed with the next section, “Step 4: Set Master Roaming Users 
Location and Connection” on page 12.
11
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Step 4: Set Master Roaming Users Location 
and Connection

On each computer where providers will dictate as Roaming Users, you 
must tell that installation of Dragon NaturallySpeaking where the Master 
Roaming User files are located and, if necessary, create that location.

To set the location of Master Roaming User files: 

1. In the Administrative Settings dialog box, click the Add button in the 
Network Directories section. The Roaming User Network Location 
dialog box opens.

2. Set the Display Name to the way the name of the directory should 
display in other product dialog boxes. That name later appears in:
• Roaming tab of the Administrative Settings dialog box.
• Location of user files text box in the Open User dialog box. 
• Location of user files text box in the Manage Users dialog box.

3. In the Network Location section, enter the path to the network 
location in the Address text box, using the appropriate format for the 
type of storage location:

Storage Location Type Format of Location Path

Mapped Drive <drive letter:>\<folder name>. For example, Y:\roaming

UNC Path \\servername\sharename\path\filename

HTTP (http:) http://myserver.com/webdav

HTTP with SSL (https:) https://myserver.com/webdav
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Note: The location you choose must be accessible to all computers on the 
network to be available for dictation with Dragon NaturallySpeaking.

4. (Optional) If you are using a web server to store Master Roaming 
User files, click the HTTP Settings or SSL Settings button to set 
information specific to your HTTP or HTTPS connection and proceed 
with either “Setting Up HTTP Connection” on page 14 or “Setting Up 
SSL Connection” on page 17.
If you are not using a web server, click OK in the Roaming User 
Network Location dialog box and continue with “Step 5: Set Local 
Roaming Users Location” on page 20.
13
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Setting Up HTTP Connection

(Optional, non-secure web servers only) For HTTP locations, in the HTTP 
Settings dialog box, set:

1. In the Authentication section, check the Prompt for User and 
Password box if you want the user to be forced to log in to the HTTP 
server before dictating.

2. In the User text box under Default User and Password, be sure to 
enter the domain name followed by a backslash before the user name, 
as shown in the illustration above.

3. In the Password text box, enter the password to log in to the HTTP server.
4. Set the Authentication Type to either Basic or Digest. Choose Basic if 

the HTTP server is configured for Basic authentication, which 
transmits the username and password over the network as clear text. 
Choose Digest if the server is configured for Digest authentication, 
which encrypts passwords before it transmits them across the Internet.

Note: Be sure anonymous logins are disabled on the HTTP server.

5. If you are storing Master Roaming User files on a server that redirects 
incoming connections to another location, you can set how Dragon 
NaturallySpeaking handles these redirects under Connection: 
• Never ignores all redirects.
• Always follows all redirects.
• Same Scheme Only follows only redirects using the same scheme 

as the client request.
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6. Click Keep Connection Alive to keep the connection alive after the 
current session ends. 

7. If you are connecting to the server through a firewall or proxy server, in 
the Firewall and Proxy Servers section, select Use Proxy Server to 
connect through a proxy server.

8. In the Type text box, select the type of firewall used on the HTTP 
server from the drop-down list:
• HTTP Proxy—A proxy server that specializes in HTML (web 

page) transactions
• Tunnel: Select if you are connecting to the server with tunneling 

software. 
• SOCKS4—SOCKS4 is a protocol that relays TCP sessions at a 

firewall host to allow application users transparent access across the 
firewall. SOCKS4 does not support authentication, UDP proxy. 
SOCKS4 clients require full Domain Name Service (DNS).

• SOCKS5—SOCKS5 is a protocol that relays TCP sessions at a 
firewall host to allow application users transparent access across the 
firewall. SOCKS5 supports multiple authentication methods. 
SOCKS5 clients use the SOCKS5 server to perform the DNS 
lookup.

9. In the Server text box, enter the name of the server machine.

10. In the Port text box, enter the port that connects to the proxy server or 
firewall.
15
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11. In the User text box, enter any user name needed for the proxy server 
or firewall. 

12. In the Password text box, enter any password needed for the proxy 
server or firewall.

13. In the Firewall Data or Proxy Authorization text box, enter any 
special authentication string required to access the proxy server or 
firewall. 

14. In the Timeouts section, set the timeout requirements: 
 a. In the Lock text box, enter the number of seconds the server should 

wait before breaking the lock on any open Master Roaming User 
files. Setting the lock to 0 uses the default setting from the server. 
Specifying another time overrides the server default.

Note: A network lock prevents more than one user from opening a Master 
Roaming User at the same time. While the opening process does not take a 
long time, network problems can cause a lock to become stuck and not 
release when the open process is completed. When this happens, the next 
time someone tries to open that user, a message appears stating that the 
user is locked.

 b. In the Connection text box, enter the number of seconds after which 
to close the connection. 

 c. To indicate how the number of seconds is applied, select one of the 
options under Type.
• Inactivity—Close the connection if the roaming user is inactive 

for the number of seconds in the Connection text box. 
• Absolute—Close the connection after the number of seconds in 

the Connection text box have elapsed independent of the activity 
or inactivity of the user. 

Note: Nuance does not recommend you choose Absolute, as the connection 
could close during synchronization.

15. (Optional) To restore the default settings for the HTTP connection, 
click Restore Defaults.

16. After entering the HTTP settings, click the Test Connection button to 
make sure your settings are correct. If you cannot connect, revise your 
settings and try the button again.

17. Click OK in the HTTP Settings dialog box.
18. Click OK in the Roaming User Network Location dialog box.
19. Click Apply in the Administrative Settings dialog box.

Note: If you see a message asking whether to create the local roaming user 
directory, click Yes. If you already have a C:\Documents and 
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Settings\AllUsers\Application Data\Nuance\NaturallySpeaking9\ 
RoamingUsers directory on your machine, you do not see this message.

You have now returned to the Administrative Settings dialog box.

To proceed, continue with “Step 5: Set Local Roaming Users Location” on 
page 20.

Setting Up SSL Connection

(Optional, secure web servers only) For SSL locations, set the following in 
the SSL Settings dialog box:

1. In the Certificate Store section, you indicate the type of certificate that 
provides server identity, certificate, and public key information to 
clients that try to establish a connection:
 a. Certificate Store Type—Select the certificate store type used for 

the client certificate on the local machine:
• User (default)—or Windows, this specifies that the certificate 

store is a certificate store owned by the current user. For Java, 
this specifies that the certificate store is the name of a JKS (Java 
Key Store) file. If the provider is OpenSSL, this specifies that the 
certificate store is a file that contains the PEM encoded certificate 
and private key. 

• Machine—The certificate store is a machine store (not available 
in Java and when provider is OpenSSL). 

• PFX File—The certificate store is the name of a Private Key 
Server or PFX (PKCS12) file containing certificates. If the 
17
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provider is OpenSSL, the file can contain only one certificate and 
private key. 

• PFX Blob—The certificate store is a string (binary or base64 
encoded) representing a certificate store in PFX (PKCS12) 
format.

• PEM Key—The certificate store is a string or file name that 
contains a Privacy Enhanced Mail (PEM) encoded certificate and 
private key. This store type is currently not supported in Java. 

Notes: 

• If you select the Certificate Store Type as a PFX file, this property 
must be set to the name of the file. 

• If you select the Certificate Store Type as a PFX Blob, the property 
must be set to the binary contents of a PFX file (for example, the 
PKCS12 certificate store). 

 b. Certificate Store—Sets the name of the storage location (also 
called certificate store) used for the client certificate on the local 
machine. A certificate store will often have numerous certificates, 
possibly issued from a number of a different certification 
authorities:
• MY—A certificate store holding personal certificates with their 

associated private keys.
• CA—A certificate store holding Certifying Authority (CA) 

certificates.
• ROOT—A certificate store holding ROOT certificates.
• SPC—A certificate store holding Software Publisher Certificate 

(SPC) certificates.
• Other—Any other Certificate Store not listed above. 

 c. Certificate Store Password—Set to the password for the Certificate 
Store on the local machine if one is required. 

2. If your HTTPS server uses Open SSL (a free non-commercial 
implementation of SSL) as a certificate authority, under Open SSL:
 a. Check Using OpenSSL.
 b. Cipher List—Enter a string that controls the ciphers to be used by 

SSL. The list must consist of one or more cipher strings separated by 
colons.

 c. Certificate Authority File—Name of the file containing the list of 
CAs your application trusts. The file should contain a list of CA 
certificates in PEM format.



Chapter 1: Creating and Configuring Roaming Users
 d. CA Directory—Path to a directory containing CA certificates. The 
path should point to a directory containing CA certificates in PEM 
Format.

 e. Under General, check the SSL protocols you expect to use.

Note: If you are using OpenSSL, the property must be set to the name of 
the file containing a certificate and a private key.

3. In the General section, enable/disable the security protocols supported 
on the HTTPS server by checking those to enable:
 a. TLS1—Version 1 of the Transport Layer Security (TLS) protocol.
 b. SSL3—Version 3 of the Secure Sockets Layer (SSL) protocol.
 c. SSL2—Version 2 of the Secure Sockets Layer (SSL) protocol.
 d. PCT1—Version 1 of the Private Communications Transport (PCT) 

protocol.

Notes: 

• Although a number of sites still support SSL2, Nuance recommends 
that you disable it because of potential security vulnerabilities.

• If you select OpenSSL, this functionality is provided by the Cipher 
List.

4. After entering the SSL settings, click the Test Connection button to 
make sure your settings are correct. If you cannot connect, revise your 
settings and try the button again.

5. (Optional) To restore the default settings for the SSL connection, click 
Restore Defaults.

6. After filling in the SSL settings, click the Test Connection button to 
make sure your settings are correct. If you cannot connect, revise your 
settings and try the button again.

7. Click OK in the SSL Settings dialog box.
8. Click Apply in the Administrative Settings dialog box.

Note: If you see a message asking whether to create the local roaming user 
directory, click Yes. If you already have a C:\Documents and 
Settings\AllUsers\Nuance\NaturallySpeaking9\RoamingUsers directory 
on your machine, you do not see this message.

You have now returned to the Administrative Settings dialog box.

To proceed, continue with “Step 5: Set Local Roaming Users Location” on 
page 20.
19
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Step 5: Set Local Roaming Users Location
After you complete setup of a Master Roaming User directory, the name 
of the directory appears in the list in the Network Directories section in 
the Administrative Settings dialog box. (You can have more than one 
directory of Master Roaming Users.) When a provider opens a Master 
Roaming User, Dragon NaturallySpeaking transfers a copy of the 
associated user files to the local machine. That local copy is called the 
Local Roaming User. 

To set the location of Local Roaming User files: 

1. In the Local directory (for cache) box in the Administrative Settings 
dialog box, accept the default <Roaming Local> location by leaving 
this setting unchanged. When you later click OK in the 
Administrative Settings dialog box, you are then prompted to create 
the default directory if it does not already exist.

NuanceHospital Users X:\NuanceHospital\PhysicianUsers
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The default location of <Roaming Local> is C:\Documents and 
Settings\All Users\Application Data\Nuance\NaturallySpeaking9\ 
RoamingUsers\<display name>, where <display name> is the name 
you defined for the Master Roaming User location in the Roaming 
User Network dialog box.
OR
To change the default local cache storage location for Local Roaming 
Users, use the Browse button next to Local directory (for cache). 
When the Browse For Folders dialog box opens, enter the location on 
the computer where changes made during a dictation session, such as 
corrections or new acoustic data, are stored before they are 
synchronized with the Master Roaming User files stored remotely. 
Click OK to return to the Administrative Settings dialog box.

2. Click Apply.
3. Click OK and proceed to “Step 6: (Optional) Set Additional Roaming 

User Options” on page 22.
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Step 6: (Optional) Set Additional Roaming 
User Options

The Administrative Settings dialog box also contains several options that 
affect how the Roaming User feature works (see below). 

You can set the options to modify the behavior of a roaming user who 
dictates on this particular machine:

• Allow non-roaming users to be opened—Check to permit the user to 
open non-roaming (local) users. Clear check box to prevent anyone 
from dictating with a non-roaming (local) user by mistake.

• Merge contents of vocdelta.dat into network user when file is full—
Check to copy the contents of the local vocdelta.dat file to both Local 
and Master Roaming Users whenever the file is full, without having 
to run the Acoustic and Language Model Optimizer. After copying 
the content, Dragon NaturallySpeaking empties the file so it can receive 
new data. The operation occurs each time you open the Local 
Roaming User and can cause several minutes of delay. (vocdelta.dat 
contains the latest changes to the user’s vocabulary—including new, 
deleted, and modified words, as well as pronunciation and word 
property changes.)

NuanceHospital Users X:\NuanceHospital\PhysicianUsers
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• Access network at user open/close only—Check to synchronize user 
file changes made during a dictation session across the Local Roaming 
User and Master Roaming User only when Dragon NaturallySpeaking 
opens or closes. Otherwise, synchronization occurs each time the person 
dictating switches users, closes a user, or saves a user. If you experience 
excessive network slowdowns, checking this option may solve the 
problem by limiting how often user files are synchronized.

• Ask before breaking locks on network users (recommended for UNC 
and mapped drives)—Check to display the option of maintaining or 
breaking a network lock when opening a Roaming User. Network 
locks prevent more than one person from opening a Roaming User at 
the same time; while a program tries to break it, the lock can become 
“stuck” due to network problems and not release when the process is 
complete; then, the next time someone tries to open that user, a 
message states that the user is locked and gives the option of overriding 
that lock. To avoid display of the message and always break the 
network lock in this situation, clear this check box. Because a lock can 
indicate a problem that needs to be addressed, Nuance 
Communications recommends that you enable this option.

Note: The above option is valid for users connecting to the Master 
Roaming User location using a mapped drive or UNC drive, but is not 
supported for users connecting over HTTP. 

• Set audio levels on each machine (recommended)—Check to run the 
Check your audio settings option from the Accuracy Center window 
before each Roaming User dictation session. This includes the Volume 
Check and the microphone Quality Check. This option is helpful if 
your users work on different machines or work on a single machine, 
like a laptop, in many different locations. When a user changes 
machines or locations, the audio setup data can vary depending on 
differences in the microphone, sound card, and ambient sound levels of 
the location. In situations where Dragon NaturallySpeaking detects a 
significant difference between operating systems, sound cards, 
microphones, or other hardware, the program prompts you to run 
Check your audio settings even if this option has not been selected.

• Copy Dragon log to network—Check to copy the Dragon.log file 
from the Local Roaming User location to the Master Roaming User 
location at the same time that the program synchronizes the Local and 
Master Roaming Users. Dragon.log contains information that can 
help diagnose problems with using Dragon NaturallySpeaking.

Note: If you set the Disk space reserved for network archive option, the 
Dragon.log file is not copied once the storage reaches maximum size.

• Always copy acoustic information to network—Check to copy the 
user’s acoustic files (.usr and .sig) to the Master Roaming User 
23
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location as soon as the speaker’s user files are saved. (The Local 
Roaming User copies of .usr and .sig files are stored in: 
C:\Documents and Settings\All Users\Application Data\Nuance\ 
NaturallySpeaking9\RoamingUsers\<display name>\<username> 
\current\voice, where the <display name> is the name you defined for 
the Master Roaming User location in the Roaming User Network 
Location dialog box.)
Roaming Users using the same dictation source at multiple 
workstations benefit from checking this option, because by always 
copying .usr and .sig acoustic files to the Master Roaming User 
location, you ensure that corrections and new words are consistently 
available at all locations and are automatically synchronized when the 
Master Roaming User is opened from another location.
Additional acoustic files (.nwv and .dra) are always copied to the 
Roaming User location, even if you do not check this option.
If this option is not checked, changes to a Roaming User file on one 
machine are not automatically available on other network machines. To 
make changes available across the network, after changes to user files 
are saved from all roaming locations, you should run the Acoustic and 
Language Model Optimizer from the Master Roaming User location 
to optimize the Master Roaming User files with corrections, acoustic 
training, and new words. These changes then become available the next 
time the user is opened.

Note: Acoustic files (.usr and .sig) are always copied to the network 
location, even after the limit set for the Disk space reserved for network 
archive option has been reached.

• Conserve archive size on network—Select this box to prevent the 
copying of .DRA files (of acoustic data from the latest dictation 
session) to the Master Roaming User location when the program 
synchronizes the Local and Master Roaming Users. Leaving this box 
unchecked lets the local .DRA files synchronize with the Master 
Roaming User and makes the .DRA files available to the Acoustic 
and Language Model Optimizer when it runs on the Master 
Roaming User files, providing increased accuracy. 
However, .DRA files can be large. If you experience excessive network 
slowdowns, checking this option may solve the problem by eliminating 
the copying of these files each time the Master and Local Roaming 
Users synchronize. Running the Acoustic and Language Model 
Optimizer on the Master Roaming User is then more efficient, since 
it does not have to process the .DRA files.

Note: If you set the Disk space reserved for network archive option, the 
.DRA files are not copied once the maximum size is reached.
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• Disk space reserved for network archive—Use this option to specify 
the maximum size of the directory containing the acoustic data 
available to the Acoustic Optimizer. By default the archive size is  
500 MB. To conserve space, you can reduce the default size and select 
the Conserve archive size on network option. For this option to work, 
the machine you are setting it for must be connected to the network.

Creating a Roaming User

There are three ways to create a Roaming User:

• Create and train a new Roaming User
• Convert a non-roaming local user into a Roaming User
• Copy an non-roaming local users to the Master Roaming User location

Creating and Training a New Roaming User
To create and train a new Roaming User:

1. On the DragonBar, select NaturallySpeaking > Open User. The 
Open User dialog box opens. If you do not see the user you are looking 
for, hit F5 to refresh the list of users. 

Note: When the Roaming User feature is enabled, you can create only 
Roaming Users and the Location of user files field displays only the 
Roaming User locations you defined in the Administrative Settings dialog 
box, unless you checked the Allow non-roaming users to be opened 
option. If you can select both non-roaming Local and Roaming Users, or if 
you have set up more than one Roaming User location, be sure you select 
the correct location from the Location of user files drop-down list.

2. Click New and begin training the user as you would any other user.
For more information on creating and training a user, refer to Step 3 of 
“Creating User Files”.
When you are finished training the user, the program copies the user 
files into the master Roaming User location displaying in the Location 
of user files field.
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You can convert an existing non-roaming local user to a Roaming User 
from the Manage Users dialog box. Converting a non-roaming local user 
copies that user to the specified Master Roaming User location.

To convert a non-Roaming Local User into a Roaming User:

Note: To be able to open local users for conversion to Roaming Users, be 
sure you checked the Allow non-roaming users to be opened option in the 
Administrative Settings dialog box. 

1. Make sure that no local user is open; if a user is open, then on the 
DragonBar, select NaturallySpeaking > Close User.

2. On the DragonBar, select NaturallySpeaking > Manage Users. The 
Manager Users dialog box opens.

3. In the Location of user files drop-down list, select the location of the 
local user files. If you have not changed it, the location is <Default>.

4. Select the non-roaming local user you want to convert.

e
>
d.

al
ng
lt>
x.



Chapter 1: Creating and Configuring Roaming Users
5. Click the Advanced button and then click Save to Roaming.

The Save to Roaming dialog box opens. 

6. Select the Master Roaming User location where the converted user 
files will reside from the drop-down list and click OK. Master 
Roaming User locations appear in this list only if they are on machines 
currently available to the local machine over the network.

Note: In the Select Roaming Master Location to save the user to text box, 
you will see the Display Name(s) you created in Step 2 on page 12.

7. Repeat steps 4 through 6 for any other non-roaming local users you 
want to convert to Master Roaming Users.

8. When you have finished converting the users, while still in the Manage 
Users dialog box, you should be able to select the Master Roaming 
User location from the Location of user files drop-down list.

NuanceHospital Users
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The list in the next illustration shows saving some of the local users 
you saw earlier to the Master Roaming Users location. 

9. (Optional) Once the users are converted, to prevent providers from 
opening a local user instead of a roaming user, close all open users. On 
the DragonBar, select Tools > Administrative Settings and uncheck 
the Allow non-roaming users to be opened option, then click Apply 
and OK.

Copying a Non-Roaming User into the 
Master Roaming User Location

You can also convert a non-roaming user into a Roaming User by copying the 
user files into the network directory of the Master Roaming Users. This 
approach has the advantage of letting you convert several non-roaming users 
into Master Roaming Users at one time.

To copy a user into the Master Roaming User location:

1. If the Master Roaming Users are on an Apache server, skip this step. 
If they are on an IIS server, before you proceed, be sure you have 
Microsoft Web Folders functionality installed on your local machine. If 
it is not installed, visit http://www.microsoft.com/downloads/
details.aspx?familyid=17C36612-632E-4C04-9382-
987622ED1D64&displaylang=en and download the software.

Note: After you download the Web Folder functionality, you might need to 
try this copying action more than once before it succeeds.
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2. On the local hard drive, navigate to the location of the non-roaming 
local user files you want to convert to Master Roaming Users. By 
default, non-roaming user files are located in C:\Documents and 
Settings\All Users\Application 
Data\Nuance\NaturallySpeaking9\Users. You see a folder for each 
non-roaming local user, as shown in the example below. 

3. Select the folders of user files for each user you want to copy and copy 
them to the Master Roaming User location. Later, you see a folder for 
each roaming user on the Master Roaming User location. 

4. (Optional) Once you have copied the users to the Roaming Users 
location, to prevent providers from opening a local user instead of a 
roaming user, close all open users. On the DragonBar, select Tools > 
Administrative Settings and uncheck the Allow non-roaming users 
to be opened option, then click Apply and OK.
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Opening a Roaming User

Once you have created Roaming Users, you can open them from any machine 
connected to the location where Master Roaming User files reside.

To open a Roaming User from any machine connected to the Master 
Roaming User files location:

1. On the DragonBar, select NaturallySpeaking > Open User. The 
Open User dialog box opens. If you do not see the user you are looking 
for, press F5 to refresh the list of users.
If you allow providers to select both non-roaming local and Roaming 
Users, or if you have set up more than one Roaming User location, be 
sure providers know how to select the correct location from the 
Location of user files drop-down list.

Note: If you connect to your Roaming User Master Directory over HTTP 
or HTTP with SSL, and you find that not all your users are listed in the 
Open User dialog box, be sure that: 

• The .INI extension is registered in the MIME types (ini.png) list of your 
IIS server.

• Access to the user’s topics.ini file is not locked, password protected, or 
otherwise restricted by your server permissions.

2. Select a user and click Open.

Synchronizing Master and Local 
Roaming Users

Dragon NaturallySpeaking makes several changes when synchronizing Local 
and Master Roaming Users:

• Combines words added to the Local Roaming User during a dictation 
session with the Master Roaming User vocabulary.

• Removes words deleted in the Local Roaming User from the Master 
Roaming User vocabulary. 

• Copies acoustic data (from .DRA or .NWV files) from the Local Roaming 
User to the Master Roaming User where the data becomes available to 
the Acoustic and Language Model Optimizer. 

• Copies any custom commands locally created or modified using the 
MyCommands Editor to the Master Roaming User. 
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• Saves any local user options that you changed in the Options dialog box to 
the Master Roaming User, except for the following options. These options 
are not synchronized, but remain with the local roaming user only:

Data tab

• Conserve disk space required by user files (for portability)
• In the Advanced dialog box, Create usability log option 
• Incremental adaptation in general training 

Formatting tab

• Enable postal code commands 

Miscellaneous tab

• Use Active Accessibility for menu and dialog control 
• Launch in QuickStart mode on Windows startup 

Text-to-speech tab

• All options 

Hot keys PowerMic tab

• All options

Hot keys tab

• All options 

Note: During synchronization, changes to the Master Roaming User 
overwrite any changes you made to the Local Roaming User that was not 
on the network.
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Chapter 2

Creating and Training 
User Files

Objectives
In this chapter, you will learn:

• How to plug in a headset or handheld 
microphone

• How to start/stop Dragon NaturallySpeaking

• How to get help on Dragon NaturallySpeaking

• How to properly position the microphone

• How to control the microphone and how to set 
up a dictation source

• How to create user files for a provider

• How to choose the correct vocabulary

• How to select a provider name from a list

• How to add a new dictation source (audio 
device) for a user

• How to assign multiple vocabularies to a single 
user
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Connecting the Headset or 
Handheld Microphone

You can use Dragon NaturallySpeaking with either a headset or a handheld 
microphone. A headset might be easier to use if you dictate for long periods 
of time. You can use both types of microphones, even switch between 
types of microphones, but might achieve greater recognition accuracy if 
you use one type most of the time. For best accuracy, add a new dictation 
source for each type of microphone or recording device you might use. 

Your headset microphone’s cord has one plug for the microphone and one for 
the earphone; plug the earpiece into the sound system speaker jack. 

If you have multiple dictation sources, run this audio check on each: 

1. On the DragonBar, select Tools > Accuracy Center.
2. In the Accuracy Center dialog box, click or say “Check your audio 

settings.” 

Microphone Jacks

Locating the microphone jacks on your computer:

• Microphone jacks are located on your computer, sound card, or 
monitor. Consult your computer documentation if you need help 
locating your microphone jack. 

• Your computer might have two microphone jacks, one on the front and 
one on the rear. On some computers, the jack on the rear provides better 
sound quality than the one on the front.

• Microphone jacks are different from the Line In jack, which you 
normally should not use.

USB Microphones

USB microphones do not connect to a sound system. If you have a USB 
microphone, plug it into one of your computer’s USB ports. If you 
experience trouble plugging in your USB device, follow the instructions 
that came with it instead of this description.

Note: Dragon NaturallySpeaking Medical Edition has built-in support for 
Dictaphone PowerMic and PowerMic II microphones. On Windows Vista, 
only newer beige PowerMics work with Dragon NaturallySpeaking 
Medical Edition. To use a black PowerMic II in this configuration, first 
download and install a firmware update for the PowerMic II. 
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Starting Dragon NaturallySpeaking

To start Dragon NaturallySpeaking:

From the Windows Start menu, choose Start > Program Files > Dragon 
NaturallySpeaking 9.5 > Dragon NaturallySpeaking 9.5. Or double 
click on the Dragon NaturallySpeaking icon on your desktop.

Stopping Dragon NaturallySpeaking

To stop Dragon NaturallySpeaking:

• Click the Dragon Icon and select Close or say “Close DragonBar.”

OR

• On the DragonBar, select NaturallySpeaking > Exit.

Getting Help on Dragon 
NaturallySpeaking

To get help using Dragon NaturallySpeaking:

• Say “Give me help” 
OR

• On the DragonBar, select Help > Help Topics. The Dragon 
NaturallySpeaking Help dialog box opens.
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Positioning a Headset Microphone

To position your headset microphone correctly 
and consistently for optimal speech 
recognition:

1. Adjust the headset so that it fits comfortably 
on your head.

2. Move the microphone element to the side of 
your mouth to avoid noise from breathing 
(about a thumb’s width from the side of your 
mouth).

3. Confirm that the front of the microphone 
points toward the side of your mouth. The 
front of the microphone might be indicated 
by a colored dot, the word Talk, or some 
other label.

Positioning a Handheld Microphone

To position your handheld microphone correctly for optimal speech 
recognition:

1. Hold the microphone in a comfortable position. Be sure not to hold it in 
an awkward, tiring position.

2. Point the microphone head close to and directly in front of your mouth.
3. Hold the microphone consistently every time you use it.
4. Do not use a microphone stand or holder because it will be harder to 

keep a consistent position and the stand could conduct noise.
5. Do not dictate into the side of the microphone.

Controlling the Microphone

You can turn the microphone on and off with the mouse or keyboard. Using your 
voice, you can turn the microphone off or make it stop listening temporarily.

To turn the microphone on and off do one of the following:

• Press the plus key (+) on the numeric keypad.
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• Click the Microphone Icon on the DragonBar.
• Click the Microphone Icon in the Windows taskbar.
• Press the Dictate/Record button on your handheld microphone.

To make the microphone stop listening temporarily:

Say “Go to Sleep” or “Stop Listening.”

To reactivate the microphone:

Say “Wake Up” or “Listen To Me.”

Note: If you use the built-in switch to turn a handheld microphone on and 
off, wait a second after you turn the microphone on before you start 
dictating. This ensures that Dragon NaturallySpeaking recognizes the first 
thing you say.
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Creating User Files

Before you can begin using Dragon NaturallySpeaking with a microphone, 
headset, or portable recorder, you create a set of user files or a user specifically 
adapted to the sound of your recorded speech. 

Your user files store acoustic information about your voice that Dragon 
NaturallySpeaking utilizes to recognize what you dictate. These files also store 
any changes you make to the standard Dragon NaturallySpeaking vocabulary, 
for example, any specialized words, names, acronyms, and abbreviations you 
might add. 

You create a user by running the New User Wizard where you make several 
decisions about the user and type of recording device (dictation source) the 
user works with.

Caution: Most digital recorders require special software to transfer voice 
files from the recorder to the computer. Make sure that you have installed 
any software required by your recorder. Consult the documentation that 
came with your recorder for details.

To create a user:

1. On the DragonBar, select NaturallySpeaking > Open User. 
2. In the Open User dialog box, click New to start the New User Wizard. 

Note: If you have not previously created a user in Dragon 
NaturallySpeaking, the New User Wizard opens automatically  
when you start the program.
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3. On the Create User page of this wizard, enter a unique name in the 
Your name field for your user files. 

Note: Names can contain up to 128 characters, including spaces. Names 
are not case-sensitive. You cannot create names that are the same except 
for capitalization. For example, you cannot create both “Jean” and “jean” 
as user names.

4. In the Language box you see US English, the only language available 
in the Medical Edition. 

5. Select the appropriate audio device from the drop down list for 
Dictation source. The type of microphone or other device you are 
speaking into is called the Dictation Source. 

Note: If your device does not appear in the list, you must install the 
appropriate recorder software and be sure the device is connected to your 
computer. The list below does not show all dictation sources that you can 
use. For a complete list refer to the hardware compatibility list found at 
http://support.nuance.com/compatibility/default.asp. At the site, click on 
the product drop-down list, select Dragon NaturallySpeaking, and click 
Continue to proceed.

• If you have a Sony® recorder/digital voice recorder ICD-MS Series, 
a Sony IC recorder ICD-BP Series, a Sony IC recorder S series, a 
Sony IC recorder ST series, a Sony IC recorder ICD-CX Series, an 
Olympus® digital recorder DS-150/650, a Panasonic IC recorder, or 
a Pocket PC device, select that device from the list. 

• If you have any other digital recorder or a Palm OS® device, select 
Digital recorder using sound files (.wav, .mp3, .wma) on disk.

• If you have an analog recorder, select Recording device plugged 
into Line-In jack. 

Note: If you are using a Dictaphone PowerMic and you do not see the 
PowerMic listed as a dictation source, make sure that it is set as your 
default device for recording and playback. 

To set the default device for recording and playback: 

 a. Select Start > Control Panel.
 b. Find and open Sounds and Audio Devices.
 c. Click the Audio tab and set the PowerMic as your default device 

under both Sound playback and Sound recording. 
 d. Click Apply.
 e. Click OK.
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 Specialty

Addiction

Allergy

Anesthesia 

Angioplasty

Bariatric surgery

Breast surgery

Cardiac & thoracic sur

Cardiology

Cardiothoracic surgery

Cardiovascular (non-sur
6. Click the drop down list arrow for the Vocabulary field and select the 
particular vocabulary for the user from the drop down list.

Note: Commands Only is a restricted vocabulary of only command words 
and phrases; do not choose this vocabulary. General (US English) is a 
large vocabulary providing excellent recognition accuracy for general, 
business, and professional dictation. 

Choosing the Correct Vocabulary

Medical Vocabulary types that Nuance Communications recommends you 
select are in the table below.

 Choose...  Specialty  Choose...

MentalHealth Neonatology Pediatrics

GeneralPractice Nephrology GeneralPractice

Neurology Neurology Neurology

Neurology Neurosurgery Orthopaedic

Surgery Nuclear medicine Radiology

Surgery Obstetrics/Gynecology ObGyn

gery Surgery Oncology GeneralPractice

Cardiology Oncology Oncology

Cardiology Ophthalmology surgery Orthopaedic

gical) Cardiology Orthopedics Orthopaedic
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Chemotherapy

Colon & rectal surgery

Dentistry

Dermatology

Diabetes

Diagnostic radiology

EEG

Electrophysiology

Emergency medicine

EMG

Endocrinology

ENT surgery

Epidemiology

Family medicine

Fetal medicine

Gastroenterology

General pediatric surge

General Practice

Geriatric medicine (wit
significant cardiology conte

Geriatric medicine (gen

Hand surgery

Hematology

Immunology

Infectious diseases

Internal medicine 

Interventional radiolog

Language pathology

Medical education

Mental health

Midwifery

 Specialty
7. (Optional) Click the Advanced button to open the Advanced dialog 
box.

Cardiology Osteopathy GeneralPractice

Surgery Pain management Neurology

Orthopaedic Pathology Pathology

GeneralPractice Pediatric cardiology Cardiology

MentalHealth Pediatric dentistry Pediatrics

Oncology Pediatric endocrinology Pediatrics

Neurology Pediatric ENT Pediatrics

Cardiology Pediatric gastroenterology Gastroenterology

Emergency Pediatrics Pediatrics

GeneralPractice Perinatology ObGyn

GeneralPractice Physical therapy & rehabilitation Neurology

Orthopaedic Plastic surgery Orthopaedic

GeneralPractice Podiatry Orthopaedic

GeneralPractice Proctology Surgery

ObGyn Psychiatry MentalHealth

Gastroenterology Pulmonary GeneralPractice

ry Surgery Radiology Radiology

GeneralPractice Radiation therapy Oncology

h 
nt)

Cardiology Radiology Radiology

eral) GeneralPractice Reproductive endocrinology ObGyn

Orthopaedic Rheumatology GeneralPractice

GeneralPractice Sexual assault MentalHealth

GeneralPractice Sleep GeneralPractice

GeneralPractice Speech GeneralPractice

GeneralPractice Substance abuse GeneralPractice

y Neurology Surgery Surgery

MentalHealth Trauma surgery Surgery

GeneralPractice Urology Surgery

MentalHealth Vascular surgery Surgery

ObGyn Other or multiple specialties Medical

 Choose...  Specialty  Choose...
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This provides users with information about the language you are using, 
the vocabulary type, and the vocabulary size. It shows the speech 
model recommended for your machine and lets you select an 
alternative one from the Speech model drop-down list. You can choose 
from a speech model (see the table below) to achieve the greatest 
accuracy for the language, accent, and dictation source type of the 
provider.

Note: Skip the Advanced button unless you are dictating in English with an 
Indian accent; if you have an Indian accent, select the BestMatch III 
Medical Indian option from the drop-down list for Speech model. 

The Vocabulary size of any medical vocabulary is usually Large, 
meaning it is designed for computers with at least 512 MB of RAM.

Note: The Empty Dictation is a vocabulary language model with no words. 
(Not recommended.)

8. Click OK if you made changes or Cancel to exit the dialog box.

Speech Model Achieves Greatest Accuracy for...

BestMatch Array Speakers dictating into an array microphone.

BestMatch III US English speakers.

BestMatch III Medical Speakers using medical vocabularies.

BestMatch III Medical Indian US English speakers with an Indian accent.

Bluetooth 8kHz For US English speakers dictating into an 8 KHz 
Bluetooth device and transcribing audio from it.

Medical Bluetooth 8kHz For US English speakers dictating with medical 
vocabularies into an 8 KHz Bluetooth device and 
transcribing audio from it.
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Continuing Setup of User Files/Running Audio Tests
9. Although you can skip the initial training session of the New User 

Wizard by checking the Skip initial training of this user check box, 
before dictating medical reports, Nuance Communications advises that 
you perform the training. Performing the training when creating a user 
enhances your initial recognition accuracy. Initial training includes 
reading aloud for several minutes from text provided.

Notes: 

• You can choose the Skip initial trainingof this user option only for 
user files with USB microphones or microphones plugged into the 
Mic In jack of the computer, but not for user files created to work 
with array microphones, Bluetooth microphones, or portable 
devices. 

• If you skip the initial training of this user, it is important to read 
aloud the text exactly as presented when the New User Wizard leads 
you through the volume and quality checks for your microphone. If 
you want to do additional training at a later date, run general 
training from the DragonBar by selecting Tools > Accuracy Center 
and selecting Perform general training.

10. Click Next.

Note: If you have a PowerMic microphone and forgot to select a dictation 
source earlier in step 5, a Choose your sound system screen appears 
where you can select the brand name of your microphone and click Next. If 
you did choose a dictation source in step 5, you do not see that screen.

11. Click Next in the Position your microphone page of the New User 
Wizard.
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12. In the Adjust Your Microphone: Volume Check page of the New 
User Wizard, click the Start Volume Check button and read the text 
in the box above it. 

When the microphone volume has been adjusted, the product beeps and 
you click Next to continue to the next dialog box.

13. In the Adjust Your Microphone: Quality Check page of the New 
User Wizard, click the Start Quality Check button and read the text 
in the box above it. 
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Note: If you receive a FAILED in the Quality Check dialog box, click the 
Back button and go through the screens again.

Note: If you receive a warning that says The sound level is too high, low, 
or unacceptable. Try running the test again., you should reread the text. If 
this warning continues to appear, there might be a problem with your 
sound system. You can proceed; however, you might receive poor 
recognition accuracy.

When the microphone quality has been adjusted, the product beeps and 
you click Next to continue to the next dialog box.

Carrying Out Training
14. When the first Train Dragon NaturallySpeaking page opens, click 

Go and read the text in the box.  

(There are only two dialog boxes associated with this step.)
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15. When the Select Text dialog box opens, select the text you want to read 
from the list of choices and click OK.

Note: Choose the text that you are most comfortable reading; it does not 
have to be a medical document. If you prefer to read medical text, you 
might find the Radiology Reports the easiest one to read.

Before you begin reading:
• Position your microphone carefully.
• Sit up straight and speak as clearly as possible.
• Try not to pause using Ums or Ahhs or any similar word.
• Speak naturally, at a comfortable pace, pausing as you do normally.
• Take your time.
• Although you do not have to dictate the punctuation marks in the 

Train Dragon NaturallySpeaking page, if you are a first time 
speech recognition user, you should try doing so to get familiar with 
dictating punctuation marks.

• Do not dictate any capitalization commands, such as “Cap.”

Talking to your Computer (Easier Reading: Instructional)
Kennedy’s Inaugural Address (Medium Reading: Historical Speech)
Dave Barry in Cyberspace ((Medium Reading: Humor)
Medical Reports (Harder Reading: Medicine)
Radiology Reports (Harder Reading: Medicine)
Pathology Reports (Harder Reading: Medicine)
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16. Read the text presented on the next series of pages, which vary 
depending on the type of text you selected for training. For example, 
here is a sample Medical Reports training page:

While you read, text you have read becomes gray and text to be read 
remains black. A yellow arrow points to where you should resume 
reading.
You can click Pause if you need to stop reading, Redo if you want to 
start the page over, or Skip to skip the text.
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Note: If the arrow does not advance while you are reading, try reading the 
text again. If the arrow still does not advance, continue by clicking the Skip 
button. You might need to click the button twice. 

17. After you have finished reading the training passages, click OK in the 
Dragon NaturallySpeaking dialog box that congratulates you on 
completing the training.

Note: If you skip training, the wizard displays the Initialize user files 
dialog box while it prepares you for dictation.

Adapting Recognition to Your Writing Style

In these optional dialog boxes you can take action to further enhance the 
quality of recognition when you dictate email or documents. 

18. In the Adapt Dragon NaturallySpeaking to your writing style page 
of the New User Wizard, you can select E-mail and/or Documents 
check boxes to indicate the data that Dragon NaturallySpeaking should 
use to adapt to your writing style. 

Note: If you check Documents, Dragon NaturallySpeaking adapts only to 
text in documents it finds in your My Documents folder. If there are no 
relevant documents in My Documents, uncheck this box.

19. Because you need to wait up to 30 minutes for Dragon 
NaturallySpeaking to integrate emails and documents into your user 
files, Nuance Communications does not recommend you take this 
action in the classroom. Instead, skip this step by clicking the Skip this 
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step check box to the lower left. Or to initiate the adaptation process, 
click Start. 

20. When either the adaptation is complete or you have clicked the Skip 
this step check box, click Next.
If you skip adapting recognition to your writing style, you can return to 
the New User Wizard later and carry out the process:
 a. On the DragonBar select Tools > Accuracy Center.
 b. In the Accuracy Center dialog box, select or say either “Add 

words from your documents to the vocabulary” or “Increase 
accuracy from e-mail” and follow the instructions.
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21. In the Done page of the New User Wizard, choose one of three 
possible actions (below):

• Start the Tutorial — Brings up the tutorial.
• See what’s new in Version 9 — Opens the What’s new in Dragon 

NaturallySpeaking version 9 dialog box in the Help.
• Begin dictating — The wizard closes and you can then start 

dictating commands and/or create a report in an application, such as 
DragonPad, Microsoft Word, or other application.

22. Click Finish to proceed with the action you chose.
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Selecting a User from a List on 
Startup

After you have created user files for providers, when you start up Dragon 
NaturallySpeaking, the list of providers opens.

The list of users includes:

• Any user previously created on this computer.
• Any users imported from an earlier version (if your site has been upgraded 

to a newer version of the software).
• If your site allows roaming users, any roaming users on your system.
• If you have multiple dictation sources and/or vocabularies for a single user, 

multiple entries for that user. 

To ensure that you are working with user files that have stored your voice 
model based on previous dictation, you must choose your own user name from 
the list.

To access your user files and begin dictating:

1. Select your name from the list and click Open. You can get to your 
name quickly by typing the first few letters.

2. After the user files have been loaded, turn on the microphone and begin 
dictating.
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Adding a New Dictation Source 
(Audio Device) for a User

To add a new dictation source for a user:

1. On the DragonBar, select NaturallySpeaking > Open User.
2. Select the user name of the user for whom you are creating a new 

dictation source.
3. Click the Source button and then click New. This displays the New 

Dictation Source dialog box.

4. Select a new input device from the drop-down list in the New 
Dictation Source dialog box. 

5. Do not check the Skip initial training of this dictation source box.

Note: Nuance recommends that you immediately train the user on the new 
dictation source to ensure the highest quality speech recognition.

6. Click OK. You return to the Open User dialog box.
7. Select the user who is using the dictation source you just created and 

click Open. 
8. When the New User Wizard opens, begin training the user on this 

dictation source.
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Assigning Multiple Vocabularies to 
a Single User

To assign additional vocabularies to a single user:

1. Start up Dragon NaturallySpeaking and open the user who you want to 
assign additional vocabularies.

2. On the DragonBar, select NaturallySpeaking > Manage 
Vocabularies. The Manage Vocabularies dialog box opens containing 
a list of the vocabularies currently assigned to the open user.

3. To assign another vocabulary to the user, you must create a new one. 
Click New and the New Vocabulary dialog box opens.

4. Select a vocabulary to be the base vocabulary for the new one in the 
Based on text box.

Note: If the new vocabulary is to be used for non-clinical documents such 
as email messages, choose Base General - Large for the base vocabulary.

5. Assign the new vocabulary a name in the Vocabulary name text box. 
For simplicity, this name should be related to the base vocabulary 
name.

6. Click OK. 
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7. When the Vocabulary Optimizer dialog box opens, you can either 
click Cancel or click Start to run it. Because the optimization process 
can take anywhere from 5 to 30 minutes, in the classroom we 
recommend you skip it.

The Manage Vocabularies dialog box redisplays containing the 
additional vocabulary. 

8. (Optional) To immediately use the vocabulary with the open user, 
highlight the vocabulary and click Open.

9. Repeat steps 3 through 7 for each vocabulary you want to add.
10. When you have added all the vocabularies the user needs, and if you 

have not immediately used a vocabulary (step 8), click Close to close 
the dialog box.
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Note: If you skipped step #8, there is no dialog box to close and your new 
vocabulary is ready to be used. 

Opening the User with New Vocabulary
To open the user and select one of the new vocabularies:

1. On the DragonBar, select NaturallySpeaking > Open User. 
2. You now see the user listed once for each new vocabulary. 

3. Select that user with the vocabulary needed for the next dictation 
session. 

4. Click Open to open the user.
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Switching Vocabularies for Open User
If the user is already open and you want to switch vocabularies, on the 
DragonBar, select NaturallySpeaking > Open Recent Vocabulary and 
select the vocabulary you want from the list.
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Using the DragonBar

Objectives 
In this chapter, you will:

• Examine the DragonBar

• Identify the Dragon Icon

• Learn about the Microphone Icon

• Interpret colors on the Volume Display

• Work with the Select-and-Say Indicator

• Identify the DragonBar menus, Message Area, 
and Extras toolbar
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The DragonBar

The DragonBar is a special toolbar in Dragon NaturallySpeaking that appears 
at the top of your screen when you start the program for the first time. You can 
later change its appearance and behavior to suit your working style. For 
instance, you can set where the DragonBar appears and whether or not it 
appears on top of other dialog boxes.

You can turn on voice access to the DragonBar menus by saying 
“NaturallySpeaking”; after that, you can dictate the name of any DragonBar 
menu and that menu opens. 

The DragonBar contains the following elements, starting from the left side:

• Dragon Icon
• Microphone Icon
• Volume Display
• Select-and-Say Indicator
• Menus
• Message Area
• Extras toolbar icon

– Correction menu
– Playback toolbar
– Transcribe button
– User name
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Dragon Icon  

In the far upper left corner of the DragonBar, you see the Dragon Icon. You 
use the Dragon Icon to display a menu that controls how the DragonBar 
looks and acts on your screen.

Setting How DragonBar Looks/Acts
There are five different modes (or ways) for displaying the DragonBar. 

To change the DragonBar mode:

1. Click the Dragon Icon on the left side of the DragonBar to open the 
DragonBar shortcut menu. 
OR

2. Say “Switch To,” “Change To,” or “Select,” and the name of the 
mode if you have selected the Enable Natural Language Commands 
option on the Commands tab of the Options dialog box found under 
the Tools menu.

3. Click the mode you want:

Docked to Top Mode

Default mode. The DragonBar always stays at the top of the screen, 
elongated to stretch across the full width of the screen. The 
DragonBar appears in this mode the first time you run the 
application. 

Docked to Bottom Mode

The DragonBar always stays at the bottom of the screen, elongated 
to stretch across the full width of the screen. 

Note: If the Windows taskbar is visible at the bottom of the 
screen, the DragonBar appears just above it.
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Floating Mode

The DragonBar appears in a window you can drag around.

Cling Mode

The DragonBar clings to the top left of the active window. When 
you drag the active window to a new location on your screen, the 
DragonBar moves with it. 

Note: In Cling mode, you do not see the Extras toolbar icon.

Tray Icon Only Mode

The DragonBar is not visible on the screen and you do not have 
access to the DragonBar menu. Only the Microphone Icon in the 
Windows system tray indicates that Dragon NaturallySpeaking is 
running. To return to the last DragonBar mode, right-click the 
Microphone Icon and click Restore Previous DragonBar Mode.

Always on Top

To make the DragonBar always appears in front of other windows.

To make the DragonBar appear always on top:

1. Say “Make DragonBar Always on Top”
OR

1. Click the Dragon Icon on the DragonBar.
2. Select Always on Top from the menu.

OR

1. Right-click anywhere on the DragonBar.
2. Select Always on Top from the menu.

Note: To avoid having the DragonBar obscure windows such as the 
DragonPad and Help screens when you set it to Always on Top, you might 
have to move the secondary windows. 
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Microphone Icon and Volume 
Display  

When you click the Microphone Icon to turn the microphone on and off, 
notice how the icon appearance changes: 

• When the Microphone Icon is red and horizontal, the microphone is off. 
• When the icon is green and vertical, the microphone is on.
• When the icon is yellow and slanted to the right, the microphone is in Sleep 

mode. 

Note: The microphone might be in Sleep mode when you first start the 
product, if the option has been selected under Tools > Options on the 
Miscellaneous tab. If the microphone is in Sleep mode, you must say 
“Wake Up” or “Listen to Me” to activate it before beginning to dictate.

• To the right of the Microphone Icon is an oval-shaped Volume Display. 
The Volume Display indicates how well the program is hearing your voice. 
When the microphone is on, this bar indicates the input volume using 
yellow for low volume, green for normal volume, and red for high volume.

Note: If the volume is consistently low or high when you speak, you should 
redo the audio volume and quality check. 

To check the audio volume and quality:

1. On the DragonBar, select Tools > Accuracy Center. The Accuracy 
Center dialog box opens.

Note: If the Choose Your Sound System page appears, select the 
brand name of your dictation source and click Next.

2. Select Check your audio settings.
3. Click Next on the Audio Setup Wizard dialog box. 
4. Click Start Volume Check on the Audio Setup Wizard and read out 

loud the text in the box.
5. Click Next.
6. Click Start Quality Check and read out loud the text in the box. 
7. Click Finish.
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Select-and-Say® Indicator 

Normally you can dictate and use Dragon NaturallySpeaking voice commands 
in any text window of any application. However, you might occasionally find 
an application or a specific window where some voice commands do not work 
or do not work consistently. Such a window is called a non-standard window.

The Select-and-Say Indicator turns green when the cursor is in a window 
where all of Dragon NaturallySpeaking’s functionality is supported. 

When you are in a non-standard window, the Select-and-Say Indicator goes 
out, indicating that you might have some difficulty selecting and editing 
dictated text using voice commands. 

Also, when you start dictating into a non-standard window, the DragonBar 
displays an appropriate message like one of these:

Dictating into a non-standard window 

No speech available 
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DragonBar Menus

The menus on the DragonBar contain the commands you can use while 
working in Dragon NaturallySpeaking. 

Note: Some of these commands duplicate functions available from other 
parts of the DragonBar.

Message Area 

To the right of the menus is a box where messages display the current status of 
Dragon NaturallySpeaking, such as:

• Whether the microphone is on or off.
• The current dictation mode.
• If there are no user files loaded.
• If you are dictating in a non-standard window or application.

To hide the message box:

1. On the DragonBar, select Tools > Options. The Options dialog box 
opens.

2. Go to the View tab and uncheck Show messages.
3. Click Apply.
4. Click OK.

Extras Toolbar Icon  

Click the down arrow icon to display the Extras toolbar. The Extras toolbar 
appears along the bottom of the DragonBar and displays buttons for 
transcribing audio from a handheld recorder and playing back your dictation. 

Correction Menu 
Click the Correction button to stop playback and display the Correction 
menu to correct a mistake.
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Playback Toolbar 
The Playback toolbar contains the following controls that you use to 
control the playback of dictation:

• Begin Playback.
• Begin Fast Playback.
• Stop Playback or Text-to-speech.
• Skip backward.
• Skip forward.

Notes: 
• Unless your computer is equipped with a full-duplex sound card, it’s 

not possible to stop playback by voice, because the computer can’t 
hear speech when it’s playing back dictation.

• Playback is available only until you close a document. After you 
close a document, Dragon NaturallySpeaking deletes the recorded 
dictation for that document, unless you save the recorded dictation 
with the document.

Transcribe Button 
Click the Transcribe button to open the Transcribe a Recording or 
Transcribe from dialog box, where you transcribe recordings dictated on 
portable recorders. (See also “Transcribe Recording” on page 202.)

User Name 
The name of the current user appears on the Extras toolbar. You can click 
this name to open the Open User dialog box. When the Open User dialog 
box opens, it displays a list of user names. In this dialog box, you can:

• Open another user.
• View the properties of the current user.
• Create another user.
• Create a new dictation source.
• Delete an old dictation source.
• Change the location where your user files are stored (as long as they do 

not belong to a roaming user).
• For more information, refer to “NaturallySpeaking Menu” on page 168.

Note: Depending on how you have set the options, your providers might be 
able to change the location where their user files are stored.



Chapter 4

Dictating and Correcting 
Reports 

Objectives 
In this chapter, you will:

• Dictate text into DragonPad

• Edit recognized dictation with voice commands, 
keyboard, and mouse

– Select, correct, and revise text

– Delete text

– Capitalize words

– Break text into lines and paragraphs

– Hyphenate words

• Dictate punctuation marks

• Work with the Results Box

• Work with the Correction menu

• Use voice commands in the Correction menu

• Spell and add words during dictation

• Spell words into your document 

• Play back dictation in the Spell dialog box

• Use voice commands in the Spell dialog box
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Dictating Text into DragonPad

When you start Dragon NaturallySpeaking, before you open an application, 
only commands are available; once you open an application both dictation and 
commands are available.

To begin dictating, start the application you want to use, such as an Electronic 
Medical Record (EMR), Microsoft Word, or any word processor. You will use 
DragonPad in this course. DragonPad is a simple word processor that 
provides basic formatting options and the ability to save and print documents.

Although similar to WordPad, DragonPad contains speech recognition 
features not available in WordPad, such as the ability to save dictated audio of 
recognized text and the ability to defer or delegate correction of the text.

To start DragonPad:

1. Say “Start DragonPad.”
OR
On the DragonBar, select Tools > DragonPad. 

2. With your microphone turned on, begin dictating (see “About 
Dictating” on page 67).
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About Dictating
To dictate text:

1. Place the cursor where you want the text to go.
2. Turn on the microphone.
3. Dictate your text into the microphone.
4. Turn off the microphone.

Key points to keep in mind while dictating:

• You do not need to capitalize the beginnings of sentences. Dragon 
NaturallySpeaking automatically capitalizes after colons and periods.

• Dictate punctuation (period, comma, colon), new line, and new 
paragraph.

• Dictate acronyms, units of measure, blood pressures, dosages, and so 
on as you normally would.

• Speak in continuous phrases; this approach provides contextual clues 
about what you said and thus helps the software choose between 
homophones like “:” and “colon.” 

• Your first dictated words might take a few moments to appear on the 
screen. This is normal.

About Playing Back Dictation
Although Dragon NaturallySpeaking never makes a spelling error, the 
errors it does make can be challenging to find and fix. Sometimes what the 
program types looks very different from what you actually said.

To make correcting mistakes easier, Dragon NaturallySpeaking records 
your speech as you dictate into an electronic medical record (EMR), 
Microsoft Word, Corel WordPerfect, or DragonPad, and into most parts of 
dialog boxes where you can enter and edit text. When you check your work 
in these programs, you can play back some or all of the text to hear what 
you said.

To play back the audio in DragonPad, select the corresponding text and 
say “Play That Back.” Or say “Play Back Line,” “Play Back 
Paragraph,” or “Play Back Document.” 

You can also insert the cursor in the recognized text and say “Play Back to 
Here” or “Play Back from Here.”

Or you can use the Dragon NaturallySpeaking Sound menu options in 
DragonPad.
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Techniques for Correcting Text

When you correct recognition errors, Dragon NaturallySpeaking adapts your 
user files, so that the same errors are less likely to occur again.

The sections that follow describe the most basic techniques for correcting the 
misrecognitions. You can combine these techniques to suit your working style.

Correcting Text Using Voice Commands
To correct text using voice commands:

1. Say “Go To Beginning of Document.”
2. Look for the first misrecognition and say “Select” immediately 

followed by the text that is incorrect. Dragon NaturallySpeaking 
highlights the word or phrase.
For example, if Dragon NaturallySpeaking mistakenly typed the word 
turbans, say “select turbans.”
The Correction menu opens, showing a number of alternatives:
• If one alternative is correct, say “Choose” and the number of that 

alternative. For example, say:

“Choose Two”

Note: Do not say “Choose Numeral Two” or Dragon NaturallySpeaking 
will transcribe the phrase as the text Choose Numeral Two or Choose 2 
depending on how you set the automatic formatting properties for text on 
the Formatting tab of the Options dialog box found on the Tools menu.

• If none of the alternatives is correct, say:

“Spell That” 
and spell the correct word or words into the Spell dialog box; then 
say “OK.” 

3. Verify that the correct text appears in the document in place of the 
misrecognized text and continue to the next misrecognition.

4. Repeat the last two steps until all the text is correct.

Notes: 

• If you get a message in the status bar that there is nothing to correct, 
select the text you want to correct and say “Correct That” again.

• If you select a phrase to correct that includes automatically added 
punctuation, the list of corrections that appears in the Correction 
menu includes a version without the inserted punctuation.
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• To dictate the word “Correct” as the first word after a pause and not 
have it interpreted as a command, either say “Correct” and then 
pause, or hold down the Shift key while you dictate to force Dragon 
NaturallySpeaking to recognize the word as dictation and not as a 
command. 

Voice Commands for Correcting Text

Correcting Text with the Keyboard
To correct text with the keyboard:

1. Use the mouse or keyboard to move the insertion point to the beginning 
of the dictation you want to correct.

2. Press the Correction hot key to display the Correction menu. By 
default, the hot key is the minus (–) key on the numeric keypad. You 
can also click the Correction button on the Extras toolbar of the 
DragonBar

3. Press the Down Arrow key until the correct alternative is highlighted 
and press the Right Arrow key to replace the incorrect text with the 
corrected text.
If no alternative is correct, press the Down Arrow key until Spell That 
is selected and press Enter to open the Spell dialog box. Then type the 
correct word in the Spell dialog box and press Enter. 

4. Continue until all the text is correct.

To Say

Correct the last thing you said “Select That” or “Correct That” 

Correct the selected text “Correct That”

Correct a range of text “Correct dark through night” where dark is the 
first word to correct and night is the last word to 
correct. 
You do not have to include the entire phrase when 
you use this command.
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Correcting Text While Playing Back 
Dictation

To correct text while playing back dictation:

1. Use the mouse or keyboard to move the insertion point to the beginning 
of the dictation you want to correct.

2. On the DragonBar, select Sound > Play That 
Back or click the Begin Playback button on 
the Extras toolbar. 

3. When the playback of your dictation reaches a 
recognition error, press the correction hot key. 

Note: You can change any hot key assignment by going to the DragonBar 
and selecting Tools > Options, then selecting the Hot Keys tab. You then 
click the button for the action to take and press the new key or keys you 
want to use to take the action until the key sequence appears in the 
adjacent text box. 

If you have a PowerMic microphone, assign the hot keys in the Hot keys 
PowerMic tab. After you click the button for the action to take, press the 
PowerMic key you want to use to take the action until its name appears in 
the adjacent text box.

4. Click the Correction button on the Extras 
toolbar of the DragonBar.
The Correction menu displays Dragon NaturallySpeaking’s best guess 
of alternatives for the text you selected.
• If one of the alternatives is correct, press the Down Arrow key to 

highlight that choice and then press Enter to accept it. Playback 
continues automatically from the point where you stopped.

• If no alternative is correct, just type or say the correct text and click 
the Begin Playback button. Playback continues from the point 
where you stopped.

Begin Playback 
Button
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Selecting and Revising Text

When you are dictating, you can select text in several different ways.

Selecting Characters, Words, and Phrases
To select individual characters and words:

 

To select specific words:

Say “Select <text>”, where <text> is the word or phrase you want to select. 
The text must be visible on the screen for you to select it.

Examples

Say: “Select visualized”
Say: “Select multiple views”

To select a phrase or range of words:

Say:

“Select” <text> “Through” <text>

Outside the USA or Canada, say:

“Select” <text> “To” <text>

Examples

To select the words found in the thoracic spine, in the complete sentence: 
No abnormalities were found in the thoracic spine, say:

“Select found Through spine”

Say Then Say Then Say

“Select”
 

“Next” “Character” 
or
<1-20> “Characters”
or
“Word”
or
<1-20> “Words”

“Forward”

“Previous”

“Back”

“Last”

<text> “through” <text>
or
“to” <text>
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Selecting Correct Text 
When you select text by dictating Select, then the text you want selected, 
Dragon NaturallySpeaking finds the instance of the text nearest to the 
current insertion point. Sometimes the program selects the wrong words or 
selects the right words, but not from the correct location.

When the wrong text is selected, to have Dragon NaturallySpeaking 
select the correct text:

• Try dictating Select <text> again. This time, Dragon NaturallySpeaking 
searches for different text with a similar pronunciation.

• Try using a longer phrase to provide Dragon NaturallySpeaking more 
information; then it is more likely to select the correct text.

• If the correct words were selected but not from the correct location, say 
“Select Again” to select the previous/next occurrence of the same text.

You can resume editing text using the Resume with <text> voice 
command. Then, dictate the revised text.

Notes: 

• Insertion point movement commands deselect any text that is 
selected.

• You can select punctuation marks by voice; for example, say “Select 
comma.”

• You can cancel a selection by saying “Unselect That,” selecting 
different text, or moving the insertion point in the document.

• To dictate the word “Select” as the first word after a pause and not 
have it interpreted as a command, either say “Select” and then 
pause, or hold down the Shift key while you dictate to force Dragon 
NaturallySpeaking to recognize the word as dictation and not as a 
command. 
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Deleting Dictated Text

Use the following procedure to remove text from a document.

To delete the last words you dictated:

Say:  “Scratch That” 

To delete any text:

1. Select the text.
2. Say: “Scratch That”

or  “Delete That”

Note: You can repeat “Scratch That” up to ten times to delete words you 
just said one at a time, or you can just say “Scratch That <2-20> Times.”

Deleting by Backspacing
To delete characters to the left of the insertion point:

Say:  “Backspace”

or “Backspace” <number of characters to delete from 2 to 20>

Examples:

Say: “Backspace” 
to delete one character or space.

Say: “Backspace 5” 
to delete back 5 characters.

Note: Commands to delete by words or paragraphs do not work in 
programs unless those programs use the same shortcut keys as WordPad. 
Commands to delete by paragraph work only in Microsoft Word and Word 
Perfect.
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Deleting Characters, Words, Lines, or 
Paragraphs

To delete characters, words, lines, or paragraphs:

Example:

Say: “Delete Previous 4 Lines”

Say Then Say Then Say

“Delete” “Next” “Character”

“Previous” “Character”

“Last” <2-20> “Characters”

“Word”

<2-20> “Words”

“Line”

<2-20> “Lines”

“Paragraph”

<2-20> “Paragraphs”
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Capitalizing Text

Dictate a command without pausing to affect the word or phrase you 
say immediately after it. 

 

To change what you just said or change the selected text:

Notes: 

• If “Cap That” produces the word That, make sure you are not in 
Dictation mode and try holding down the CTRL key to force the 
command to be recognized.

• You can also use “Format That Caps,” “Format That Uppercase,” 
and “Format That Lowercase” in DragonPad, WordPad, Microsoft 
Word, Microsoft InfoPath, and Corel WordPerfect.

To Say

Start the next word with a capital, in this example, 
Hemoglobin

“Cap hemoglobin”

Start typing words with Initial Capitals “Caps On”

Stop typing words with initial capitals “Caps Off”

Type the next word in all uppercase, in this example, 
ASSESSMENT

“All-Caps 
assessment”

Start typing words in ALL UPPERCASE “All-Caps On”

Stop typing words in all uppercase “All-Caps Off”

Type the next word in all lowercase, in this example, jack “No-Caps Jack”

Start typing words in all lowercase “No-Caps On”

Stop typing words in all lowercase “No-Caps Off”

To Say

Capitalize The First Letter Of Each Word “Cap That”

APPLY ALL UPPERCASE “All-Caps That”

apply all lowercase “No-Caps That”
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Adding New Lines and Paragraphs

Adding New Paragraph or Line
While you are dictating, to simulate pressing the Enter key once (to add 
a new line) or twice (to add a new paragraph): 

Note: Saying “New Paragraph” simulates pressing the Enter key twice 
and capitalizes the next word you dictate.

Moving the Cursor within a 
Document

Moving the Insertion Point to the Beginning 
or End of a Document or Line

To move the text insertion point to the top or bottom of a document and 
the beginning or end of a line: 

To Say

Add a new line “New Line”

Add a new paragraph “New Paragraph”

Say Then Say

“Go to”
or
“Move to”

“Top”

“Top of Document”

“Beginning of Document”

“Start of Document”

“Bottom”

“Bottom of Document”

“End of Document”

“Beginning of Line”

“Start of Line”

“End of Line”
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Examples

Say: “Go to Top” 
Say: “Move to End of Line”

Moving the Insertion Point by Characters, 
Words, Lines, Sentences, or Paragraphs

To move the insertion point by characters:

To move the insertion point by words:

To move the insertion point by lines: 

To move the insertion point by sentences:

Say Then Say Then Say

“Move” “Right” <1-20>
or
“a character”
or
<1-20> “characters”

“Left”

“Forward”

“Back”

Say Then Say Then Say

“Move “Right “a Word”
or
<1-20> “Words”

“Left

“Forward

“Back

Say Then Say Then Say

“Move
 

“Up <1-20> “Lines”

“Down

Say Then Say Then Say

“Select “Period “Select again”
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To move the insertion point by paragraphs: 

Examples

Say: “Move Right 3”

Say: “Move Back 15 characters”

Say: “Move Left 3 Words”

Say: “Move Forward a Word”

Say: “Move Up 3 Lines”

Say: “Move Down 5”

Say: “Move Up a Paragraph”

Say: “Move Forward 8 Paragraphs”

Moving Insertion Point to Specific Words
To move the insertion point before or after a specific word:

Say one of these phrases:

“Insert Before” <text>  
“Insert After” <text>

 

Note: Do not pause anywhere in the middle of saying these commands. For 
example, “Insert Before Esophagus” is all one command.

Say Then Say Then Say

“Move “Up “a Paragraph”
or
<1-20> “Paragraphs”

“Back

“Down

“Forward

To Say, for example Phrase This Way

Move the insertion point before the word thoracic “Insert Before Thoracic”

Move the insertion point after the phrase pineal 
gland

“Insert After Pineal 
Gland”
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Hyphenating Words

Dragon NaturallySpeaking automatically hyphenates words based on standard 
usage, but you can also insert hyphens manually.

To hyphenate words:

Say “Hyphenate That” and the product hyphenates the last phrase you 
said. You can also select specific words and say “Hyphenate That.”

Spaces between words are replaced with hyphens. Any tabs or line breaks 
are also replaced.

Note: To hyphenate words as you dictate, say “hyphen” between words. 
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Dictating Punctuation Marks

Below is a list of the common punctuation marks you can dictate. 

To enter Say (for All Dialects) Say (in Particular Dialects)

, “comma”

. “period”
“dot”
“point”
“full stop”
[each one has different spacing 
characteristics]

? “question mark”

! “exclamation mark” “exclamation point” (US/Canada)

“ “open quote”
“begin quote”

” “close quote”
“end quote”

‘ “open single quote”
“begin single quote”

’ “close single quote”
“end single quote”

( “left parenthesis” 
“open parenthesis” 

“left paren” (US)
“open paren” (US)

) “right parenthesis” 
“close parenthesis”

“right paren” (US)
“close paren” (US)

’ “apostrophe”

’s “apostrophe-ess”

- “hyphen”
“minus sign”

-- [double hyphen] “dash”

“space bar”

{ “left curly brace”
“open curly brace”

“left brace” (US)
“open brace” (US)

} “right curly brace”
“close curly brace”

“right brace” (US)
“close brace” (US)

~ “tilde”
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Note: You can have Dragon NaturallySpeaking automatically insert 
commas and periods; on the DragonBar, select Tools > Options. Under the 
Formatting tab, check Automatically add commas and periods. For more 
information see “Formatting tab:” on page 194.

[ “open square bracket”
“open square”

] “close square bracket”
“close square”

^ “caret”

& “ampersand”

< “less then sign”

> “greater then sign” 

: “colon”

; “semicolon”

# “number sign”

% “percent sign”

+ “plus sign”

/ “slash”

To enter Say (for All Dialects) Say (in Particular Dialects)
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Working with the Results Box

The Results Box is the small, floating box that displays text or commands after 
you say them and while Dragon NaturallySpeaking is analyzing them. When 
Dragon NaturallySpeaking finishes processing, it enters the text into the 
document or executes the command.

Notes: 

• The contents of the Results Box can change several times while 
Dragon NaturallySpeaking performs speech recognition.

• You can also move the Results Box anywhere on the screen, keep it 
in one place, and make it disappear after a recognition. For more 
information see “View tab:” on page 188.

• If the borders of the Results Box turn blue, then Dragon 
NaturallySpeaking has interpreted that dictation as a command 
rather than text to transcribe. The only exception to this behavior is 
when you say dictation commands such as “New Line” or “New 
Paragraph.”
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Stopping Recognition in Progress
You can stop recognition in process when it is taking too long and/or when 
you want to change what you said.

To stop recognition that is in progress:

Click the small red button inside the Results Box. 

Dragon NaturallySpeaking stops recognition processing and turns off the 
microphone.

Note: The red button appears only while a recognition is in progress.

Click
this button
to stop a
recognition
process
that is taking
too long
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Working with the Correction Menu

To bring up the Correction menu during dictation:

1. Select the text you want to correct. For example, in the text shown 
below, you would say “Select the” (without pausing) to imitate a 
correction of the word the. The word becomes highlighted.
The Correction menu automatically opens and displays several 
possible replacements for the selected text.

Note: You can also click the Correction button in the Extras toolbar, 
located on the DragonBar.

Note: You can change the number of choices offered to you in the list. On 
the DragonBar, select Tools > Options. Then on the Correction tab, 
choose a number in the Show no more than n choices box.

2. You can, for instance in the example shown above, say “Choose 2” or 
select that option from the menu with the mouse to correct the text.
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Using Voice Commands in the 
Correction Menu

Correction Menu Voice Commands 

To choose a line with the correct text from the list of choices:

Say: “Choose” <n> 

where <n> is the number of the correct alternative.

The text of the numbered choice replaces the selected text and the menu 
closes.

If none of the choices in the list are correct:

Say: “Spell That”

The Spell dialog box opens where you can spell the word or phrase, train 
the pronunciation if you want, and add it to your vocabulary.

Note: The Correction menu must be active (its title bar highlighted) for the 
voice commands to work.

Option How to Use

“Choose”  
<number from list 
of choices>

If one alternative is correct, give the number of that alternative. 
By default, the Correction menu displays up to five choices.

“Spell That” Opens the Spell dialog box where you can add words to the 
vocabulary by spelling and, if you want, by training them.

“Play That Back” Plays back the audio for the selected text.

“Cap That” Capitalizes the initial letter in the selected word or words.

“Unselect That” Deselects the selected word or words. 

“Correction 
Options”

Opens the Correction tab of the Dragon NaturallySpeaking 
Options dialog box, where you can modify the behavior of the 
Correction menu and specify whether saying “Correct” or 
“Select” opens it.
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Spelling and Adding Words During 
Dictation

If Dragon NaturallySpeaking misrecognizes a word, it could be because that 
word is not in the program’s vocabulary. You can add it to the vocabulary by 
spelling it in the Spell dialog box. You can also train Dragon 
NaturallySpeaking to recognize how you pronounce the word or phrase you 
spell.

To spell a word or phrase:

1. Select the word or words you want to correct, then say “Spell That.”
The next illustration shows the Spell dialog box opening and offering a 
list of possible corrections to the selected text.

2. For this example, when the Spell dialog box opens; say “Choose 2” 
and the correct word replaces the misrecognized one in the document. 

3. (Optional) To train the pronunciation of the word, click Train or say 
“Click Train” and follow the instructions in the “Train Words” 
dialog box.

4. (Optional) To play back the audio, click the Play Back button.

Notes: 

• You cannot use the Spell dialog box to add a word that has hyphens 
or spaces. The program recognizes each part of such a word as 
separate pieces. For example, if you tried to use the Spell dialog box 
to add the name Havisham-Smythe, you would actually be adding 
the names Havisham and Smythe. The next time you spoke the name 
you would get Havisham Smythe without the hyphen. To add such a 
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word or name, use the Vocabulary Editor dialog box (on the 
DragonBar, select Words > View/Edit).

• If you use the “Spell That” command, dictating the characters 
immediately is optional; instead, you can wait for the Spell dialog 
box to open before you begin spelling. By spelling words while the 
Spell dialog box is open, you can confirm that the word is correct 
before it appears in your document and you can also then train the 
pronunciation of the word.

• Normally, the Spell dialog box does not appear in response to the 
“Spell” command unless you select Spell commands bring up Spell 
dialog box option on the Correction tab of the Options dialog box 
found under the Tools menu.

• While you are spelling words, you must say “Cap” before each 
character you want to capitalize.

• You can say “Double” before any alphabetic character to enter two 
of the character, except “Double u” for uu (and not w). In this case, 
you can say “Double Letter u” or “Double Zulu” to enter zz.

• You cannot say normal forms of letters (for example “A”) and 
alpha-bravo forms of them (for example “Zulu”) together in a 
single breath (“A Zulu”), unless you pause before changing the 
spelling format.

Spelling Words into Your 
Document

You can dictate numbers, letters, and punctuation or spell names or complex 
technical terms into your document. Dragon NaturallySpeaking recognizes the 
individual letters, numbers, and punctuation marks as you speak them. 

Spelling words into your document is useful for introducing new technical 
terms or names that you do not want to add to the active vocabulary as well as 
for entering alphabetic and/or numeric identifiers.

To spell a word directly into your document without adding it to the 
vocabulary:

1. Say “spacebar” unless you do not want a space before the word.
2. Pause.
3. Say “spell,” then without pausing say the letters that make up the word.
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Notes: 

• Say “Cap” before any letter you want to capitalize.

• If you neglect to say “Cap,” after spelling the word you can pause 
and say “Cap That” or “All Caps That.”

• Use the normal forms of letters or the alpha-bravo letters, but not 
both.

• Words you spell directly into the report while the Spell dialog box is 
closed are not added to the vocabulary.

Examples:

To spell Chantix into the report without adding it to the vocabulary, say 
either of the following:

• “Spell cap c h a n t i x”
• “Spell cap charlie hotel alpha november tango india xray”

Playing Back Dictation in the Spell 
Dialog Box

If you are correcting text by spelling, you can play back the dictation that 
produced the text you are correcting.

To play back dictation in the Spell dialog box:

1. Click or say “Play Back” to play dictation for the text that is in the 
text-editing box.

2. When playback is complete, you can edit the text to match what you 
said.

Note: If dictation audio is not available, the Play Back button appears 
dimmed. Recorded speech is not available for text that was typed or pasted 
into a document.
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Using Voice Commands in the 
Spell Dialog Box

You can use the following commands in the Spell dialog box to select one of 
the numbered alternatives.

To choose a line with the correct text from the list of choices:

Say: “Choose” <1-9>

The dialog box closes.

To select a line from the list of choices in the Spell dialog box and put it 
in the edit box:

1. Say: “Select” <1-9>

2. You can then change the text either by voice or typing.

To move the insertion point to a specific word or character in the edit 
box:

1. Say: “Move Left” (or “Right”) <1-10> “Words”
OR
“Move Left” (or “Right”) <1-10> “Characters”
The insertion point moves to the left or right the number or words or 
characters.

2. Say: “Go To End of Line”
OR
“Go To Beginning of Line”
The insertion point moves to the beginning or end of the line.

Note: When you spell, you can dictate nearly any standard Windows 
character as you normally say it.
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Chapter 5

Advanced Voice 
Commands 

Objectives 
Note: Not all formatting commands shown in this chapter work 
in all applications. 

In this chapter, you will edit recognized dictation with advanced 
voice commands, keyboard, and mouse:

• Selecting parts of a document

• Cutting, copying, and pasting

• Formatting text and numbers

• Setting font, name, size, and style

• Aligning text and breaking into lines and paragraphs

• Joining words
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Selecting Parts of a Document

To select one or more lines or paragraphs: 

Cutting, Copying, and Pasting

You can speak commands to cut, copy, and paste selected text to and from 
documents.

To cut selected text:

Say:  “Cut That” 

To copy selected text:

Say:  “Copy That”

OR 

“Copy All To Clipboard” 

To paste cut or copied text:

Say:  “Paste That” 

Say Then say Then say

“Select” “Next” “Line” 
or
<1-20> “Lines”
or
“Paragraph”
or
<1-20> “Paragraphs”

“Forward”

“Previous”

“Back”

“Document”

“All”
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Formatting Text

To format text you have just dictated or text you have selected:

You can combine different formatting and font style commands. For example, 
you can say either one of these:

“Format That Bullet Style Italic”

To Say 

Apply bold “Bold That” or “Format That Bold”
Apply italics “Italicize That” or “Format That Italics”
Apply bold italics “Bold Italic That” or “Format That Bold Italics”
Add underlining “Underline That” or “Format That Underline”
Add strikeout “Format That Strikeout”
Remove all bold, italics, 
underline, and strikeout 
formatting

“Restore That or Format That Regular” or 
“Format That Plain”

Change text to initial capitals “Format That Caps” or “Format That Initial 
Caps”

Change text to uppercase “Format That Uppercase ”or “All-Caps That”
Change text to lowercase “Format That Lowercase” or “No-Caps That”
Create a bulleted list “Format That Bullet Style”
Put hyphens between words “Hyphenate That”
Combine multiple words into 
one

“Compound That”
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Setting Font Name, Size, and Style

You can use commands to specify any combination of font name, size, and 
style, in that order. These commands change both selected text and text you 
dictate from then on.

To set a font name, size, or style:

Say one of these:

“Set Size” 
“Set Font Size” 
“Format That”

then the font name, size, and/or style.

Examples:

“Set Font Times”

“Set Font Size 12 Points”

“Format That Courier 18 Points Bold”

“Format That Arial 12 Points”

Notes: 

• You can specify any combination of font name, size, and style, but 
you must specify them in that order (name, size, style). To specify 
only size, you are required to dictate “Points.” 

• Not all formatting commands work in all applications. These 
commands work only in applications that have rich text controls, 
including Microsoft Word, Microsoft InfoPath, Corel WordPerfect, 
DragonPad, and WordPad. Check the Command Browser for 
additional application-specific commands.

• Commands that start with “Set Font” change both selected text and 
text you dictate from then on.

• Commands that start with “Format That” change only the selected 
text or what you just said.
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Formatting Numbers

You can have Dragon NaturallySpeaking type your dictation as numerals. You 
can also change the format of numbers while you are dictating them or while 
you are editing existing numbers that you have selected.

To format dictation as numerals:

Say:  “Start Numbers Mode”

To turn off Numbers mode:

Say:  “Stop Numbers Mode”

To change text to numbers:

Say: “Format That Number”

Examples:

To change numbers to text:

Say: “Format That Spelled Out”

Examples: 

Note: You can select text that contains several numbers separated by 
words. When you say one of these commands, the numbers all reformat 
without changing the words.

To change from To Say

Twenty-fifth 25th “Format That Number”
5 million 5,000,000 “Format That Number”

To change from To Say

5 million five million “Format That Spelled Out”
27 twenty-seven “Format That Spelled Out”
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Aligning Text

To align text as you are dictating or text that you have selected: 

Note:  In the DragonPad, when you use the “Format That” command to 
align an empty paragraph, the previous paragraph is aligned also. To 
prevent this, dictate some text in the new paragraph before saying the 
alignment command.

To Say One of These

Center text “Center That” 
“Format That Centered”

Left align text “Left Align That”  
“Format That Left Aligned”

Right align text “Right Align That”  
“Format That Right Aligned”



Chapter 6

Building a Vocabulary in 
Dragon NaturallySpeaking

Objectives 
In this chapter, you will learn about personalizing the vocabulary 
of Dragon NaturallySpeaking:

• Personalizing your vocabulary

• Adding individual words

• Adding words through the Vocabulary Editor

• Training words 

• Adding words from documents

• Adding lists of words

• Changing word properties

• Deleting words from the vocabulary
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About Vocabularies

A vocabulary in Dragon NaturallySpeaking is a body of information that 
includes a word list and a language model. The word list includes information 
about all the words that the program can recognize. The language model 
contains usage information about those words. Dragon NaturallySpeaking uses 
a vocabulary to recognize words correctly based on not only the sound of the 
words, but their context as well. 

When you create a new user or new vocabulary for an existing user, you select 
an existing vocabulary to become the basis for the vocabulary you are creating.

Understanding Vocabulary Size
When you create a set of user files, Dragon NaturallySpeaking recommends 
the vocabulary that best fits your computer’s speed and memory. The size of 
the vocabulary is often set to Large to indicate it is designed for computers 
with at least 512 MB of RAM. A vocabulary labeled Empty Dictation has a 
language model but no words and is designed to be a starting point for creating 
specialized vocabularies.
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About Personalizing Your 
Vocabulary

You can personalize a vocabulary to more closely match your writing style and 
to recognize any special words that you dictate. You do this in several ways:

• By adding individual words
• By adding words through the Vocabulary Editor
• By adding entire documents that you write
• By adding lists of words that you prepare
• By spelling words into the Spell dialog box

The software adds these new words to the vocabulary and updates the 
vocabulary with information about your word usage, improving the likelihood 
that Dragon NaturallySpeaking will correctly recognize what you say.

If you use multiple-word phrases with unusual capitalization (for example, 
National Park Medical Center), you improve recognition accuracy by adding 
these phrases to the vocabulary before Dragon NaturallySpeaking analyzes 
your documents. Add these phrases using the Vocabulary Editor dialog box 
(say “Edit Vocabulary” or on the DragonBar select Words > View/Edit) or 
by including them in lists that you import into the vocabulary.

Notes: 

• You are not required to train new words because Dragon 
NaturallySpeaking automatically guesses the pronunciations based 
on their spelling. If, however, your new words are not recognized 
correctly, you can train them.

• Be sure to save your user files after adding new words or the new 
words will not be saved. Save the user files by going to the 
DragonBar and selecting NaturallySpeaking > Save User Files. 
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Adding Individual Words to Your 
Vocabulary

The active vocabulary is stored in the computer’s memory and contains the 
words that Dragon NaturallySpeaking is most likely to recognize on the first 
try, without you taking corrective action. 

If Dragon NaturallySpeaking gets a word wrong, it might be because the word 
is not in the active vocabulary. In this situation, you can use the following 
procedure to add that word so that it is readily recognized in the future.

Note: When you add individual words, they are added to the vocabulary 
currently in use.

To add individual words:

1. On the DragonBar, select Tools > Accuracy Center.
2. In the Accuracy Center dialog box click or say “Add a single word to 

your vocabulary.”
3. In the Add Individual Word dialog box that opens, spell (by voice) or 

type the word you want to add.

4. Click Add. 
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Note: If you selected the I want to train the pronunciation of this word 
check box in the Add Individual Word dialog box, the word you entered 
appears in the Train Words dialog box, where you teach Dragon 
NaturallySpeaking your pronunciation of the word. 

5. Click Go and dictate the pronunciation of the word. 
6. Click Done when you are finished.

Chantix
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Adding Words through the 
Vocabulary Editor

You can add words and phrases to the vocabulary or view and train dictation 
commands to customize your vocabulary.

You begin by viewing your active vocabulary using the Vocabulary Editor.

To open and work in the Vocabulary Editor:

1. On the DragonBar, select Words > View/Edit. The Vocabulary 
Editor dialog box opens.

2. In the Written form field, you specify the word or words in the 
Dragon NaturallySpeaking vocabulary that you want to find or select 
by typing the word letter by letter. As you enter letters, the list of words 
changes. If the word is in the list, it comes to the top. You can also:
• Scroll the list of words.
• Click words to select them.
• Use the Ctrl and Shift keys to select multiple words.
• Type into the word list box to search for words.

Note: Words with a written form that begin with a number, such as 99th, 
appear in the list before words that begin with the letter a.

3. In the Spoken form field, specify the sound of a word or words when 
spoken. 

Note: If the written and spoken forms are the same (the word sounds the 
way it is spelled), leave this box empty.
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• For initials spoken letter by letter without periods, such as UPMC, 
no spoken form is needed. 

• If a spoken form requires a single letter, enter the letter with a 
period, for example A. or B. or use a word that sounds like the letter; 
for example, if the written form is B+, enter the spoken form as 
either B. positive or be positive. 

• For numbers, spell out the numbers in the spoken form. For 
example, if the written form is STS-7, enter the spoken form as: 
STS seven. If the written form is 20/20, enter the spoken form as 
twenty twenty. 

• For a phrase that needs to be capitalized in a certain way, enter the 
phrase with the correct capitalization in the Written form field. You 
do not need to enter a spoken form. For example, add National 
Park Medical Center as the written form.

4. The list below the Written form and Spoken form fields lists all 
words currently in the active vocabulary.
• Dictation commands, such as backslash, are located at the top of the list. 
• Words stored only in the backup dictionary are not listed. 
• A red star  next to a word indicates that it is a custom word that 

has been added to the vocabulary. 
• A blue star  next to a word indicates that the properties of the 

word have been changed from the default properties. 
• A green star  next to a word indicates that a word was moved 

from the backup dictionary to the active vocabulary due to a 
correction. (The backup dictionary contains all vocabulary words.) 

Note: To have new words automatically added to the vocabulary: On the 
DragonBar, select Tools > Options. When the Options dialog box opens, 
on the Correction tab check Automatically add words to the vocabulary.

5. Use the Display drop-down list to select the type of words you want to 
appear in the list. The choices are:
• All words—Displays all the words in the current vocabulary. 
• Custom words only—Displays only words added to the vocabulary 

by the user. 
• Words with spoken forms only—Displays only words with spoken 

forms that are different from their written forms. 
• Words with formatting properties only—Displays only words 

with special formatting properties that influence how they appear in 
the transcription of dictated text. 

• Words containing spaces—Displays only words containing spaces. 
For example, anorexia nervosa.
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• Words containing digits—Displays only words containing digits. 
For example, B12.

• Words containing punctuation—Displays only words containing 
punctuation. For example, X-ray. 

• Words containing capital letters—Displays only words containing 
capital letters. For example, Zyrtec. 

• Temporary Words—When you reply to a message while dictating 
in Outlook and Outlook Express, Dragon NaturallySpeaking finds 
new words from the original email message and recognizes them. 
When you use these words in replying to an email, these words are 
added as temporary words. For example, if you reply to an email 
that contains the drug name Zomaril and you use Zomaril in your 
reply, Zomaril is added as a temporary word. When you send an 
email using temporary words, those words are permanently added to 
the vocabulary.

• Words from the Backup Dictionary—The backup dictionary 
contains all vocabulary words stored on the computer’s hard drive. 
Dragon NaturallySpeaking moves frequently used words from the 
backup dictionary into the active vocabulary. To move the word into 
the active vocabulary, use the Correction menu to correct the error, 
then save the user files.

Note: Specialized words, names, acronyms, and abbreviations 
might not be in the backup dictionary. You must add them 
manually by way of the Vocabulary Editor.

6. Close —Closes the dialog box.
7. Add —Adds the specified word to the vocabulary. 
8. Delete —Removes a word from the vocabulary. 

Note: You should not delete some common words, because that would 
adversely affect recognition accuracy.

9. Train —Opens the Train Words dialog box, so you can train a word, 
phrase, or dictation command.

10. Properties —Opens the Word Properties dialog box, where you can 
change the way a word or phrase appears when transcribed.
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Changing Word Properties

Word properties affect how Dragon NaturallySpeaking performs certain types 
of formatting such as spacing, capitalization, and spelling out numbers.

Some changes that are occasionally requested in healthcare are:

• Capitalize automatically after the New-Line or Next-Line command 
• Force small numbers (1 through 9) to be formatted as digits rather than 

spelled out when used before or after certain words such as times or units 
of measure

To capitalize the word after a New-Line or Next-Line command:

1. On the DragonBar, select Words > View/Edit. The Vocabulary 
Editor dialog box opens.

2. Scroll to the top of the Written form list (above the word a) and select 
the word with New-Line as the Spoken form.

3. Click the Properties button to the lower right. The Word Properties 
dialog box opens.

4. In the Use alternate written form drop-down list, select New line and 
capitalize next.
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5. Click OK. You return to the Vocabulary Editor dialog box.
6. Repeat steps 2 through 5 for Next-Line so that it behaves the same way 

as New-Line.

Training Individual Words

If Dragon NaturallySpeaking is not recognizing a certain word or phrase, and 
you have tried correcting it at least twice, then you should train that word or 
phrase to teach Dragon NaturallySpeaking exactly how you pronounce it.

Two different ways to train words or phrases are:

• Train words and phrases immediately after dictating them.
• Train individual words and phrases at any time.

Training Words Immediately after Dictating
To train individual words and phrases immediately after dictating 
them:

1. Correct the misrecognized word or phrase you want to train and say 
“Train That.”

2. Click Go in the Train Words dialog box and record your speech saying 
the word or phrase you want to train.

• Clicking Done ends the recording process.
• Clicking Cancel stops recording and erases all recording since you 

last clicked Go.
3. When you have finished recording the text, click Done.

erythromycin
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Training Words at Any Time
To train individual words and phrases at any time:

1. On the DragonBar, select Words > Train. The Training dialog box 
opens.

2. Type the word or phrase you want to train.
3. Click Train and the Train Words dialog box opens. 

4. Click Go and record your speech saying the word or phrase you want to 
train.

5. (Optional) If you make a mistake, click Cancel and the recording is 
erased.

6. When you have finished recording the text, click Done.

Note: You can also use the Train button in the Vocabulary Editor dialog 
box. When you train a word or phrase using the Train Words dialog box, 
you add to the acoustic data stored for later use by the Acoustic and 
Language Model Optimizer. This data includes your pronunciation and 
the acoustic differences between the trained correction and the 
misrecognized word or phrase.

neurocardiogenic
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Adding Words from Documents

You can use the Add Words From Documents tool to add words from 
documents to your vocabulary. Dragon NaturallySpeaking uses these words 
and phrases to update the vocabulary with information about your word usage. 
To achieve the best results, remove all formatting from the documents you use.

Preparing Documents to Add Words From
To prepare documents to add words from, follow these guidelines:

• Paragraphs: Separate each paragraph with a blank line.
• Tables and bulleted lists: Unconverted content will be processed, but 

due to limited context, might not include useful information for 
determining your writing style.

• Columns: Convert text in two or more columns to a single column.
• Captions: Convert captions to text if they contain relevant information. 

Otherwise they will be ignored.
• Bold or italicized text: This text might contain coding tags that can 

decrease accuracy if you do not convert it.
• Remove:

– Graphics: Graphics slow processing. Text within bitmap graphics is 
not processed.

– Headers, footers, and titles: If they contain important information, 
move them into the body of the document, otherwise remove them.

– Tables containing numbers: Numbers provide no useful input.
– Duplication: Because it might adversely affect statistical 

information, remove duplication when possible. 

Note: If you use several documents that contain the same medical text, 
leave that text in one document and remove it from the others.

Adding Words from Documents
To add words from documents:

1. On the DragonBar, select Tools > Accuracy Center.
2. In the Accuracy Center dialog box click or say “Add words from 

your documents to the vocabulary.”
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3. In the Add Words from Documents page of the Add Words from 
Documents wizard dialog box, place a check mark next to one or more 
of available options that apply:

• Find unknown words
– Find known words with unknown capitalization
– Preview the list of unknown words

• Adapt to writing style
4. Click Next and the Add Documents page of the wizard opens.
5. Use the Add Folder and Add Document buttons to browse and find 

the files. The documents then appear in the Document List. 
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Notice that the Remove Document and View Document buttons are 
grayed out until you select the name of a file to remove or view.
 a. If you make a mistake, to get rid of a file you imported, click the file 

name in the list, then click the Remove Document button. 
 b. To preview a document, click the file name in the list, then click the 

View Document button. 
6. Click Next. The Document Analysis dialog box displays while the 

analysis occurs. 

7. When the analysis completes, click Next.

Note: If Dragon NaturallySpeaking finds no new words to add, a message 
stating that appears. Click OK, then click Next to move to the Summary 
dialog box where you then click the Finish button.

If new words were found, the Add Words to Vocabulary page of the 
wizard opens.
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8. Place check marks next to words to be downloaded and uncheck the 
ones you do not want. 
 a. The Check All or Uncheck All button lets you check or uncheck all 

words to make selecting and deselecting the words easy.
 b. Click Edit to edit the word before adding it to the vocabulary.

9. Click Next.
10. (Optional) When the Train Words page of the wizard opens, you have 

the opportunity to check off the words you want to train. If you selected 
words, you can now train them by clicking the Train button.
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11. Whether or not you selected words to train, click Next and the process 
of adapting to your writing style begins. 

12. When the adapting to your writing style completes, click Next. The 
Summary page of the wizard then displays the number of words found, 
the number of words added to the vocabulary, and a message that the 
adaptation of your writing style was successful. 

13. Click Finish to close the dialog box.

Notes: 

• If you make a mistake and do not want to add the words, avoid 
making additional changes to the vocabulary that you want to save. 
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Then exit Dragon NaturallySpeaking. When you are prompted to 
save your user files, click No.

• The Add Words from Documents dialog box sometimes adds words 
that differ from words in the vocabulary only in case (upper- or 
lowercase). It is a good idea to use Preview Words to make sure you 
do not add any unnecessary words.

Adding Words from Lists

You can create a list of words to add directly to your vocabulary.

Preparing Lists of Words to Add
To prepare a list of words to add to a vocabulary:

1. Create a document for the new words. You can use any word processor 
to create the document as long as you can save the final version as a 
text (.txt) file. 

2. Enter each word on a separate line. Make sure words are spelled and 
capitalized correctly. 

3. To add a multiple-word phrase, such as Accu-Check Advantage, enter 
it on one line.

4. To include a spoken form for a word, type the word followed by a 
backslash (\) and the spoken form. For example, to have Dragon 
NaturallySpeaking enter University of Pittsburgh Medical Center 
when you say “UPMC” type: University of Pittsburgh Medical 
Center\UPMC

5. Save the document as a text (.txt) file. 
6. (Optional) Create a folder for storing all word lists you create.

Adding Lists of Words
To add words from a list

1. On the DragonBar, select Tools > Accuracy Center.
2. In the Accuracy Center dialog box, click or say “Add a list of words 

to your vocabulary.”
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3. (Optional) In the Add Words from Word Lists page of the Add 
Words from Word Lists wizard dialog box, place a check mark next 
to Preview the list of unknown words.

4. Click Next.
5. In the Add Word Lists page of the wizard, use the Add File button to 

browse and find files. The document names appears in the File List.

Notice that the Remove File and View File buttons are grayed out until 
you select the name of a file to remove or view.
 a. If you make a mistake and want to get rid of the file you imported, 

click the file name in the list, then click the Remove File button.
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 b. (Optional) To preview your document, click the file name in the list, 
then click the View File button.

6. Click Next, then click Next again.

Note: If you did not select Preview the list of unknown words earlier, the 
Summary dialog box now displays the number of words added to the 
vocabulary. Click Finish to close the dialog box and skip the remaining 
steps.  

7. If new words were found, the Add Words to Vocabulary dialog box 
opens. Place check marks next to words to be downloaded and uncheck 
the ones you do not want. 
 a. The Check All or Uncheck All button lets you check or uncheck all 

words to make selecting and deselecting the words easier.
 b. Click Edit to edit the word before adding it to the vocabulary.
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8. Click Next. The Train Words page of the wizard opens.

9. (Optional) You now have the opportunity to place check marks next to 
the words you want to train. If you select words to be trained, you can 
train them by clicking the Train button.

10. Whether or not you selected words to train, click Next. The Summary 
dialog box then displays the number of words found and the number 
added to the vocabulary. 

11. Click Finish to close the dialog box.

Notes: 

• Use the Add Words from Word List wizard if you want to add 
multiple-word phrases to your vocabulary, even if they are used in 
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documents that you will process using the Add Words from 
Documents wizard. You should do this because the Add Words from 
Word List wizard adds words from documents as single words, not 
phrases.

• You can create a list of the custom words you have added to a user 
by exporting these words to a file. 

Exporting Custom Words to a File

You can create a list of the custom words that have been added for a provider 
by exporting these words to a .txt file. You can then add those words to another 
provider’s vocabulary by importing the .txt file into that provider’s vocabulary.

To export custom words:

1. Open the user whose custom words you want to export.
2. On the DragonBar, select Words > Export.
3. When the Export Custom Words dialog box opens, navigate to the 

directory to export the file into and assign the file a name with a .txt 
extension.

4. Click Save to save the file.
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Importing Custom Words from 
Another User

Once you have exported custom words to a .txt file, you can add those words 
to another provider’s vocabulary by importing the .txt file for that provider.

To import custom words exported from another provider’s user files:

1. Open the user whose vocabulary you want to add the custom words to.
2. On the DragonBar, select Words > Import. The first page of the Add 

Words from Word Lists wizard opens.
3. (Optional) In the Add Words from Word Lists page of the Add 

Words from Lists Wizard dialog box, check Preview List of 
Unknown Words, then click Next. The Add Word Lists page of the 
wizard opens. 

4. Use the Add File button to browse and find files to import into this 
user’s vocabulary and click Open. The names of the files appear in the 
File List.

5. If you click on a file name in the list box, you can click the View File 
button to open and review the contents of the .txt file or click Remove 
File to remove a file from the list.

6. Click Next and the File Analysis dialog box of the wizard opens. Click 
Next again.
If new words were found, the Add Words to Vocabulary page of the 
wizard opens.
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7. Place check marks next to words to be downloaded and uncheck the 
ones you do not want. 
 a. The Check All or Uncheck All button lets you check or uncheck all 

words to make selecting and deselecting the words easy.
 b. Click Edit to edit the word before adding it to the vocabulary.

8. Click Next.
9. (Optional) When the Train Words page of the wizard opens, you have 

the opportunity to check off the words you want to train. If you selected 
words, you can now train them by clicking the Train button.

10. Whether or not you selected words to train, click Next and the process 
of adapting to your writing style begins. 

11. When the adapting to your writing style completes. The Summary 
page of the wizard then displays the number of words found, the 
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number of words added to the vocabulary, and a message that the 
adaptation of your writing style was successful. 

12. Click Finish to close the dialog box.

Note: If the user is a Roaming User, changes to the vocabulary are not 
copied to the network until you save the user.
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Deleting Words

Normally, you do not need to delete words from the active vocabulary. If a 
word is regularly confused with another one that you never use, however, you 
might want to delete the word you never use.

To delete words from the active vocabulary:

1. On the DragonBar, select Words > View/Edit to open the Vocabulary 
Editor dialog box.

2. In the Written form box, type the letters of the word until the word 
appears in the list. Or scroll the list to find the word and select it.

3. Click Delete and confirm the delete operation. Then, close the 
Vocabulary Editor dialog box.

Notes: 

• If you delete a word using the Vocabulary Editor dialog box, but 
that word exists in the current document, the word might be 
automatically added back into your active vocabulary.

• There are several thousand common words in the active vocabulary 
that you cannot delete.
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Chapter 7

General Application 
Navigation 

Objectives 
In this chapter, you navigate your desktop and applications using 
voice commands. Here are some of the actions you will take:

• Starting and exiting programs

• Opening and closing documents

• Controlling a window size

• Switching between windows

• Controlling menus

• Selecting buttons and dialog box options

• Selecting tabs in a dialog box

• Selecting and opening icons

• Scrolling in windows and lists

• Controlling the keyboard

• Positioning the mouse pointer with MouseGrid

• Moving and copying objects
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Starting/Exiting Programs and 
Opening/Closing Documents

Note: Not all commands work in all applications. 

You can use the following technique to start programs by voice that appear 
anywhere on your Start menu or your desktop. You can also open documents 
or folders by voice.

To start a program, including the application, or open/close a document 
or folder:

To access some built-in items on the main section of the Windows Start 
menu, including Shut Down, Help, Run, and the Favorites, Find, and 
Settings menus:

Example:

To open the Recycle Bin:

Say “Start Recycle Bin.”

To open the Windows Start menu:

Say “Click Start Menu.”

To exit a program or close a document or folder:

Say “Close Window.”

Or say “System Menu” and then “Close.”

To close the program:

Say “Close NaturallySpeaking” or “Close DragonBar.”

To start the Find Files or Folders tool: 

Say “Click Start” and then “Find Files or Folders.”

Say Then say

“Start”  
or  
“Close”

<name of program or item on the Start menu>

<name below icon on desktop>

Say Then say

“Click Start” <name of each menu until you reach program you want>

“Click Start Menu”
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Note: In some versions of Windows you must close any open applications 
before you can exit the Windows desktop with the voice command “Shut 
Down Windows.”

Controlling Window Size

Note: Not all commands work in all applications. 

You can use voice commands to close a window, control the window size, and 
switch to the previous or next window of a running program.

To control a window’s size:

Say one of the following commands:

• To enlarge the active window to the size of your monitor’s screen: 

• To minimize the active window to a taskbar icon: 

• To return a maximize window to its original size:  

Example:

To minimize the current window:

Say “Minimize Window.”

Say Then say

“Maximize” “Window”

Say Then say

“Minimize” “Window”

Say Then say

“Restore” “Window”
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Switching Between Windows

Note: Not all commands work in all applications. 

To switch between windows:

Example:

To move the cursor to an open Microsoft Word document:

Say “Switch to Microsoft Word”

To move the cursor to an open Notepad document:

Say “Switch to Notepad”

Note: If a program shows both the program and document name in its title 
bar, you can say either name. You do not have to dictate both names.

Say Then say

“Switch to”  “Previous Window”

“Next Window”

<program or document name>
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Controlling Menus

Note: Not all commands work in all applications. In some versions of 
Windows, a feature called Active Accessibility must be on in order for you 
to control certain windows menus and controls by voice. Set the Use Active 
Accessibility for menu and dialog control option on the Miscellaneous tab 
of the Options dialog box in order to use voice commands to control 
menus. This option is initially on by default.

You can open, close, and choose items from the menus in most programs by 
voice. To control the menus in a window, the window must be active.

To open a menu:

Example:

To open the File menu in Microsoft Word:

Say “Click File” or “File”

To choose an item from an open menu:

Say “Click” followed by the name of the item or just say the item.

If the “File” menu is open, say “Click New” or “New.”

Example:

To close a menu:

Say “Cancel”

Note: By default, you do not have to say “Click” before the name of any 
menu other than the Start menu. If you want to require that “Click” must be 
spoken, select the Require “Click” to select menus and controls box on the 
Commands tab of the Options dialog box found on the Tools menu.

Caution: In Office applications on the Microsoft Windows XP operating 
system, you cannot control menu items by voice that have changed position 
in an automatically expanding menu. 

For voice control of menu items at all times, turn off the expanding menu 
feature in the Customize dialog box of the Microsoft Office XP application 
you are using; for instance, in Microsoft Word.

Say Then say

“Click” <name of the menu>

<name of the menu>
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To turn off expanding menus in Microsoft Office XP:

1. On the menu bar, select View > Toolbars > Customize. The 
Customize dialog box opens. 

2. Click the Options tab.
3. Check the Always show full menus option.
4. Click Close to close the dialog box.

Selecting Buttons and Dialog Box 
Options

Note: Not all commands work in all applications. 

You can select buttons and dialog box options by voice when the dialog box is 
the active window.

To select a button or option in the active window:

Example

To change the measurement units in a Microsoft Word document, say:

1. “Click Tools.”
2. “Options” (to open the Microsoft Word Options dialog box).
3. “General” (to open the General tab).
4. “Measurement Units” (to open the measurement units list).
5. “Move <direction and number of items>” (for example “Move Up 

One” to move the selection from Centimeters to Millimeters).
6. “OK” (to accept the new measurement unit and close the Options 

dialog box).

To open a list:

If the list is selected (the item displayed is highlighted), say “Expand List” 
or “Drop List.” 

If the list is not selected, say the name of the list. To open the next list, say 
“Press Tab” and then either “Expand List” or “Drop List.”

Say Then say

“Click” <name of the button or option>

<name of the button or option>
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To click the Close or OK buttons:

Say “Close” or “Click Close,” “OK” or “Click OK.”

Note: You cannot dictate the following items: 

• File names in dialog boxes.
• Folder names in dialog boxes.
• Names of items within list boxes.
• Toolbar icons.

Selecting Tabs in a Dialog Box

Note: Not all commands work in all applications. 

You can select tabs on a tabbed dialog box (such as the Options dialog box in 
Dragon NaturallySpeaking) in the following manner:

Note: If the tab has a caption with a shortcut key (underlined character) 
you can say “Click” followed by the name of the tab.

Selecting and Opening Icons

Note: Not all commands work in all applications. 

To select a desktop icon:

1. Point to the Windows desktop and say “Mouse Click” to make the 
desktop active.

2. Dictate the name of an icon. For example, “My Documents.”
The icon becomes highlighted to indicate that it is selected.

3. To select another icon, say “Move” followed by a direction (“Left,” 
“Right,” “Up,” or “Down”) and the number of icons (up to 20) you 
want to move. For example, “Move Right 1” or “Move Up 3.”

To Say

Select the next tab “Move to Next Tab” 
“Go to Next Tab” 
“Click Next Tab”

Select the previous tab “Move to Previous Tab” 
“Go to Previous Tab” 
“Click Previous Tab”
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To open a desktop icon for an application:

1. Point to the Windows desktop and say “Mouse Click” to make the 
desktop active.

2. Say “Open” and the name of an icon. For example, “Open My 
Documents.”

To close an open window:

1. Point to the open window and say “Mouse Click” to make the window 
active.

2. Say “Close Window.”

Scrolling in Windows and Lists

Note: Not all commands work in all applications. 

With Dragon NaturallySpeaking you can scroll within a window or list in a 
dialog box.

To scroll vertically:

Make sure the insertion point is in the list of a dialog box and say “Move 
Down” or “Move Up” followed by the number of lines (up to 20) you want 
to scroll. This presses the Up or Down Arrow key the number of times you 
specify. You can also say “Page Up” or “Page Down” to press the “Page 
Up” or “Page Down” key.

Examples:

Say “Move Up 10”

Say “Move Down 4”

Say “Page Up”

To scroll horizontally:

If the list or window has a horizontal scroll bar, make sure the insertion 
point is in the list or dialog box and say “Move Left” or “Move Right” 
followed by a number (up to 20). This presses the “Left” or “Right” arrow 
keys the number of times you specify.

Examples:

Say “Move Left 10”

Say “Move Right 5”
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Notes: 

• You can use these commands to scroll Help windows by voice.

• You can also go straight to a list item by saying the first letter of the 
item, such as “Press M.” In some applications you can go to a list 
item by saying that item. You need to test each technique to find out 
whether it works in any given field.

Controlling the Keyboard

Note: Not all commands work in all applications. 

When Dragon NaturallySpeaking is running, you can control the keyboard by 
voice.

To control the keyboard:

To take any control action using the keyboard:

To move around a dialog box or list: 

To select items in a dialog box or list, move to the item, then: 

Say Then say

“Press”  
<name of the key or keys to press>“Press Key” 

“Type”

Say Then say Then say

“Press” 
or 
“Type”

“Shift”  
<any letter, number, symbol, arrow key, or other key>“Control”

“Alt”

Say Then say

“Press” “Tab” 

Say Then say

“Press” “Enter” 
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Examples:

To enter the following keyboard characters say a phrase in the left column, 
then the name of the key(s) you want to press (right column).

Note: To undo a keystroke, say “Undo That” or “Backspace.” You cannot 
undo a keystroke by saying “Scratch That.” For example, if you say “Press 
Cap A” then “Scratch That,” the A remains in the document. Instead, say 
“Undo That” or “Backspace.”

Say Then Say

“Press,”
“Press 
Key,” 
or
“Type”

“Tab”

“Backspace”

“Enter”

“Escape”

“Space Bar”

“Print Screen”

“Pause”

“Up Arrow”

“Down Arrow”

“Right Arrow”

“Left Arrow”

“Home”

“End”

“Page Up”

“Page Down”

“Insert”

“Delete”

“Function 1” to “Function 12”

“Keypad” followed by any numeric keypad key: 0...9, ., /, *, -, +, 
Enter).

“Shift,” “Control,” or “Alt” (alone or in combination) followed 
by any other key.
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Moving the Mouse Pointer 

You can move the mouse pointer up, down, left, or right using the mouse 
pointer commands. You can also drag the mouse pointer.

Move Commands
Available at any time, these commands can move the pointer a short 
distance in any direction (up to 10 units).

To move the mouse pointer a short distance:

Examples:

Say “Mouse Down Two”

Say “Mouse Right Eight”

Click Commands
To click the mouse with voice commands:

Examples:

Say “Mouse Double-Click”

Say “Mouse Right-Click”

Say Then Say Then Say

“Mouse” “Up” 
“Down”  
“Left”  
“Right”

<1–10>

Say Then Say

“Mouse” “Click”

 “Double-Click”

 “Right-Click”

 “Left-Click”
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Optional Mouse Move Commands
To enable more Move commands:

1. On the DragonBar, select Tools > Options.
2. Click on the Commands tab.
3. Select the Enable mouse motion commands check box.

You can then use these movement commands: 

You can say a speed command at any time while the pointer is moving to 
speed the movement up or slow it down.

Note: The default mouse motion speed is 2 (on a scale from 1 to 25). You 
can change the default speed by clicking the Speed button on the 
Commands tab of the Options dialog box and selecting a new speed.

Examples:

Say “Move Mouse Down Faster”

Say “Mouse Move Lower Right Very Fast”

Say “Mouse Move Up Very Fast” (pause) “Slower” (pause) “Stop”

Say “Drag Mouse Down Faster”

Say “Mouse Drag Lower Right Very Fast”

Say “Mouse Drag Up Very Fast” (pause) “Slower” (pause) “Stop”

Say “Shift-Drag Up

Say Then a direction Then a speed (optional)

“Move Mouse” or
“Mouse Move”

“Up” “Faster”

“Down” “Very Fast”

“Drag Mouse” (to 
move)

“Left” “Much Faster”

“Mouse Drag” (to 
move)

“Right” “Slower”

“Control Mouse 
Drag” (to copy)

“Upper Left” “Very Slow”

 “Lower Left” “Much Slower”

 “Upper Right”  

 “Lower Right”  
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Stopping Mouse Movement 
While the mouse pointer is moving, you can stop the movement by 
saying one of the following:

• “Stop”
• “Cancel”

Note: You can combine moving the mouse pointer with clicking the mouse 
or marking and dragging the object in a single voice command. 

Positioning the Mouse Pointer 
Using the MouseGrid

You can position the mouse pointer anywhere on the screen using the 
MouseGrid. The movement can be relative to the full screen or the active 
window.

MouseGrid divides the screen or window into nine numbered areas.

To position the pointer using the MouseGrid:

Examples:

Say “MouseGrid 3 2 5”

Say “MouseGrid Window 7 8”

Say “MouseGrid 5 3 Go”

To Say

Place the MouseGrid over the full screen MouseGrid

Place the MouseGrid over the active window MouseGrid Window

Position the pointer in that numbered area <number from 1 to 9>

Position the pointer again <pause slightly, then say another 
number>

Close the MouseGrid after the command <any above command> Go

Cancel

Close the MouseGrid automatically by 
turning microphone off

Go to Sleep
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To combine a MouseGrid positioning command with clicking the 
mouse or marking and dragging the object in a single command:  

Example

Say “MouseGrid 5 3 Double-Click”

Say “Mouse Drag Lower Left”;  
then when the desktop icon is selected say “Double-Click.”

Note: To undo the last MouseGrid action, say “Undo That.”

Say Then say Then say

MouseGrid <number 0–9> Click

Double-Click

Right-Click

Left-Click

Mouse Drag Upper Left

Lower Left

Upper Right

Lower Right
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To

To mark 

To move

To copy t

To move
object
Moving and Copying Objects

You can use the following procedure to move or copy an object (including 
objects on the Windows desktop) if you select the Enable mouse motion 
commands box on the Commands tab of the Options dialog box.

To move or copy an object: 

You can say a speed command at any time while the pointer is moving to 
speed the movement up or slow it down.

Examples (with the mouse positioned over the object):

“Shift Mouse Drag Down Faster”

“Control Mouse Drag Up Very Fast” (pause) “Slower” (pause) “Stop”

To stop mouse movement while the pointer is moving: 

• “Stop”
• “Cancel”

Do Then Say Then say
Then a 
direction

Then a 
speed

an object Position the 
mouse 
pointer by 
voice

“Mouse 
Click”

 the object “Mouse 
Click”

“Mouse drag” “Up” “Faster”

he object “Mouse 
Click”

“Control 
Mouse drag”

“Down” “Very Fast”

 more than one “Mouse 
Click”

“Shift Mouse 
drag”

“Left” “Much 
Faster”

“Right” “Slower”

“Upper Left” “Very Slow”

“Lower Left” “Much 
Slower”

“Upper 
Right”

“Lower 
Right”
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Marking and Dragging Objects 
with MouseGrid

You can mark an object and drag it to a different location by voice using the 
MouseGrid.

To mark and drag an object: 

Examples

Say “MouseGrid 3 6 2 Mark, MouseGrid 9 3 1 Drag”

Say “MouseGrid Window 2 1 Mark, MouseGrid Window 5 2 Drag”

Say “Mouse Up 3 Mark, Mouse Right 8 Shift-Drag”

Say “Mouse Down 9 Mark, Mouse Left 2 Control-Drag”

To Do Then say

To select one object or the first 
object of multiple objects

Position the mouse 
pointer by voice

“Mark”

To move the single object Position the mouse 
pointer in location to 
move to

“Drag”

To move multiple objects “Shift-Drag”

To copy “Control-Drag”



Chapter 8

Creating Custom 
Commands

Objectives 
In this chapter, you will learn about creating and using custom 
commands:

• Understanding command types

• About grammars for commands

• Creating a custom Text and Graphics command

• Creating Text and Graphics commands with 
lists

• Creating a Macro Recorder command

• Creating a Step-by-Step command

• Creating an Advanced Scripting command

• Training Command names

• Dictating your command

• Editing a Command command

• Deleting Command command
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Understanding Command Types

Custom commands in Dragon NaturallySpeaking are called MyCommands.

You can create four types of MyCommands that work inside almost any 
Windows application:

• Text and Graphics to enter text and graphics of your choosing. Useful 
for reporting normal exam results, recording routine procedures, 
developing standard treatment plans and patient instructions, or 
developing other documents requiring routine tasks or standard input. 

• Macro Recorder to record a sequence of mouse and keystroke actions.
• Step-by-Step to activate menu and keystroke commands to control 

your application.
• Advanced Scripting to program voice commands that can perform 

virtually any function on the computer.

About Grammars for Commands
You create each command for a particular grammar that defines where the 
command should take effect, such as in a particular application or in all 
applications (including the Windows desktop). A grammar that contains 
commands that work in all applications is the Global Commands grammar. 

You can assign your command to a new grammar or an already existing 
grammar. 
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Creating a Text and Graphics 
Command

You can use the MyCommands Editor to create your own custom voice 
commands to insert text and graphics. These commands let you automate 
repetitive text and graphics insertion tasks. For example, you can use this kind 
of command to insert standard text, drawings of relevant information, and 
scanned signatures in EMRs.

To create a Text and Graphics command in the MyCommands Editor 
dialog box:

1. On the DragonBar, select Tools > Add New Command or say “Add 
New Command.” The MyCommands Editor dialog box opens.

2. Make sure the cursor is in the MyCommand Name box. 
141



142

Dragon® NaturallySpeaking® Medical Edition Provider and Administrator Courseware Guide
3. Using your microphone, dictate a name for your new command. For 
example, you might use a name such as insert normal exam. 

If you decide to type the command name, be sure to put spaces between 
multiple words. Command names can have as many as 200 characters 
and can contain spaces, periods, apostrophes, hyphens, numbers, and 
letters. However, if the command name becomes too long or 
complicated to say and/or type, it defeats the purpose of using custom 
commands. A command name cannot contain symbols, such as *, @, #, 
$, %, or the underscore character. 
We recommend command names be two to four words in length or an 
acronym that is as descriptive as possible. All acronyms should be 
capitalized and all other words should be in lowercase for better clarity. 
Here are some specific examples:

• CT head
• brain scan
• MRI lumbar
• lateral chest
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Notes: 

• Improper naming can lead to misrecognition, infrequent 
recognition, or commands that do not work properly.

• You can create multiple commands with the same name only if each 
command is specific to a certain window within an application; for 
instance, in Microsoft Word, if one command works in the Print 
dialog box and another in the Paragraph dialog box, the commands 
can have the same name; otherwise, Dragon NaturallySpeaking 
tells you that there is already a command with that name.

4. (Optional) If you want to teach Dragon NaturallySpeaking your 
pronunciation of the command name, click the Train button. For more 
information, refer to “Training Command Names” on page 162.

5. (Optional) In the Description box, dictate a short description of the 
command's function. 

6. (Optional but recommended) From the Group drop-down list, select a 
group, or create a new group. To add or change a group name, dictate or 
type over User-defined with a group name of your choosing. The new 
group name appears in the list the next time you create a command. 

Note: Although placing a command in a group is optional, doing so makes 
it easier for you to find commands in the Command Browser under 
Manage mode. 

7. For Availability, keep the default setting of Global. This setting 
ensures the command will work in all Windows applications. 

8. From the Command Type drop-down list, select Text and Graphics 
(default).

9. In the Content section, dictate the text you want to enter; for example: 
Physical Examination:

Vital signs are stable. Afebrile.

Patient appears well developed, well nourished,  
in no acute distress. 

HEENT: Unremarkable.

Neck: Supple with no adenopathy.

Heart: Regular rate and rhythm with no murmur, rub, 
or gallop.

Lungs: Clear to auscultation bilaterally.

Abdomen: Soft, nontender, no organomegaly.

Extremities: No edema, clubbing, or cyanosis.

Neuro: Intact.

(If your command uses a graphic, you also insert your graphic in the 
Content section).
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10. When you are finished, click Save.

Notes: 

• If you include a bitmap or formatted text in your command, to 
preserve the bitmap or formatting, do not select the Plain Text 
option.

• Text and Graphics commands create rich text (.rtf) that includes 
formatting that you specify. Programs that cannot accept .rtf format 
text, such as Notepad and many EMR systems, will show a plain text 
version of the command’s contents.

• Copying Text and Graphics commands do not work in all window 
applications, in particular it does not work in Windows Remote 
Desktop windows; as an alternative, create a Step-by-Step or 
Advanced Scripting Command. See “Creating a Step-by-Step 
Command” on page 153 and/or “Creating an Advanced Scripting 
Command” on page 158.

• Select the Plain Text check box if you want the contents to be 
entered in the same font style and size as the text preceding it in the 
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document. However, if your command contains graphics, do not 
select the Plain Text check box.

Creating a Text and Graphics 
Command with Lists

When you use a Text and Graphics command to insert frequently used blocks 
of text into a report, the text can contain a list of variables that let you choose 
the appropriate value each time the text block is used in a particular report. A 
list is a set of valid values you can choose to replace a variable in the 
command.

To create a Text and Graphics command with lists in the 
MyCommands Editor dialog box:

1. On the DragonBar, select Tools > Add New Command or say “Add 
New Command.” The MyCommands Editor dialog box opens.

2. Click the Name Editor button. The MyCommands Name Editor 
dialog box opens.

3. Type a name for your new command in the MyCommand Name box.

4. To add a list to the command:
 a. After (or within) the command name you just entered in the 

MyCommand Name box, type the less than angle bracket (<) to 
begin the list. 

 b. Enter the name for the list. In this example, type <lr 
 c. Type the greater then angle bracket (>) to end the list. 
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 d. You now see, for this example, <lr> after the command name and lr 
in the Lists used in this command section of the dialog box.

Note: Dragon NaturallySpeaking interprets the text inside the angle 
bracket as a variable whose value you later choose when you dictate a 
report.

5. To complete the command for a central venous report where the side, 
systolic, and diastolic information changes for each patient, you would 
enter central venous line <lr> <systolic> over <diastolic>. Notice all 
list names appear in the Lists used in this command section.

Note: Variables with lists of values are already available in the 
MyCommands Name Editor dialog box. To open one of those variables, 
click the Insert list button. The Insert list dialog box appears. Use the 
drop-down list to choose from several list names and view their list 

central venous line <lr>

lr

The lists in this 
box appear in 
alphabetical order 
rather than in the 
order they appear 
after the command.

diastolic
lr
systolic

central venous line <lr> <systolic> over <diastolic>
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contents. Click OK when you have found a list to use. It automatically 
appears in the MyCommand Name.

6. Once you have entered the command name with all its lists (each 
within angle brackets), select the first list name and click the Edit 
button (to the lower right of Lists used in this command). The View 
List dialog box appears. 

7. In the View List dialog box, enter all possible values for that list, such 
as the side for the <lr> list. In the example shown below, you see 
values left and right that identify the side of the body where the blood 
pressure was taken. 

Note: Each list value can have both a written form and a spoken form. 
Enter the written form first followed by a backslash (\) and then the spoken 
form. If you do not specify a spoken form for a value, the spoken and 
written forms are the same.

8. When you are finished, click OK. You now return to the 
MyCommands Name Editor dialog box. 

9. Repeat steps 6 through 8 for the remaining lists in the command. When 
there are no more lists to enter, click OK to return to the 
MyCommands Editor dialog box.

10. (Optional) In the Description box, dictate a short description of the 
command’s function. 

11. (Optional but recommended) From the Group drop-down list, select a 
group, or create a new group. 
For more information on creating a group, refer to Step 6 on page 143.

12. For Availability, keep the default setting of Global. This setting 
ensures the command will work in all Windows applications. 
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13. From the Command Type drop-down list, select Text and Graphics 
(default). 

14. In the Content section, dictate or type your text. (If your command 
uses a graphic, you also insert your graphic in the Content section). 
Within the text, place <<list-name>> wherever a provider should 
select a value from that list; for example, see the Content section 
below: 

When you later execute the command, all instances of <<list-name>> 
are replaced with spoken values from the appropriate list. This use of 
variables makes Text and Graphics commands dynamic.

Note: Select the Plain Text check box if you want the contents to be entered 
in the same font style and size as the text preceding it in the document. 
However, if your command contains graphics, do not select the Plain Text 
check box.

15. When you are finished, click Save.

Central Venous Line and Blood Pressure
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Creating a Macro Recorder 
Command

You can create a Macro Recorder command that executes a recorded 
sequence of mouse movements and keystrokes. 

To create a Macro Recorder command:

1. On the DragonBar, select Tools > Add New Command or say “Add 
New Command.” The MyCommands Editor dialog box opens.

2. Make sure the cursor is in the MyCommand Name box. 
3. Using your microphone, dictate a name for your new command. For 

example, you might use a name such as chart to open up a patient’s 
chart in your EMR.
For more information on naming a command, refer to Step 3 on 
page 142.

4. (Optional) In the Description box, dictate a short description of the 
command’s function. 

5. (Optional but recommended) From the Group drop-down list, select a 
group, or create a new group. 
For more information on creating a group, refer to Step 6 on page 143.

6. (Optional) For Availability, do not select Global because you want this 
command to work only in a particular application rather than all 
applications. In this training module you’ll see an example of an 
application-specific macro recorder command.
To associate the macro with a particular application:
 a. Open the application you want the macro to work in. For example, to 

have the macro work in your word processor, open Microsoft Word.
 b. In the MyCommands Editor, select the Application-specific 

button (next to Global) and go to the Application text box that then 
appears just below the line of Availability buttons. 

 c. Click the drop-down list, which contains only open applications; 
find your application in the list and select it.

OR
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7. (Optional) To have the command work in a particular dialog box of the 
application you chose in the previous step, such as the Font, 
Paragraph, or Print dialog box:
 a. Open the application where you want the macro to work. For 

example, to have the macro work in your word processor, open 
Microsoft Word.

 b. In the actual application, open the Font, Paragraph, or Print or 
other dialog box where the macro should work.

 c. Select the Window-specific button.
 d. In the Application drop down list, select the application.
 e. In the Window drop-down list, select the dialog box. (The list 

contains only open dialog boxes.)

Note: Dragon NaturallySpeaking recognizes a window or dialog box by 
the text in its title bar.

8. (Optional) Click the Recognizable in States drop-down list to select a 
state where the command is applicable. 

9. From the Command Type drop-down list, select Macro Recorder.
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To record the macro actions:

Note: The Actions section of the dialog box displays the sequence of mouse 
movements and keystrokes you record. 

You use the buttons to the right of the Actions box to control the 
recording process:
• Record—Click to begin recording.
• Play—Click to play back the macro.
• Insert—Click to open the Macro Recorder Action dialog box and 

then execute the mouse clicks and keystrokes of the macro you want 
recorded. You can also use the Macro Recorder Action dialog box 
in a later session to add clicks and keystrokes to the end of the 
sequence already in the Actions list or at the location of a selected 
step.

• Edit—Click to open the Macro Recorder Action dialog box and 
change the selected mouse movement or keystroke in the Actions 
list.

• Delete—Click to remove the selected step from the sequence of 
mouse movements and keystrokes in the Actions list.
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10. Click Record to begin recording. The MyCommand Editor window 
minimizes, disappearing from your view.
When the Floating Recorder window 
appears, recording is already in process, 
so the far left (Start) button is disabled. 
You can click Play, Pause, and Stop as 
needed during recording. 
When you click the Pause button during 
recording to pause and take actions you do not want recorded as part of 
the macro, you can later click the Start button to resume recording 
again. 

Note: If you click the record button while you are in the middle of 
recording a macro, the recorder deletes the entire sequence of keystrokes 
and mouse movements previously recorded in this session and begins 
recording a new sequence of actions. Actions in the same macro from 
previous sessions are not erased.

11. When you have finished, click the Stop button on the Floating 
Recorder.

12. Click the X in the upper right corner of the Floating Recorder to close 
the recorder and redisplay the MyCommand Editor dialog box. 

13. When you have finished, click Save to save the macro.

Start
Play Pause

Stop

Back
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Creating a Step-by-Step 
Command

You can also create a Step-by-Step command that helps you, for instance, 
navigate an EMR system. This type of command carries out a series of steps 
where each step can take one of these actions:

• Executing keystrokes on the keyboard to enter particular characters of text. 
• Executing control keys sequences on the keyboard.
• Opening an application. 
• Waiting a specified number of seconds.
• Turning the microphone on and off. 
• Putting Dragon NaturallySpeaking into a paused state (Sleep mode).

To create a Step-by-Step command:

1. On the DragonBar, select Tools > Add New Command or say “Add 
New Command.” The MyCommands Editor dialog box opens.

2. Make sure the cursor is in the MyCommand Name box. 
3. Using your microphone, dictate a name for your new command. For 

example, you might use a name such as notes tab to open up a patient’s 
notes tab in your EMR.
For more information on naming a command, refer to Step 3 on 
page 142.

4. (Optional) In the Description box, dictate a short description of the 
command's function. 

5. (Optional but recommended) From the Group drop-down list, select a 
group, or create a new group. 
For more information on creating a group, refer to Step 6 on page 143.

6. For Availability, do not select Global because you want this command 
to work only in a particular application rather than all applications. In 
this training module you’ll see an example of an application-specific 
step-by-step command.
To associate the Step-by-Step command with a particular application:
 a. Open the application you want the command to work in. For 

example, to have the Step-by-Step command work in your EMR, 
open the EMR.
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 b. In the MyCommands Editor, select the Application-specific 
button (next to Global) and go to the Application text box that then 
appears just below the line of Availability buttons. 

 c. Click the drop-down list, which contains only open applications; 
find your application in the list and select it.

7. From the Command Type drop-down list, select Step-by-Step.

8. In the Steps section of the dialog box, enter the steps you want the 
command to take by first selecting the type of step from the New Step 
drop-down list near the bottom of the dialog box. 
In the New Step drop-down list you see all types of actions the step 
could take (see below):
• Keystrokes—Acts as if you pressed a particular key. 
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• Open (application)—Opens a particular application or document, 
or switches to that application or document if it is already open. 

• Wait—Take no action for a specified time. This step is useful when 
a command needs to wait for something to happen, such as an 
application opening. 

• Type Text—Enters the text you specify. 
• Send Keys—Types a sequence of keys, including Ctrl, Alt, and 

Shift key sequences.
• Stop Listening—Puts Dragon NaturallySpeaking into Sleep mode. 
• Microphone On—Turns the microphone on. 
• Microphone Off—Turns the microphone off.
In this example, you enter keystrokes (default) in the Next Step.

9. Click the Insert button and an appropriate dialog box appears. For 
Keystrokes, the Send Keystrokes dialog box appears.

10. Enter the appropriate information in the dialog box. For Keystrokes, 
type the actual keystrokes you want the step to execute; they appear in 
the box provided. 
For example, to have the notes tab command open the notes tab in an 
EMR using the Ctrl and N keys on the keyboard, you would press 
those keys and they would appear in the Send Keystrokes dialog box 
as shown below:

Ctrl + N is an 
example of the type 
of keystrokes you 
can enter.
155



156

Dragon® NaturallySpeaking® Medical Edition Provider and Administrator Courseware Guide
11. Click OK in the dialog box. You can then see the keystrokes appear in 
the Steps section as Press Ctrl + N as shown in the illustration below. 

You can continue to insert and position as many New Step 
combinations as needed.

12. (Optional) After you have created several steps, select one of the steps 
in the Steps section and the buttons to the right of the steps then 
become available: 
• Edit—Allows you to modify the step.
• Copy—Allows you to copy the step (and then click Paste to paste 

it).
• Delete—Allows you to remove the step.
• Move Up/Move Down—Allows you to move the step up or down 

in the list of steps.
13. Click Save to save the entire Step-by-Step command.
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Adding a Step to Open an 
Application in a Step-by-Step 
Command

To create a step in the Command that opens an application:

1. On the DragonBar, select Tools>Add New Command or say Add 
New Command. The MyCommands Editor dialog box opens.

2. Make sure the cursor is in the MyCommand Name box.
3. Using your microphone, dictate a name for your new command.
4. (Optional) In the Description box, dictate a short description of the 

command’s function.
5. (Optional but recommended) From the Group drop-down list, select a 

group, or create a new group. For more information on creating a 
group, refer to Step 6 on page 143.

6. For Availability, do not select Global,to allow this command to work 
only in a particular application rather than all applications.
To associate the Step-by-Step command with a particular application:
 a. Open the application where you want the command to work.
 b. In the MyCommands Editor, select Application-specific (next to 

Global) and go to the Application text box that then appears just 
below the line of Availability buttons.

 c. Click the drop-down list, which contains only open applications; 
find your application in the list and select it.

7. From the Command Type drop-down list, select Step-by-Step.
8. In the Steps section, select Open (application) from the New Step 

drop-down list and click Insert. The Open Application/Document 
Step dialog box opens.

9. To supply a Target to open:
 a. Click the Browse button. The Choose Application or Document 

dialog box opens. 
 b. Find the .exe file for the application to be opened and click Open.

10. Enter any arguments needed in the Arguments box.
11. In Start in, set where to start the application.
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12. In Run, set the size to open the application’s window to—Normal, 
Minimized, or Maximized. 

13. Click OK in the Open Application/Document Step dialog box.
The step appears in the Steps section.

14. Click Save to save the entire Step-by-Step command.

Creating an Advanced Scripting 
Command

This section presents how to create an Advanced Scripting command. You 
can use this type of command to run a script, instructions that carry out a series 
of actions much the way a programming language would. Dragon 
NaturallySpeaking scripts use the Visual Basic for Applications (VBA) 
scripting language, embedded in Microsoft Office applications.

To create an Advanced Scripting command:

1. On the DragonBar, select Tools > Add New Command or say “Add 
New Command.” The MyCommands Editor dialog box opens.

2. Make sure the cursor is in the MyCommand Name box. 
3. Using your microphone, dictate a name for your new command. For 

example, you might use a name such as standard mammo note.
For more information on naming a command, refer to Step 3 on 
page 142.

4. (Optional) In the Description box, dictate a short description of the 
command’s function. 

5. (Optional but recommended) From the Group drop-down list, select a 
group, or create a new group. 
For more information on creating a group, refer to Step 6 on page 143.
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Statement or 
Keystroke

‘ (open single quote

% (percent sign)

^ (caret)

+ (plus sign)
Non-Printing Keys—

Enter, Delete, 
Home, End
6. For Availability, keep the default setting of Global. This setting 
ensures the command will work in all Windows applications. 

7. From the Command Type drop-down list, select Advanced Scripting.

8. To indicate the action that the custom Advanced Scripting command 
should take, in the Script section, type statements between Sub Main 
and End Sub to form the script. Select action statements or keystrokes 
for the script following the guidelines in the next table.

Visual Basic for Applications Language Statements

Usage Description Syntax/Example of 
Usage

) Use anywhere in a line to indicate start of a comment. ‘This is a comment

Acts as the Alt key

Acts as the Ctrl key

Acts as the Shift key
Keyboard keys that do not correspond to any printable character.

Inserts a press of the key. The syntax requires the curly 
braces around each key name.

{Enter} {Delete} {Home} 
{End}
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Up, Down, Left, 
Right Arrows

Tab, Esc

Function Keys
Statements—Keywo

SendKeys

Wait

Beep

HeardWord

Statement or 
Keystroke
The illustration below shows a script using some of these VBA 
statements. The sequence of commands in the script take these actions:
• Types the line: This study is interpreted without clinical 

correlation. If any clinical sign of concern for neoplastic disease 
remains, MRI evaluation is recommended.

• Selects the entire document and sets the font to bold
• After a 0.5 second wait, puts the cursor on the next line and beeps to 

indicate that the command executed successfully.

Inserts the press of the corresponding arrow key. {Up} {Down} {Left} 
{Right}

Inserts the press of the corresponding key. {Tab} {Esc}

Inserts a press of the corresponding function key. {F1} {F2} {F3} and so on
rds that take action in the script.

Sends a stroke of the key to the active window where the 
script is being executed, as if the key were being typed on 
the keyboard. Can also send a string of keys. Syntax 
requires double quotes around all keys or text strings 
entered. 

Note: Commands are not case-sensitive; VBA auto-
formats the line once you press Enter.

SendKeys “The lungs are 
normal in size.”
SendKeys “^p”
SendKeys “%pq”
SendKeys “{Enter}”

Pauses script action for the indicated number of seconds 
before executing the next statement.

Note: Start with longer waits between steps, then 
shorten the waits as you become more familiar with 
the command.

Wait .3
Wait .5

Generates the default Windows sound. Beep

Makes Dragon NaturallySpeaking respond as if the 
specified word, sequence of words, or voice command were 
received by the recognizer.

Note: Words must be individually enclosed in double 
quotes. Words are case-sensitive.

HeardWord “edit”, 
“vocabulary”

Usage Description Syntax/Example of 
Usage
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The Script section of the dialog box contains a row of icons for 
formatting, editing, debugging, and other aspects of developing your 
script. Below the Script section are several buttons. More detail on the 
Advanced Scripting feature is available in the Help file. Look under 
the following topics for more information:

9. Click Save to save the command.

Note: If you entered any incorrect syntax in the command, when you save 
the command, VBA highlights the line or lines in red and presents a dialog 
box that displays this message: Please, correct syntax error(s) before 
saving a macro. Click OK in the dialog box, make the corrections, and 
save the command again.

•  Advanced Scripting menu
• Script Editor toolbar
• Object and Proc lists
• Break Bar
• Script Editing window
• Status Bar

• Object Browser
• Reference dialog box
• MyCommands Editor 

dialog box
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Training Command Names

These steps apply to training a custom command name inside the 
MyCommands Editor dialog box.

To train Dragon NaturallySpeaking on how you pronounce your new 
command (while the MyCommands Editor dialog box is open):

1. Click the Train button adjacent to the MyCommand Name. The 
Train Words dialog box opens. 

2. Click Go and dictate the command name.
3. When you are finished, click Done. The Train Words dialog box 

closes.

To later train Dragon NaturallySpeaking to understand how you 
pronounce a command name, in the Command Browser:

1. On the DragonBar, select Tools > Command Browser or say “Open 
Command Browser.”

2. Click the Script button in the task pane to the left. This action displays 
the custom commands that are available. By default, the custom Global 
Commands are displayed. 
To view a different command grammar, select one from the Grammar 
drop-down list.

3. Find and select the command.
4. Click Edit and the MyCommands Editor dialog box opens.
5. Click Train and the Train Words dialog box opens.
6. Click Go and dictate the command name.
7. When your finished, click Done. The Train Words dialog box closes.
8. Click Save.
9. Click the X in the upper right corner of the Command Browser to exit.

notes tab



Chapter 8: Creating Custom Commands
Dictating Your Command

To use a text and graphics, step-by-step, macro recorder, and/or an 
advanced scripting command that you have created:

1. Open the application you want to use and position the cursor where you 
want the results of the command to appear.

2. With your microphone turned on, dictate the command name that you 
want to use. The result of the command appears on your screen.

Example

You can call three of the commands created earlier in this chapter by 
saying:

“insert normal exam” (see page 142)

“chart” (see page 151)

“notes tab” (see page 154)

Examples

Here is an example of a command with one list and the two ways to say 
this command:

Command: Patient consent <mf> 

“Patient consent male”

“Patient consent female”

Here is an example of a command with more then one list and three 
ways to say this command:

Command: central venous line <lr> <systolic> over <diastolic> 

“central venous line left 110 over 71” (see page 145)

“central venous line right 140 over 80” 

“central venous line left 104 over 68”

Note: Do not pause before or after dictating any of the list values.
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Editing Commands in the 
Command Browser

You can edit existing voice commands.

To open the Command Browser and edit a command:

1. On the DragonBar, select Tools > Command Browser or say “Open 
Command Browser.”

2. Click on the Script button in the task pane to the left. This action 
displays the command grammars where custom commands are 
available. By default, the custom Global Commands are displayed.
To view a different command grammar, select one from the Grammar 
drop-down list.

To edit a specific command:

1. Select the command you want to edit and click Edit in the task pane to 
the left. 

2. The MyCommands Editor dialog box opens with the command in it, 
ready for you to edit.

3. Modify the command as you see fit. 
4. When you have finished modifying the command, click Save to save 

the command. The MyCommands Editor dialog box closes.
5. Click the X in the upper right corner of the Command Browser to exit.
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Creating a New Command by 
Copying of an Existing Command

To create a new command by starting with a copy of an existing 
command:

1. On the DragonBar, select Tools > Command Browser or say “Open 
Command Browser.”

2. Click the Script button in the task pane to the left. This action displays 
the command grammars where custom commands are available. By 
default, the custom Global Commands are displayed.
To view a different command grammar, select one from the Grammar 
drop-down list.

3. Select the command you want to copy. 
4. Click New Copy in the task pane to the left. The MyCommands 

Editor dialog box opens with a copy of the current command ready for 
you to edit.

5. Rename the command in the MyCommand Name box. If the 
command name includes variables, the MyCommand Name box 
appears grayed out. Click the Name Editor button and make changes 
as necessary.

6. (Optional) Modify the description of the command in the Description 
box.

7. (Optional, but recommended) From the Group drop-down list, select a 
group or create a new group. 

8. Modify the command as you see fit.
9. When you have finished modifying the command, select Save to save 

the command.
10. Click the X in the upper right corner of the Command Browser to exit.
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Deleting Commands in the 
Command Browser

You can use the Command Browser to delete commands that you have either 
created or imported into Dragon NaturallySpeaking.

To delete a command:

1. On the DragonBar, select Tools > Command Browser or say “Open 
Command Browser.”

2. Click the Script button in the task pane to the left. This action displays 
the command grammars where custom commands are available. By 
default, the custom Global Commands are displayed.
To view a different command grammar, select one from the Grammar 
drop-down list.

3. Select the command you want to delete and click Delete in the task 
pane at the left.

4. Click YES to confirm that you want to delete the command. 
5. Click the X in the upper right corner of the Command Browser to exit.
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DragonBar Menus

Objectives 
In this chapter, you will explore the DragonBar menus:

• NaturallySpeaking 

• Tools 

• Words 

• Sound 

• Help 
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NaturallySpeaking Menu

Turn Microphone On/Off
Toggles the microphone on or off. 

Prepare User for Dictation
If the user is not fully trained, this menu option becomes available. Use it to 
initiate training of the user.

Open User
Brings up a list of users to choose from. 

• Open—Loads the user files and vocabulary for the user you select 
from the list. That user can then begin dictating.

• Cancel—Closes the dialog box.
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• Properties—Opens the User Properties dialog box, displaying 
property values for the selected user.

• New—Opens the New User Wizard dialog box.
• Source—Provides New and Delete options:

– New lets you select a new dictation source.
– Delete lets you delete a dictation source.

• Help—Opens the Dragon NaturallySpeaking Help to the page about 
this menu’s selections.

• Browse—Lets you browse for a location to store your user files.
• Location of user files — From this drop-down list, select a new 

location to retrieve/store user files. If the site has more then one Master 
Roaming User directory, the drop-down list is available and displays 
all the locations. However, if there is only one Master Roaming User 
location and the administrator has not checked the Allow non-roaming 
users to be opened option, the providers see this text box grayed out.
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Manage Users
Allows administrators to manage system users; for example, create, delete, 
convert a user to a roaming user, or rename a user, as well as view 
properties of the current user or change the location where the user files are 
stored. For providers, brings up a list of users to choose from. 

• New—Opens the New User Wizard dialog box where you can create a 
user.

• Properties—Opens the User Properties dialog box, displaying 
information about the selected user, including language, dictation 
source, speech model, vocabulary being used, and whether or not the 
user has performed training.

• Rename—Opens the Rename User dialog box where you can rename 
the user.

• Delete—Deletes the selected user from Dragon NaturallySpeaking. 
You cannot delete a user that is open.

• Advanced—Provides a menu of choices:
– Import — Opens the Browse For Folder dialog box where you 

find the folder you want to import, select the folder, and click OK.
– Export — Opens the Browse For Folder dialog box where you 

select the folder to store a copy of the user file you want to export 
(or make a new folder), select the folder, and click OK.

– Save to Roaming — (Select after you set the Location of user files 
to the Master Roaming Users directory.) Saves the selected user to 
the Master Roaming Users directory.
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– Backup — Makes a backup copy of the user file for the selected 
user in the directory indicated in the Administrative Settings dialog 
box.

– Restore — Restores any backed up user file and adds the user to the 
list of users with the word Restored added to the end of the name.

– Close — Closes the dialog box.
• Help—Opens the Dragon NaturallySpeaking Help to the page about 

this menu’s selections.
• Browse—Lets you browse for user files.
• Location of user files—From this drop-down list, select a new location 

to retrieve/store user files. If the site has more then one Master 
Roaming User directory, the drop-down list is available and displays 
all the locations. However, if there is only one Master Roaming User 
location and the administrator has not checked the Allow non-roaming 
users to be opened option, the providers see this text box grayed out.

Close User
When a user has finished dictating, you select this menu option to close the 
user.

Note: The menu selection does not exit Dragon NaturallySpeaking; it only 
closes the current user’s session.

Open Recent User
Displays a list of users who most recently have been using the product. You 
can select one of the users from this menu item to more quickly load that 
user.

Manage Vocabularies
Allows administrators to create, open, delete, rename, export, and import 
vocabularies. 
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Brings up a list of the vocabularies assigned to the currently open user.

You can select a vocabulary from the list and take these actions: 

• New — Opens the New Vocabulary dialog box where you can create a 
new vocabulary based on an existing vocabulary: 

• Open — Opens the selected vocabulary 
• Delete — Deletes the selected vocabulary and the folder that contains 

its files. You cannot delete a vocabulary that is currently in use unless 
you first open a different vocabulary.

• Rename — Open the Rename Vocabulary dialog box where you can 
rename the selected vocabulary.

• Export — Opens the Save As dialog box so you can export a copy of 
the selected vocabulary into a .top file.

• Import — Opens the Open dialog box, so you can locate a .top file to 
import a vocabulary from.

• Close — Closes the Manage Vocabularies dialog box. This button 
does not cancel any action you took.
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Open Recent Vocabulary
Displays a list of the vocabularies for the currently open user. You can 
select one of these vocabularies from this menu item to more quickly load 
that vocabulary.

Save User Files
Saves the changes to the open user’s user files. You should take this action 
when you know the user has dictated some reports and/or added/trained 
words or phrases, so that the information is integrated into the acoustic and 
language models for the user.

Exit
Exits Dragon NaturallySpeaking.
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Tools Menu

Accuracy Center
Opens the Accuracy Center dialog box, which provides you access to the 
tools that help you improve how Dragon NaturallySpeaking hears and 
understands what you say.

This tool offers you several options. If you click the underscored text, the 
Accuracy Center links you to the associated tool:

• Click or say a link that interests you.
–  Which tool should I use? Opens the Dragon NaturallySpeaking 

Accuracy Assistant, where you can get solutions to some problems 
that users might have. 

• Improve your acoustics:
– Check your audio settings. Opens the Audio Setup Wizard dialog 

box, where you conduct the Volume Check and Quality Check 
tests on your microphone and sound system. (For details on those 
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tests, see “Continuing Setup of User Files/Running Audio Tests” on 
page 43.)

– Perform general training. Opens the General Training page of 
the New User Wizard dialog box, where you train the current user. 
(For details on how to complete training in the New User Wizard, 
see “Carrying Out Training” on page 45.)

• Manage your commands:
– Launch the Command Browser. Opens the Command Browser 

dialog box. For details on the Command Browser, see “Command 
Browser” on page 176.

• Improve your vocabulary:
– Add a single word to your vocabulary. Opens the Add Individual 

Word dialog box. For more information, see “Adding Individual 
Words to Your Vocabulary” on page 100.

– Add words from your documents to the vocabulary. Opens the 
Add Words from Documents dialog box. For more information, 
see “Adding Words from Documents” on page 108.

– Increase accuracy from e-mail. Opens the Increase Accuracy 
from E-Mail dialog box. For more information, see “Adapting 
Recognition to Your Writing Style” on page 48.

– Add a list of words to your vocabulary. Opens the Add Words 
from Word Lists dialog box. For more information, see “Adding 
Words from Lists” on page 113.

– View or edit your vocabulary. Opens the Vocabulary Editor 
dialog box. For more information, see “Adding Words through the 
Vocabulary Editor” on page 102.

– Run the Vocabulary Optimizer. Opens the Vocabulary Optimizer 
dialog box. You run this optimizer during training, but can run it 
from here at any time. For more information, see “Adapting 
Recognition to Your Writing Style” on page 48.

• Get more information:
– How to manage and personalize your vocabularies. Opens the 

Dragon NaturallySpeaking Help to a section about vocabularies 
that provides more information on managing your vocabulary.

If you have not set up Roaming Users, you also see these options under 
Improve your acoustics:

– Run Acoustic and Language Model Optimizer. Opens the 
Acoustic and Language Model Optimizer dialog box. For more 
information, see “Running the Acoustic and Language Model 
Optimizer on Non-Roaming Users” on page 238.
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– Schedule Acoustic and Language Model Optimizer to run later. 
Opens the Acoustic and Language Model Optimizer dialog box. 
For more information, see “Running the Acoustic and Language 
Model Optimizer Scheduler on Roaming Users” on page 240.

Command Browser
Opens a window where you view voice commands that Dragon 
NaturallySpeaking recognizes, including commands provided with the 
software as well as commands you or your system administrator might 
have added (custom commands) in either Browse, Script or Manage mode. 
The Command Browser is the most comprehensive place to see 
commands available in each application. 

You use the Command Browser to:

• View and train commands
• Create and modify commands
• Import and export commands
• Change the availability of custom commands
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{Mode
Buttons

Browse
Buttons
To view all commands available for Dragon NaturallySpeaking:

1. On the DragonBar select Tools > Command Browser. The 
Command Browser dialog box opens in Browse mode, displaying the 
global commands. 

To verify you are in Browse mode, it should be written in the title bar 
of the dialog box and under Mode in the upper portion of the left pane. 
Browse mode also displays a list of Browse buttons in the lower 
portion of the left pane. When you select a command in the right pane, 
you might see more buttons become available under Browse. Other 
buttons you might see in Browse mode are Train, Train Later, 
Optional, Ellipsis, and To Script. Initially, only Train List, Or, 
Refine, and Undo All might be available. 
Use the Context drop-down list in the far left corner, to select the 
application you want to view the commands for.
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M
But

Manage
Buttons
2. Click the Manage button under Mode in the left task pane. The 
Command Browser dialog box opens in Manage mode and shows a 
tree of command groups in the right pane.

3. This view of the commands is called Manage mode as shown both in 
the title bar of the dialog box and under Mode. Manage mode also 
displays a list of Manage buttons in the lower half of the left pane.
Under Manage in the left task pane, initially only the Import button is 
available. If you check off a grammar or individual command in the 
right pane, the Export, Delete, and Edit Properties buttons become 
available. Script is only available when you select a command under an 
application name.

{ode
tons

{
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M
Butt

Script
Buttons
4. Click the Script button under Mode in the left pane. The Command 
Browser dialog box opens in Script mode and shows names of scripts 
in the right pane.

5. Under Script in the left pane you have options of actions you can take 
on the command that include New, Delete, Edit, New Copy, and 
Preview. Initially, you might see only the New and Preview buttons.

{ode
ons

{
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Add New Command
Select this option to add a new custom command. 

For more information about creating your own commands, refer to Chapter 
8, “Creating Custom Commands” on page 139.
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Dictation Box
Some applications or particular windows in applications might not support 
dictation or voice commands. In this situation, the Select-and-Say 
Indicator is gray rather than green and the Message Area displays a 
message stating that you are dictating into a non-standard window. When 
you see that message, you should use the Dictation Box to receive your 
new dictation or to revise misrecognized text.

To open the Dictation Box, on the DragonBar select Tools > Dictation 
Box or say “Show Dictation Box.”

Adding Text in Dictation Box

If you have difficulty adding text in an EMR or other application:

1. Place your cursor in the active application window or document where 
you want the text to appear.

2. With your microphone turned on, say “Show Dictation Box.” The 
Dictation Box opens. 

3. Dictate into the Dictation Box, making edits as necessary.
4. When you have finished dictating, click the Transfer button (or say 

“Transfer”). 
Dragon NaturallySpeaking automatically transfers recognized text to 
the window of the application you were using when you opened the 
Dictation Box. 
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Revising Text in Dictation Box

If you have difficulty revising selected text in an EMR or other 
application:

1. In an active application window or document, highlight the text you 
want to revise.

2. With your microphone turned on, say “Edit Selection.” 
The Dictation Box opens, displaying the previously selected text.

3. When you have finished revising the text, click the Transfer button (or 
say “Transfer”). 
Dragon NaturallySpeaking automatically transfers the corrected text to 
the window of the application you were using when you opened the 
Dictation Box.

Modifying Settings for the Dictation Box

The Dictation Box works for all applications that can accept standard 
shortcuts for Windows Clipboard operations. In some applications that do 
not accept these commands, your text may be lost or changed when 
transferring text in and out of the Dictation Box. If this happens, you can 
try changing the Copy and Paste settings. Copy and Paste settings can be 
different for each application that you use with the Dictation Box. For 
example, you can have one set of copy and paste settings for AOL Instant 
Messenger and another for Microsoft PowerPoint. You can also set the font 
and window position of the Dictation Box.

Patient presents with intermittent episodes related to history of 
neurocardiogenic syncope.
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(Optional) To modify the font, window position, and copy and paste 
settings of the Dictation Box:

1. Open the application where you want the Dictation Box settings to 
apply.

2. On the DragonBar, select Tools > Dictation Box.
3. Click the Settings button to the lower right in the Dictation Box. The 

Dictation Box Settings dialog box appears.

4. To set the font, in the Font section click Change Font and choose the 
font name, style, and size you would like and press OK to keep the 
changes. Click Default to return to the default font setting.

5. To set the window position, in the Window position section click one 
of these:
• Anchor—To have the box appear where it was last closed. If you 

dragged it to a new position before closing it, the Dictation Box 
appears in the new position when you next open it.

• Automatically position Dictation Box near the cursor—To have 
the box appear as close to the cursor as is practical.
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6. In the Settings for application “<application name>” section, you set 
Copy and Paste settings:
 a. Under Copy select:

• Do not copy—If you do not want an automatic copy of any text 
from the application when Dictation Box first opens.

• Type keys <Ctrl+C>—If you want to use Ctrl + C to copy text 
from the application.

• Use Windows Copy command—If you want to use the 
Windows Copy command to copy text from the application.

 b. Under Paste select:
• Type keys <Ctrl+V>—If you want to use Ctrl + V to paste text 

from the Dictation Box to the application.
• Use Windows Paste command—If you want to use the 

Windows Paste command to paste text from the application.
• Simulate keystrokes—If you want keystrokes sent from the 

Dictation Box to the application. Choose this option when other 
methods of pasting text fail.

7. To have the Dictation Box show the number of characters of 
recognized text, click the Show character count check box.

8. To retain text on the Windows Clipboard even after you close the 
Dictation box, click the Keep transferred text in clipboard when the 
Dictation box is closed check box.
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DragonPad
Select this option to open the Dragon NaturallySpeaking built in word 
processor where you can dictate a report or document. 

For more information on the DragonPad, refer to “Dictating Text into 
DragonPad” on page 66.
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Options
Select this option to modify settings of the functions on the tabs shown 
below in the Options dialog box.

Correction tab:

Note: Changing these options only affects the current user; any other users 
keep their existing settings.

The Correction tab offers you options to select and correct recognized 
text:

• How the Select, Correct, and Spell commands behave.
• Whether or not words are automatically added to the vocabulary.
• Whether or not recognized audio is automatically played back on 

correction.
• Correction menu — How the menu is displayed:

– Show only the choices — Check to display only correction choices.
– Anchor — Check to lock the Correction menu in its current 

location until you drag it to a new location.
– Enable double-click to correct —Check to open the Correction 

menu by double-clicking words with your mouse. We recommend 

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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you check it to allow use of the mouse for correcting. This feature 
does not work in all applications. 

– Show no more than # choices— Controls the number of choices 
the Correction menu will display. We recommend when you first 
start that you maximize the setting to 9 to display more options for 
users to choose from.

• Restore defaults button — Restores original settings for the 
Correction tab.

Commands tab:

Note: Changing these options only affects the current user; any other users 
keep their existing settings.

The Commands tab offers you options to customize how you work with 
commands:

• Pause required before commands — Length of silence to precede a 
command. Default is 250 milliseconds (.25 second).

• Enable Natural Language Commands — Allows commands that you 
can use with a variety of applications such as Microsoft Word, Corel 
WordPerfect, AOL, and Microsoft PowerPoint. 

• Enable commands in HTML windows — Allows commands 
designed specifically for web browsers like Internet Explorer. 

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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• Require “Click” to select menus and controls — Requires you speak 
the word Click to select a hyperlink, menu option, or control.

• Enable recognition mode switching commands — Lets you dictate 
and say mode commands interchangeably.

• Enable mouse motion commands 
— Lets you state commands that 
move the mouse, such as “Mouse 
left.” 

• The Speed button lets you set the 
speed of the mouse motion voice 
commands.

• Restore defaults button — Restores 
original settings for the Commands tab.

View tab:

Note: Changing these options only affects the current user; any other users 
keep their existing settings.

The View tab offers you options to control the look and behavior of:

• DragonBar:

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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– Mode — Set to how you want the DragonBar positioned: Docked 
to Top , Docked to Bottom, Floating, Clinging to current window, 
or sitting in the Tray Icon Only. (For more information, see 
“Setting How DragonBar Looks/Acts” on page 59.) 

– Show messages — Check to see messages in the DragonBar 
Message Area.

– Show extras — Check to see the Extras toolbar automatically 
every time you start Dragon NaturallySpeaking.

• Results Box:
– Beep after recognition — Check to have a beep occur after a 

phrase is recognized and uncheck to have it stop occurring.
– Anchor — Locks the Results Box in its current location until you 

drag it to a new location. 
– Auto-hide delay — Select how many seconds to delay hiding the 

Results Box after dictation stops. We recommend 5 seconds rather 
than Never hide, so that the Results Box does disappear and allow 
the provider access to the application you are working in without 
moving the box.

• Restore defaults button — Restores original settings for the View tab.

Hot keys tab:

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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Note: Changing these options only affects the current user; any other users 
keep their existing settings.

The Hot keys tab lets you modify the hot keys:

• Microphone on/off {NumKey+} — Toggles the microphone on/off. 
For example if you are using a Philips SpeechMike, you can use the 
SpeechMike control utility to associate a microphone button with a 
keystroke, and then on the Hot Keys tab you can associate a Dragon 
NaturallySpeaking function with that same key.

• Correction {NumKey–}— Brings up the Correction menu.
• Force command recognition {Ctrl}— Forces spoken words to be 

recognized as commands rather than dictated text.
• Force dictation recognition {Shift}— Forces words to be recognized 

as dictation rather than as commands.
• DragonBar menu {NumKey*}— Opens NaturallySpeaking menu on 

the DragonBar.
• Microphone sleep/on {NumKey/}— Toggles microphone between 

sleep and wake states.
• Press-to-talk — Holding down this key keeps the microphone on until 

you release it.
• DictationBox {Ctrl+Shift+D}— Opens the DictationBox dialog box.
• Playback {Shift+NumKey–}— Starts playback of the audio.
• Fast Playback {Shift+NumKey*}— Increases the playback speed.
• Restore defaults button — Restores original settings for the Hot keys 

tab.
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Hot keys PowerMic

Note: Changing these options only affects the current user; any other users 
keep their existing settings.

Only if a PowerMic or PowerMic II is connected to your computer does the 
Hot keys PowerMic tab appear. On this tab you indicate the button on the 
PowerMic that performs each function. For instance, in the illustration 
above, the Tab Backward button opens the Correction menu.

• Microphone on/off (Dictate) — Toggles the microphone on/off. 
• Correction (Tab Backward) — Brings up the Correction menu.
• Force command recognition (Custom Left) — Forces spoken words 

to be recognized as commands rather than dictated text.
• Force dictation recognition (Custom Right) — Forces subsequent 

spoken words to be recognized as dictation rather than as commands.
• DragonBar menu () — Opens the NaturallySpeaking menu on the 

DragonBar.
• Microphone sleep/on () — Toggles microphone between sleep and 

wake states.
• Press-to-talk ()— Holding down this key keeps the microphone on 

until you release it.
• DictationBox ()— Opens the DictationBox dialog box.
• Playback (Stop/Play) — Starts playback of the audio.

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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• Fast Playback ()— Increases the playback speed.
• Restore defaults button — Restores original settings for the Hot keys 

PowerMic tab.

Refer to the PowerMic and PowerMic II quick references for the names of 
the buttons on each microphone.

Text-to-speech tab:

Note: Changing these options only affects the current user; any other users 
keep their existing settings.

The Text-to-speech tab lets you adjust the attributes of Text-to-speech 
playback.

• Attributes — Sets the audio characteristics applied when the product 
reads back text, including Volume, Speed, Pitch, and Voice.

• Preview — Enter or paste text in this box to preview Text-to-speech 
playback.
– Read text button — Click to hear a sample reading of the text in the 

Preview box using the settings you selected.
• Unload text-to-speech button — Turns off the feature.
• Restore defaults button — Restores original settings for the Text-to-

speech tab.

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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Miscellaneous tab:

Note: Changing these options only affects the current user; any other users 
keep their existing settings.

The Miscellaneous tab lets you set the miscellaneous options. 

• User Open:
– Microphone on (asleep) — Check to have the microphone 

automatically turn on in sleep mode when you open a user. Check 
this option only if the user cannot use his or her hands to turn the 
microphone on/off.

– Launch DragonPad — Check to have DragonPad start 
automatically when you open a user.

• User Close:
– Automatically save user files — Check to automatically save the 

user files when closing a user without displaying a dialog box asking 
you to confirm that you want the user files saved. 

– Speed vs. Accuracy—You can have faster recognition that is not 
quite as accurate or slower recognition that is extremely accurate. 
Most of the time, you want a balance of the two.

– Use screen reader compatible menus—Check to have a screen 
reader to read menu items out loud to vision-impaired users. Some 
screen readers have trouble reading menus unless this option is 

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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turned on. If this option is on, the small icons next to menu items 
disappear.

– Use Active Accessibility for menu and dialog control—Check to 
have Dragon NaturallySpeaking use Microsoft Active Accessibility 
features, required by some versions of Windows to control the 
menus and dialog boxes of certain applications by voice. 

Note: This option is dimmed if Active Accessibility is not installed or if 
your version of Windows does not require it. This setting affects all users.

– Launch in QuickStart mode on Windows startup—Check to 
have Dragon NaturallySpeaking load in the background when you 
start your computer or log in to your operating system, depending on 
your version of Windows.
When Dragon NaturallySpeaking is launched in QuickStart mode 
the Microphone icon appears in the system tray and is available for 
use more quickly than when you start it in Normal mode.

• Restore defaults button — Restores original settings for the 
Miscellaneous tab.

Formatting tab:

Note: Changing these options only affects the current user; any other users 
keep their existing settings.

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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Formatting 
Option

Web and e-mai
addresses

Street addresse

Abbreviations

Contractions

ISO currency c

Units of measu

Phone numbers

Time
The Formatting tab lets you set the default formatting for various types of 
data; for instance, you can have automatic formatting of web addresses, 
phone numbers, and dates and times. Here are the types of data whose 
default format you can set:

• Do not automatically format text — Turns off automatic number 
formatting; still lets you dictate numbers by saying “Numeral” before 
the number, but you must explicitly specify digits and punctuation. 

Note: Punctuation of numbers and currency depends on the settings on the 
Number and Currency format of the Windows Control Panel Regional 
Settings Properties.

• Automatically format text — Turns on different forms of automatic 
number formatting; lets you dictate numbers in a natural way and 
format abbreviations, contractions, and e-mail addresses. 
Makes several options available, shown in the table below.

Automatically Format Text Options/Formatting Tab of Options Dialog Box

 
Purpose

l Automatically formats e-mail and Web address; lets you dictate these addresses in a 
natural manner. Concatenates names in Web and e-mail addresses and recognizes the 
word at as the @ sign.

s Automatically formats postal addresses; for example, if you say “49 Orchard Lane, 
Boston, Massachusetts Oh Two Four Four Six”, transcribes 49 Orchard Lane, 
Boston, MA 02446.

Recognizes most standard abbreviations while transcribing dictation if you say 
“Abbreviated” after the word. For example, if you say “February Abbreviated” 
transcribes Feb. If you clear this box, transcribes spoken abbreviations in a more 
formal manner. For example, if you say “Ltd,” transcribes Limited.

Recognize contractions while transcribing dictation. If you clear this box, transcribes 
spoken contractions in a more formal manner. For example, if you say “Don't go 
near the water,” transcribes Do not go near the water.

odes Goes with Currency option; displays currency amounts with the international symbol 
for the language set in the Windows Regional and Language Options tool. For 
example, if you have United States English selected and say “Ten Dollars,” 
transcribes USD10.

re Automatically formats standard units of measure, such as feet and inches. For example, if 
you say “Six Feet Three Inches,” transcribes 6'3". If you say “two by three 
millimeters,” transcribes 2 x 3 mm. For “twenty five milligrams,” transcribes 25 mg.

Automatically formats telephone numbers when you speak a sequence of seven or ten 
numbers. For example, if you say “7815551234,” transcribes 781-555-1234.

Turns on standard time formats. For example, if you say “Six Thirty PM,” 
transcribes 6:30 p.m.
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Dates

Currency

Other numbers

Allow pauses i
formatted phras

Formatting 
Option
• Automatically add commas and periods — Adds commas and 
periods (full stop outside USA or Canada) at the appropriate places in 
your dictation. Dictation with this feature turned on adds commas and 
periods for the same natural pauses that you typically use in 
conversational speech.

Note: This option is not recommended for clinical documentation.

• Enable postal code commands — Sets the format of Canadian and 
UK postal codes in your dictation. For example, to format a postal code 
in Toronto, say “Toronto Comma Ontario Post Code M Five H Two 
L Two” to enter Toronto, Ontario M5H 2L2.

Note: You must save, then reload your user files before a change to this 
option actually takes effect. On the DragonBar, select NaturallySpeaking 
> Save User Files; then select NaturallySpeaking > Open User. Be sure to 
select the correct user (the current user is selected by default), then click 
Open.

• Insert two spaces after period — Puts two spaces at the end of a 
sentence instead of a single space. Clear this check box to add only one 
space.

• Restore defaults — Clicking this button restores the values of the 
Formatting tab to settings originally installed.

• Restore defaults button — Restores original settings for the 
Formatting tab.

Automatically formats dates using the format you select in the drop down below it. 
For example, if you select MM/DD/YY from the list and say “May Sixth, 2005” or 
“Sixth of May, 2005,” transcribes 05/06/05. 
Choosing “Dates as spoken” transcribes the date exactly as you dictate it. For 
example, “Sixth of May, 2005” transcribes as 6th of May, 2005.

Note: One exception to the MM/DD/YY format is a date from early in the previous 
century. For example, if you say “May Sixth, 1905” Dragon NaturallySpeaking 
transcribes 05/06/1905 to avoid confusion with the year 2005.

Automatically formats standard forms of currency, such as dollars. For example, if 
you say “Six Dollars and Seventy Five Cents,” transcribes $6.75.

Automatically formats all numbers not covered by other options on this dialog box, 
such as negative numbers, numbers with punctuation, fractions, decimals, and roman 
numerals. For example, if you say “Ten Thousand,” transcribes 10,000.

n 
es

Formats numbers and phrases to work together if you pause while speaking a number.

 
Purpose
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Data tab:

Note: Changing these options only affects the current user; any other users 
keep their existing settings.

The Data tab offers you options to customize how data is stored, archived, 
and backed up:

• Store corrections in archive — Check to save a list of your 
corrections in an archive.

• Archive size button — Opens the Archive Size dialog box, where a slider 
lets you adjust the number of corrections stored in the archive to between 
30 and 180 minutes.

• Conserve disk space required by user files (for portability) — 
Check to save a smaller set of user files for easy portability.

• Incremental adaptation in general training — Check to run the 
acoustic optimizer after a provider performs additional training but to 

Settings 
shown in this 
illustration are 
the defaults 
on this tab.
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use only the data gathered from the training session, rather than using 
all of that provider’s dictation, for adapting the acoustic model.

• Disk space reserved for playback — Enter number of megabytes of 
disk space to reserve for audio playback.

• Save recorded dictation with document — To automatically save 
dictated audio when you save the document, without prompting you. 
Change to Never in most cases when working in Anatomic Pathology 
or EMR applications that use only a text editor to populate database.

• Automatically back up user files every “n” saves — Indicate the 
number of times data should be saved between explicit backups of user 
files. In a roaming user environment, this setting has no effect, because 
Dragon NaturallySpeaking does not back up a Roaming User.

• Advanced button — Opens the Advanced dialog box, where you can 
choose to:
– Create usability log — Log of all the menu commands, toolbar 

buttons, and voice commands used during the current session.
– Always preserve wave data — Saves every audio file dictated. 
– Collect data — Collect acoustic data for accuracy enhancement 

purposes. 
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– Delete data — Remove all usability log, audio file, and acoustic 
data that is currently stored for this session. Click this button to 
remove any accumulated data from your hard drive.

• Restore defaults button — Restores original settings for the Data tab.
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Words Menu

New
Opens the Add Individual Word dialog box to add new words to the open 
user’s vocabulary. For more information refer to “Adding Individual 
Words to Your Vocabulary” on page 100.

View/Edit
Opens the Vocabulary Editor dialog box to view and edit the open user’s 
vocabulary. For more information, refer to “Adding Words through the 
Vocabulary Editor” on page 102.

Train
Opens the Training dialog box to train a word in the user’s voice. For more 
information, refer to “Training Words at Any Time” on page 107.

Import
Opens the Add Words from Word Lists dialog box to import a list of 
words into the open user’s vocabulary. For more information, refer to 
“Importing Custom Words from Another User” on page 118.

Export
Opens the Export Custom Words dialog box where you select the path 
and enter the name of the file to export the words into. For more 
information, refer to “Exporting Custom Words to a File” on page 117.

View Recognition History
Opens the Recognition History dialog box to view a list of what Dragon 
NaturallySpeaking transcribed during a dictation session. This information 
is useful if you have been dictating without looking at the screen and you 
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discover some recognition errors. Use the Save button too save the user’s 
recognition history. 

Note: The Recognition History window provides information only; you 
cannot correct recognition errors in it.

Dictation Modes
You can change the dictation mode by saying:

1. “Start <name> mode”
2. “<name> mode on”
3. “<name> mode off”

Note: To switch between modes, say “Switch to <name> mode.” For 
example “Switch to Numbers Mode.”

Normal Mode

Default mode. In this mode, Dragon NaturallySpeaking distinguishes 
dictation from commands by analyzing what you said between pauses.

Dictation Mode

In this mode, Dragon NaturallySpeaking interprets everything you say as 
dictation and nothing as a command.

Command Mode

In this mode, Dragon NaturallySpeaking interprets every word you dictate 
as a command and none of it as dictated text.
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Numbers Mode

In this mode, Dragon NaturallySpeaking interprets every word you dictate 
as numeric digits.

Spell Mode

In this mode, Dragon NaturallySpeaking lets you spell words using a 
combination of letters, digits, and symbols. Useful for dictating acronyms 
and digit- and character-specific items. You can also dictate keystrokes 
such as “space bar” or “backspace key.”

Sound Menu

Play That Back
Plays back the audio for the text you have selected in the application where 
you have been dictating.

Read That
Reads the text you have selected using the computer’s voice. 

Transcribe Recording
Opens the Transcribe a Recording dialog box, where you transcribe audio 
you dictated into a recording device and set Transcribe options. 

Note: The first screen displayed varies based on the type of recorder you 
are using.
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To transcribe audio dictated into a recording device:

1. If your installation has been set up to use DragonPad, you do not have 
to open DragonPad unless you are adding to an already existing 
document. If you want to transcribe the dictation into an existing 
document in DragonPad or into a document in another application, 
open that document and insert the cursor where you want the 
transcribed text to begin.

2. On the DragonBar, select Sound > Transcribe Recording
3. The Transcribe a Recording dialog box appears. If you have wave 

files to transcribe or do not have a recorder attached, click the Other 
Source button to the right and proceed to the next step.
If you have a recording device attached to your computer (or the 
recorder’s removable memory is inserted into a reader connected to the 
computer), you see a large button to the left labeled with the name of 
the recording device (see the Sony Digital Voice Editor in the preceding 
illustration). To retrieve audio from that recorder:
 a. Click the large button and follow the instructions in the 

recorder software to select the file that you want to 
transcribe. 

 b. Click the button in the recorder software that starts the 
transcription (the name of the button depends on the particular 
recorder type). If the Transcription Options dialog box opens, 
select the window where transcribed text will appear, how Dragon 
NaturallySpeaking will interpret the command words in the 
transcription, and other options depending on what type of recorder 
you are using.and proceed to the steps on receiving the resulting text 
under either “In DragonPad” on page 204 or “In an Application 
Other Than DragonPad” on page 205.
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4. Click the Transcribe button in the Transcription Options dialog box. 
This will open the Transcribing dialog box and start the process when 
you click the mouse in the application that should receive the 
transcribed dictation. Transcription then begins and during the process 
you see the Transcribing dialog box.

Note: Do not touch the mouse or keyboard during the transcription 
process.The Transcribe from dialog box opens. 

5. Click Audio File or, if you are using audio from a pocket PC, click 
Audio File From Pocket PC.
Or if you are sending audio directly through the Line In jack, select 
Through the Line In Jack and proceed to Step 7.

6. Click the Browse button to the right of the File text box, find the .wav 
file containing the recorded audio, and click Open. The name of the 
wave file should appear in the File text box under Audio File.

7. Click the Transcribe button to initiate the transcription process. What 
you do next depends on whether you are receiving the text in 
DragonPad or another application.

Note: To modify which application receives the results of transcribing 
recorded audio, see “Setting Where Audio Should Be Transcribed” on 
page 206.

In DragonPad
If your installation is set up to use DragonPad, and DragonPad is not 
open, it opens automatically and you need not take any other action. 
The text resulting from recognition appears in the DragonPad text 
area, starting at the top of the document (if the document is empty) or at 
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the location of the cursor (if the document already contains other text). 
During the transcription process, you see the Transcribing dialog box.

Note: Do not touch the mouse or keyboard during the transcription 
process.

 a. Depending on the application you are using, it might be different. If, 
for example, you are using DragonPad, select File > Save. A 
message box pops up asking if you want to save the audio file for 
later playback and advising you on the amount of space the audio 
requires on your hard drive. 

 b. Click Yes to save the recording or No to discard it. After you 
respond to this dialog box, the Sound menu again becomes 
available for you to transcribe another recording.

In an Application Other Than DragonPad
If your installation is not set up to use DragonPad, after the name of 
the wave file appears in the File text box and you click the Transcribe 
button to start the process, you must then click the mouse in the 
application that should receive the transcribed dictation. Transcription 
then begins and during the process you see the Transcribing dialog 
box. 

The text resulting from recognition appears in the open document 
where the cursor is, starting at the location of the cursor.
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Note: Do not touch the mouse or keyboard during the transcription 
process.

 c. In the application, select File > Save (or the equivalent). A dialog 
box pops up asking if you want to save the audio file for later 
playback and advising you on the amount of space the audio 
requires on your hard drive. 

 d. Click Yes to save the recording or No to discard it. After you 
respond to this dialog box, the Sound menu again becomes 
available for you to transcribe another recording.

8. You can close the document or leave it open to receive transcription of 
another audio file.

Setting Where Audio Should Be Transcribed
To set transcribe options that indicate where the audio should be 
transcribed (DragonPad or another application):

1. On the DragonBar, select Sounds > Transcribe Recording
2. In the Transcribe a Recording dialog box, click the Advanced button 

and the Advanced Settings dialog box opens. 
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3. Under Destination, choose a window to receive the transcribed audio, 
by selecting either DragonPad or, for any other application, by 
selecting a selected window.

Under Commands, select how you want Dragon NaturallySpeaking to inter-
pret the recorded audio, as commands or as dictation. Choose from:

• All Commands — Enables all Dragon NaturallySpeaking 
commands during dictation to be recognized when the recording is 
carried out. 

• Restricted Commands — Disables all but restricted commands set 
during transcription. Look in Help for further information on this 
option. 

• Dictation Only. — Disables all commands during transcription, 
except fo dictation commands. If a recording has commands, they 
are entered as text in the document. 

4. (Optional) If you have a line input recorder, set the number of seconds 
of silence that indicates the end of the recording, under 
Communication Options.

5. Click OK to save the settings and close the Advanced Settings dialog 
box.
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Help Menu

Improve my accuracy
Select to open the Accuracy Assistant dialog box.
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Performance Assistant
Select to open the Dragon NaturallySpeaking Help dialog box to the 
Performance Assistant section that instructs you on how to use this 
capability to improve the speed of recognition. 
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Help Topics
Select to open the Dragon NaturallySpeaking Help dialog box contents.

Tip of the Day
Select to open the Tip of the Day dialog box. Each tip teaches you a bit of 
information about Dragon NaturallySpeaking. If you open this dialog box 
and check Show Tips at Startup, you see a tip every time you start the 
product. 
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Note: To stop the Tip of the Day dialog box from appearing, uncheck the 
Show Tips at Startup box.

Sample Commands
Open the Sample Commands dialog box to 
view available application commands you 
can use for the particular application you 
have opened.. 

The Sample Commands box appears and 
you can leave it open while you test some of 
the commands. For example, if you open 
the Sample Commands dialog box with no 
application open, you might see the 
information shown at the right. 

• Controlling the Microphone
Test commands to control the 
microphone. For instance, say 
“Microphone off” and then look in the 
DragonBar to see that the microphone 
has, in fact, been turned off.

• Controlling Modes
You are automatically in Normal mode 
when you start up DragonPad. Switch 
to Command mode and try some 
commands or switch to Spell mode and 
try spelling some words.

• Getting Help
Say “Give me Help” to open the Help.

• Selecting and Correcting Text
In the DragonPad, dictate a few 
paragraphs of a report. Then use the 
selecting and correcting commands to 
select a particular character or series of 
characters and replace them. 

• Inserting Lines and Spaces
Test the New line, New paragraph, Press Enter, and Press Tab key 
commands.
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Tutorial
Select to open the tutorial.  

The tutorial introduces you to Dragon NaturallySpeaking, guiding you 
through the fundamentals of using the product.

It has two main parts:

• Getting Started with Dictation
• Working in Applications and Advanced Topics

Getting Started with Dictation

Click the Menu button in the Getting Started with Dictation part of the 
tutorial to see a list of covered topics:

• Learning about the DragonBar
• Turning the microphone on and off
• Using Natural Punctuation
• Beginning to dictate
• Starting a new paragraph, line, or tab
• Using Commands
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• Selecting Words
• Select and Quick Correct
• Select and Spell
• Select-and-SayTM

• Deleting Words
• Deleting Words and Characters
• Inserting Words
• Formatting Words

After you listen to the narration for a particular topic:

• Click Continue to proceed to the next topic.
• Click the Pause button to temporarily pause the tutorial; later, click the 

Play button to resume.
• Click Stop to start the recording from the beginning of the topic.
• Click the Back button to return to the previous topic.
• Click the Quit button when you are finished.

When you want to try the feature after the tutorial demonstrates it, click the 
Try It button. The tutorial opens DragonPad with instructions for how to 
try the feature to the left.

Working in Applications and Advanced Topics

Click the Menu button in the Working in Applications and Advanced 
Topics tutorial to see the list of advanced topics:

• Boosting productivity with custom commands
• Using Dragon NaturallySpeaking with E-mail
• Using portable recorders
• Using Internet Explorer
• Dictating in non-standard Window

Check for Updates
Select to go to the Update Service for Dragon NaturallySpeaking where 
you can download any available updates to your version of the application.
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NaturallySpeaking on the Web
Select to go to the Dragon NaturallySpeaking Web page on the Nuance 
Communications Web site where you can obtain additional information 
about Dragon NaturallySpeaking. 

About NaturallySpeaking
Select to see the version information for your installed version of Dragon 
NaturallySpeaking.
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Distributing Vocabularies 
and Commands Across 

Multiple Users

Objectives 
In this chapter, you will learn:

• About the Data Distribution Tool

• Creating a data distribution directory

• Using the Data Distribution Tool

• Distributing custom words

• Distributing custom commands

• Distributing customized vocabularies
215



216

Dragon® NaturallySpeaking® Medical Edition Provider and Administrator Courseware Guide
About Data Distribution Tool

You use the Dragon NaturallySpeaking Data Distribution Tool when you want 
to make new words, customized vocabularies, or new commands available to 
all users on a particular Dragon NaturallySpeaking installation. 

You can use this tool to work locally or across a network.

Creating a Data Distribution 
Directory

When you create a data distribution directory where you place word lists and 
commands to be distributed to multiple users, Dragon NaturallySpeaking 
automatically imports those words and commands into the user files of a 
provider no matter where the provider dictates as soon as that provider opens 
that user file.

Note: After a default installation, custom words for existing Dragon 
NaturallySpeaking users are located in C:\Documents and Settings\All 
Users\Application Data\Nuance\NaturallySpeaking9\custom\<language>

To create a data distribution directory in a location other than the 
default:

1. (Optional) Create a directory on the network and give all providers who 
are dictating with Dragon NaturallySpeaking access to the directory. 
Set the permissions so that providers who dictate can read it and only 
administrators can write to the directory.

2. If Dragon NaturallySpeaking is running, on the DragonBar, select 
Tools > Administrative Settings. The Administrative Settings dialog 
box opens and you can continue with Step 3.
OR
If Dragon NaturallySpeaking is not running, select Start > Run. The 
Run dialog box opens.
Type the following command line in the Open text box:
C:\Program Files\Nuance\NaturallySpeaking9\Program\natspeak.exe  
/SetDefaultAdministrativeOptions

Note: Be sure to put a space between “natspeak.exe” and the slash mark 
that precedes the name of the option. 

3. Click OK.
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4. When the Open User dialog box appears, click the Miscellaneous tab.

5. (Optional) In the Data Distribution location text box, to set the 
location where Dragon NaturallySpeaking stores customized words 
and commands, usually on a central machine, click Change and 
browse to the new location. 
By default the location is C:\Documents and Settings\All 
Users\Application Data\Nuance 
\NaturallySpeaking9\custom\<language>. If you have changed the 
location and then want to restore it to the default, click the Use Default 
button.

6. Click Apply to save the changes.
7. Click OK to close the dialog box.
8. Repeat steps 2 through 6 for each workstation that should share the 

distributed words or commands.
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Using the Data Distribution Tool

You run the Data Distribution Tool on each Dragon NaturallySpeaking 
installation where you want to make new words, commands, or vocabularies 
available to your Dragon NaturallySpeaking users. 

You carry out several actions in the next three major sections:

• Distributing added words across vocabularies
• Distributing and removing shared commands
• Distributing and removing customized vocabularies for use as base 

vocabularies

Note: Both mapped drives and UNC paths are supported.

Using Data Distribution Tool to 
Distribute Custom Words

If you are adding a set of custom words to a vocabulary, you can add the same 
words on multiple Dragon NaturallySpeaking installations by using the Data 
Distribution Tool.

To add a set of custom words (for example, a list of new drug names) to 
the data distribution directory (to be distributed to all machines on the 
network):

1. Prepare a list of custom words to add.
2. Start the Data Distribution Tool.
3. Make the appropriate selections in the tool to add the words to the data 

distribution directory.

Preparing List of Custom Words
To prepare a list of custom words to add:

Prepare the text file of words to add in one of two ways:

• Create a text (.txt) file with each word, phrase, or name you want to 
add to the vocabulary on a separate line. Double check the spellings. 
To add a multiple-word phrase, such as neurocardiogenic syncope, 
enter it on one line. 
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To include a spoken form for a word, append the word with a backslash 
(\), then the spoken form. For example, to have electrocardiogram 
transcribed when you say “EKG” type electrocardiogram\EKG. 
For more detail, see “Adding Words from Lists” on page 113.

• Working with an existing installation of Dragon NaturallySpeaking, 
create the words and export the words to a .txt file. For information on 
exporting words, refer to “Exporting Custom Words to a File” on 
page 117.

Adding Words
After you have a text file containing the words to add, you start the 
Data Distribution Tool:

1. Select Start > All Programs > Dragon NaturallySpeaking9.5 > 
Dragon NaturallySpeaking Tools > Data Distribution Tool.
The first screen of the Data Distribution Tool wizard displays.

2. Select Add or remove words to share across vocabularies. If you 
have already set up the data distribution directory, proceed to step 5.

Notes: 
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• When you choose Add or remove, you can add or remove word lists 
to or from the data distribution directory, but previously distributed 
words remain in the user files that contain them, even after those 
word lists are removed from the data distribution directory. Only 
vocabularies created later do not contain the removed words. 

• Skip steps 3 and 4 if you have already set up the data distribution 
directory on the machine where you are carrying out this process. 
You might want to click the Advanced button (in step 3), however, 
just to verify that the location has been set correctly.

3. Click the Advanced button to open the Advanced Settings dialog box 
and verify the location where the local installation of Dragon 
NaturallySpeaking stores customized words. 

The default location is C:\Documents and Settings\All 
Users\Application Data\Nuance\ NaturallySpeaking9\ 
custom\<language>.
In this dialog box, you can change the data distribution directory or set 
it if you have not already set it. If you set the data distribution directory 
earlier and have not changed it here, click Cancel.

4. Otherwise, click OK to save the new/changed data distribution 
directory and close the Advanced Settings dialog box.
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5. Click Next in the wizard.

6. In the drop-down list, for language select English (Default) and click 
Next.
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7. Click the Import button, to open the Open Custom Words dialog box 
and browse to the appropriate directory, and select the text files 
containing the custom words you want to add. 
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8. Click Open and the file name appears in the Files Containing New 
list.

9. You can add as many text files as you have to the list by repeating steps 
7 and 8.

10. (Optional) To view a particular file that you added to the list, select the 
file name and click the View button. You can remove a selected file 
from the list by clicking the Remove button or remove all files from the 
list by clicking the Remove All button. The View and Remove buttons 
are grayed out until you select a file in the list.
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11. Click Next to continue. The Data Distribution Tool displays a log of all 
operations performed. 

12. Click Finish to re-start the Data Distribution Tool or click Cancel to 
exit.
The text file(s) are copied to the following directory:
C:\Documents and Settings\All Users\Application 
Data\Nuance\NaturallySpeaking\custom\<language>
The words are then imported into each provider’s user file when the 
provider opens that user file to dictate.
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Using Data Distribution Tool to 
Distribute Custom Commands

Custom commands are voice commands that you can create and modify to 
enter text, insert graphics, navigate within an application, or activate menus 
and keystrokes in any application. You can create these commands in 
MyCommands Editor or modify them using the Command Browser.

Using the Data Distribution Tool you can copy a set of custom commands you 
have created to the data distribution directory.

Creating and Exporting the Commands
Before you can give multiple users access to custom commands created for 
a single user, you must first create those commands, then export them to a 
file that you place in the data distribution directory.

To create custom commands and export them to a file: 

1. Create the custom commands in Dragon NaturallySpeaking as outlined 
in Chapter 8 on “Creating Custom Commands” starting on page 139.

2. Make sure the user you want to export the commands from is open. On 
the DragonBar, select Tools > Command Browser.

3. Click Manage mode in the left task pane. In the Group drop-down list, 
select the name of a group. For instance, if you have a group of 
commands you created for medical reports, you might select Medical 
Commands from the list.

4. Click the plus sign next to the group name of commands you want to 
export to expand the list.

5. Check each command you want to export or place a check mark next to 
the group name to select all commands under that group.

6. Click Export in the left task pane. When the Export Commands 
dialog box opens, browse to the directory where you want to save as 
and save them to a .dat file and click Save to return to the Command 
Browser dialog box. Click the X button in the upper right corner of the 
Command Browser to exit.
Either share the directory where the .dat file is located or copy the .dat 
file to a shared location accessible to all the computers where you want 
to add the commands. You can also copy from a full, local, or relative 
path to the source file, even from a removable medium, such as a CD-
ROM, ZIP drive, or external hard drive.
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Adding Custom Commands
Once you have a .dat file containing exported commands, you can make 
them available to other users.

To add the custom commands to the data distribution directory:

1. Select Start > All Programs > NaturallySpeaking 9.5 > Dragon 
NaturallySpeaking Tools > Data Distribution Tool.
The first screen of the Data Distribution Tool wizard displays. 

2. Select Add or remove shared commands and click Next.
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3. In the drop-down box for language, select English (Default) and click 
Next.

4. Click the Import button and when the Open Commands dialog box 
opens, select the .dat files containing the custom commands you want 
to add and click Open.
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5. The list of the commands in the file appears under New shared.

6. (Optional) Once you click on a command name in the list, you can 
remove it from the list by clicking the Remove button. Or you can 
remove them all from the list by clicking the Remove All button.

Note: The existing shared commands section provides a list of all 
commands previously imported and shared.

Caution: If you distribute a command with the same name as an existing 
command, the command you distribute will overwrite the existing copy of 
the command without prompting the provider to confirm it is okay.

7. Click Next to continue. 
8. The Data Distribution Tool displays a log of all operations it 

performed. 
9. Click Finish to re-start the Data Distribution Tool or click Cancel to 

exit.
The file(s) of new commands are copied to the following directory:

C:\Documents and Settings\All Users\Application 
Data\Nuance\NaturallySpeaking 9\custom\<language>

The new commands are then imported into each provider’s user file when 
the provider opens that user file to dictate.
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Removing Custom Commands
To remove shared commands:

1. Select Start > All Programs > Dragon NaturallySpeaking 9.5 > 
Dragon NaturallySpeaking Tools > Data Distribution Tool.
The first screen of the Data Distribution Tool wizard displays. 

2. Select Add or remove shared commands and click Next.
3. In the drop-down box for language, select English (Default) and click 

Next.
You see a list of the commands names that have been shared under 
Existing shared.

4. In the Existing shared list, select the name of the command to remove 
and click Remove. When a message appears, Are you sure you want 
to remove the selected commands? Click Yes.

5. Once all the commands are removed, click Next. The Data Distribution 
Tool displays a log of all operations it performed. 

6. Click Finish to re-start the Data Distribution Tool or click Cancel to 
exit.
The modified file(s) of commands are copied to the directory:
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C:\Documents and Settings\All Users\Application 
Data\Nuance\NaturallySpeaking9\custom\<language>

The removed commands are not removed from any user files where they 
have already been added, but the revised set of commands (minus those 
removed) is now imported into each provider’s user file when the provider 
opens that user file to dictate.

Using Data Distribution Tool to Add 
Customized Vocabularies

A customized vocabulary contains not only words and phrases that you have 
added with the Vocabulary Editor, but also a language model that you built 
with Voctool or with the Add Words from Documents feature. For example, 
you might create a customized vocabulary for a medical specialty that is not 
covered by one of the built-in vocabularies.

Using the Data Distribution Tool, you can make a customized vocabulary 
available to all users by adding it as a base vocabulary to a machine. A base 
vocabulary is available to all users on the machine where it is installed. It 
appears in the list of available vocabularies to choose from when you create a 
new user file, and also when you add a new vocabulary to an existing user file 
in the Manage Vocabularies dialog box.

Note: You must run the Data Distribution Tool on every machine where you 
want to install the custom vocabulary as a base vocabulary.
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Adding Customized Vocabulary
After you have copied the customized vocabulary to the shared 
location, you start the Data Distribution Tool:

1. Before you add the customized vocabulary, copy the vocabularies to a 
shared location accessible to all the computers where you want to add 
the vocabulary. Find vocabularies in the C:\Documents and 
Settings\All Users\Application Data\Nuance\NaturallySpeaking 
9\Users\<user_name>\current\<medical specialty>\ directory. Copy 
all the files in that directory.

2. Select Start > All Programs > Dragon NaturallySpeaking 9.5 > 
Dragon NaturallySpeaking Tools > Data Distribution Tool.
The first screen of the Data Distribution Tool wizard displays.

3. In the first dialog box of the wizard, select Add or remove base 
vocabularies and click Next. In the next dialog box of the wizard, you 
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see a list of vocabularies under Existing base vocabularies, including 
their IDs and names.

4. To add a Base Vocabulary, click Add. The Add Base Vocabulary 
dialog box displays.

5. In the Add Base Vocabulary dialog box: 
 a. Name—Assign the vocabulary a unique name. The name should 

describe the content of the vocabulary. 
 b. Copy from—Click Browse to open the Browse For Folder and 

select the location of the .voc file you plan to distribute to multiple 
machines. Click OK. 
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 c. New ID—Give the vocabulary an unique numeric ID. Use a value 
between 9000 and 9999.

6. Click OK when you are done. When you see the base vocabularies list 
again, the ID name and path of the vocabulary you added appears in the 
list under New base.

7. Click Next. The Data Distribution Tool displays a log of all operations 
performed.
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8. Click Finish to re-start the Data Distribution Tool or click Cancel to 
exit. 

You can use the new base vocabularies immediately. For instance, you can 
now create a new user and select your new base vocabulary in the 
Vocabulary drop-down list of the New User Wizard. You can also add 
the new vocabulary to an existing user.

Removing a Base Vocabulary
Instead of adding a base vocabulary, you can delete one:

1. Select Start > All Programs > Dragon NaturallySpeaking 9.5 > 
Dragon NaturallySpeaking Tools > Data Distribution Tool. The first 
screen of the Data Distribution Tool wizard displays.

2. In the first dialog box of the wizard, select Add or remove base 
vocabularies and click Next. In the next dialog box of the wizard, you 
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see a list of vocabularies under Existing base vocabularies, including 
their IDs and names.

3. Scroll through the list of existing base vocabularies and select the 
vocabulary to delete.

4. Click Remove and then click Next. The Data Distribution Tool 
displays a confirmation message after the vocabulary has been deleted.

Note: You cannot delete a vocabulary that comes with the product.  An 
error similar to this appears: Error: The vocabulary 1032 could not be 
deleted. 

5. Click Yes, to confirm the deletion.
6. Click Next. The Data Distribution Tool displays a log of all operations 

performed.
7. Click Finish to re-start the Data Distribution Tool or click Cancel to 

exit.
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Chapter 11

Maintaining Installations 

Objectives 
In this chapter, you will learn:

• Running the Acoustic and Language Model 
Optimizer 

• Scheduling the Acoustic and Language Model 
Optimizer

• Exporting and importing user files

• Locating Dragon.log file

• Creating a usability log 

• Locating the Dragon NaturallySpeaking 
knowledge base

• Locating the Dragon NaturallySpeaking 
hardware compatibility list
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About the Acoustic and Language 
Model Optimizer and Scheduler

You run Acoustic and Language Model Optimizer Scheduler to carry out 
the following tasks:

• Choose to optimize the acoustic files for the provider
• Choose to optimize the language model for the provider
• Schedule one or both types of optimization to occur on a particular day or 

time at particular intervals
• Enable or disable the scheduled optimizations

Running the Acoustic and 
Language Model Optimizer on 
Non-Roaming Users

An open local roaming user cannot run the optimizer tools on user files. Only 
you, as administrator, can run the Acoustic and Language Model Optimizer 
or the Acoustic and Language Model Optimizer Scheduler tools.

Notes: 

• You must have Windows Administrator privileges (at the operating 
system level) on the machine where you are running the Scheduler 
for the Acoustic and Language Model Optimizer. 

• If you want to optimize a Roaming User on the machine where you 
are running the Acoustic and Language Model Optimizer, disable 
roaming and browse to the Master Roaming User file location as if 
it were local.

As system administrator, you are responsible for running the Acoustic and 
Language Model Optimizer on the network location of the Master Roaming 
Users. You can install Dragon NaturallySpeaking on the machine where the 
Master Roaming User files are located or on any machine that has network 
access to the Master Roaming User files, then run the Scheduler for the 
Acoustic and Language Model Optimizer. Later, any optimizations that 
result from running these tools are copied to the Local Roaming User when 
Dragon NaturallySpeaking synchronizes it with the Master Roaming User. 
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You can run the Acoustic and Language Model Optimizer from the 
Windows Start menu (Select Start > All Programs > Dragon 
NaturallySpeaking 9.5 > Dragon NaturallySpeaking Tools > Acoustic and 
Language Model Optimizer Scheduler) without opening a user file, or you 
can run it from the DragonBar > Tools menu with a user file open as indicated 
here. 

To run the acoustic and language model optimizers on non-roaming 
users:

1. On the DragonBar, select NaturallySpeaking > Open User.
2. In the Open User dialog box, select a user to run the optimization on 

and click Open.
3. On the DragonBar, select Tools > Accuracy Center. The Accuracy 

Center dialog box opens.
4. Click Run the Acoustic and Language Model Optimizer. The 

Acoustic and Language Model Optimizer dialog box opens. 

Note: If you have no new data the following message appears, “There is no 
new data in the acoustic archive. Acoustic Optimizer does not need to be 
rerun.” Click OK. Then the Acoustic and Language Model Optimizer 
opens with the “Perform Acoustic Optimization” option grayed out.

5. Check the types of optimization you want to perform, Perform 
Acoustic Optimization (to optimize the acoustic files of the user), 
Perform Language Model Optimization (to optimize the language 
model of the user), or both.

6. Click Go to start the process. The process may take some time to 
complete.

7. When the process completes, you receive a message notifying you that 
it has completed. Click Done. When asked if you would like to save 
your user files click Yes to return to the Accuracy Center dialog box. 

8. Click Exit in the Accuracy Center dialog box.
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Running the Acoustic and 
Language Model Optimizer 
Scheduler on Roaming Users

To run the Acoustic and Language Model Optimizer on Roaming 
Users:

1. Be sure that a copy of Dragon NaturallySpeaking is installed on the 
computer where you plan to run the Acoustic and Language Model 
Optimizer.

2. Select Start > All Programs > Dragon NaturallySpeaking 9.5 > 
Dragon NaturallySpeaking Tools > Acoustic and Language Model 
Optimizer Scheduler. 
The Acoustic and Language Model Optimizer Scheduler dialog box 
opens.

3. To access the master directory of the Roaming Users you want to 
optimize, in the Acoustic and Language Model Optimizer Scheduler 
dialog box, select File > Set User Directory. The Set a Directory 
Containing User Files dialog box opens.

<NuanceHospital Users>
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4. On the Set a Directory Containing User Files dialog box, either enter 
the path to the directory or click the Browse button and browse to the 
location of the Master Roaming Users, then click OK. If the users you 
want to optimize are located in multiple directories, you can later repeat 
the steps outlined here and change this directory to locate the additional 
users.

5. In the tree of users, select the user you want to optimize. Notice that if 
you expand that user in the tree, you see one or more dictation sources 
under the Acoustic Optimization tasks in the tree. You also see the 
vocabulary of the user under the Language Model Optimization 
tasks. 

Note: To expand the user list, click Option > Expand/Collapse Users lists.

OR
Select File > New Task. The Windows user name and password 
dialog box opens. To set a schedule for running the Acoustic and 
Language Model Optimizer, either double-click on the dictation 
source or the language model under that user. 

Before you can proceed, enter your Windows user name and password. 
If you are logged in to a domain, you must insert the domain name in 
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front of your user name; for example, HospitalDB\RSessions for the 
HospitalDB domain.

Note: You can return later to clear your password by selecting 
Options>Clear Windows Password Information.

6. Click OK. The Select Frequency dialog box opens. 

7. Under Optimization, select Perform Acoustic Optimization, 
Perform Language Model Optimization, or both.

8. Under User Information, you can either select another user from the 
User Name drop-down list or, to select multiple users, click the 
Multiple Users button; the Select Users dialog box opens.
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 a. Use the Add> and <Remove buttons to put the users you want to 
run optimization on in the Selected users in this task list to the 
right. Or you can click Add All >> or << Remove All to add or 
remove all users from the list. 

 b. You can also move the user up and down in the list by selecting a 
name and clicking the Move Up or Move Down button. When you 
are satisfied with the list, click OK to proceed.

Note: If you have selected multiple users to run the acoustic and language 
optimization for in the Select Users dialog box, when you return to the 
Select Frequency dialog box, the User Information section is grayed out. 
Skip Step 9 and Step 10.

9. In the Dictation Source text box, select a dictation source from the 
drop-down list.

10. In the Vocabulary text box, select a vocabulary from the drop-down 
list.

11. Under Select Frequency and Start Date & Time, select how often 
and at what time you want the optimization to run, as well as the first 
date it should run.

12. At the bottom of the dialog, click the Enabled (schedule task runs at 
specified time) check box to enable the optimization.

13. Click Apply to apply the changes.
14. Click OK to close the Select Frequency dialog box. The Acoustic and 

Language Model Optimizer Scheduler dialog box displays a list of 
the events scheduled in the right pane of its dialog box. 

You can create more than one optimization schedule for a single user. 
When you do, both optimization events appear in the schedule list.

15. Click Files>Exit to close the acoustic and language model optimizer 
scheduler

Removing One or More Schedules
To remove one or more scheduled optimizations from the scheduler:

1. Select the schedule you want to remove. You can select multiple 
schedules by holding the CTRL key while clicking a schedule.
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2. Press the Delete key on your keyboard or select Options > Delete 
Selected Tasks on the toolbar.

3. Click OK in the confirmation prompt dialog box that appears.
OR

4. To remove all the scheduled optimization event in the Acoustic and 
Language Model Optimizer Scheduler select Options > Delete 
Displayed Tasks.

5. Click OK in the confirmation prompt dialog box that appears.

Notes: 

• You can optimize multiple users on the same schedule by selecting 
all the users you want to share a single schedule on the Select Users 
dialog box.
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Exporting and Importing User Files

You can export user files on one machine and import them for use on another.

Note: When you export a user to a new location, any custom words added 
to a Local Roaming User do not accompany the user files unless you first 
run Add Words from Document wizard in the Accuracy Center. 

Exporting User Files
To export users from Dragon NaturallySpeaking:

1. On the DragonBar, select NaturallySpeaking > Manage Users. The 
Manage Users dialog box opens.

2. Select the user in the list that you want to export.
3. Click the Advanced button and select Export from the menu that 

appears.
4. When the Browse For Folder dialog box opens, navigate to the folder 

where you want to store the exported user or create a new folder by 
clicking the Make New Folder button.

5. Click OK. A dialog box opens displaying a message indicating the 
export was successful; click OK.

6. Repeat steps 2 through 5 for each set of user files you want to export.
7. Click Close to close the Manage Users dialog box.
8. In the operating system, navigate to the directory where you exported 

the users. In that directory you find a separate folder for each exported 
user, labeled with the user name.

Importing User Files
To import users into Dragon NaturallySpeaking that you previously 
exported from it (usually on a different machine):

1. On the DragonBar, select NaturallySpeaking > Manage Users. The 
Manage Users dialog box opens.

2. Click the Advanced button and select Import from the menu.
3. When the Browse For Folder dialog box opens, navigate to the folder 

to retrieve a set of exported users files from.
4. Select the folder in that directory that has the name of the user to import 

and click OK.
If the user already exists a User already exists dialog box opens and 
asks you to choose how to proceed: Overwrite the existing user or 
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Import the user with an alternate name. If you choose to import the 
user and assign it another name, enter the name in the text box provided 
and click OK.

5. Repeat steps 2 through 5 for each user whose user files you want to 
import.

6. Click Close to close the Manage Users dialog box.

Locating Dragon.log File

The Dragon.log file contains information that can help diagnose problems that 
you might encounter using Dragon NaturallySpeaking. You retrieve this file 
when Dragon NaturallySpeaking displays an error message.

To locate the Dragon.log file:

1. Close the open user. On the DragonBar, select NaturallySpeaking> 
Close User.

2. (Optional) To exit Dragon NaturallySpeaking, on the DragonBar, 
select NaturallySpeaking > Exit. 

3. To locate this file, select Start > All Programs > Dragon 
NaturallySpeaking 9.5 > Show Dragon Log. A window opens 
showing the contents of the folder, including a file named Dragon.log 
that you double-click to open.
Or navigate to C:\Documents and Settings\<username>\ 
Application Data\Nuance\NaturallySpeaking9 and double-click 
Dragon.log to open the file. 

4. To save the error log (Dragon.log) to a safe location: select File>Save 
As. When the Save As dialog box opens, give the file a name and click 
Save. 
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If the error message does not provide enough information, search the 
Nuance Knowledge Base as explained under “Locating Dragon 
NaturallySpeaking Knowledge Base” on page 248.

Creating a Usability Log

You can set up Dragon NaturallySpeaking to create a usability log that logs all 
menu commands, toolbar buttons, and voice commands that you using during a 
dictation session.

To set up a usability log:

1. With a user open, on the DragonBar, select Tools > Options.
2. Click the Data tab.
3. Click the Advanced button. The Advanced dialog box opens. 

4. Check the Create usability log check box and click OK to return to the 
Data tab.

5. Click Apply.
6. Click OK, to close the Data tab of the Options dialog box.
7. Later, you can find the log under C:\Documents and Settings\ 

<username>\Application Data\Nuance\NaturallySpeaking 9.
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Locating Dragon 
NaturallySpeaking Knowledge 
Base

Solutions to known problems with Dragon NaturallySpeaking are provided at 
the Nuance Knowledge Base, located at http://knowledgebase.Nuance.com/.

If you have problems using Dragon NaturallySpeaking with Microsoft Word 
on Windows XP (for example if the program freezes or commands stop 
working in a Microsoft Office XP application), it may be that the Microsoft 
Word XP’s built-in speech recognition is interfering with Dragon 
NaturallySpeaking. 

To locate and use the Dragon NaturallySpeaking Knowledge Database:

1. Navigate to http://knowledgebase.Nuance.com/.
2. In the product drop-down list, select Dragon NaturallySpeaking and 

click Continue.
3. In the Dragon NaturallySpeaking TechNotes-Basic search section 

you can search using:
• Product version — Select the version you are using.
• Search Criteria — Type the words that would be expected to be 

found in the pages that contain the answer. Do not use words such as 
how, why, the, in, or on.

• Using: 
– Any of the words — Show pages that contain any of the words
– All of the words — Show pages that contain all of the words.
– Exact phrase entered — Show pages that contain all of the 

words in the exact order typed.
4. Click Search, to begin the search.

Locating Dragon NaturallySpeaking 
Hardware Compatibility List

You can find a list of headsets and microphones compatible with Dragon 
NaturallySpeaking at the Nuance Communications web site.

http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
http://knowledgebase.Nuance.com/
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To find the hardware compatibility list:

1. Navigate to http://support.nuance.com/compatibility/default.asp
2. At the site, click on the product drop-down list and select Dragon 

NaturallySpeaking.
3. Then click Continue to proceed.

A list of compatible hardware displays, along with a model, 
manufacturer, and accuracy scale Dragon Score.
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